none
Almost dead! An unknown network error has occurred during PC Restore RRS feed

  • Question

  • I built a WHS when it was first released back in 2003 my relationship has since been close and harmonious, until now.  I recently  realigned the disk drives in the WHS, by adding extra storage via the PCI SATA card, running admin tasks such as check disks etc. Most  of the disks have been added over the decade it’s been running and there has not been a hint of problems.  Media and shared files function fine. 

     

    I decided to strip back my media centre as it had become cluttered over the years and restore the ‘clean’ backup I have on the server. Unfortunately I found that shortly into the restore I got the error: An unknown network error has occurred. And after many different attempts it still occurs, I have tried:

     

    ·         Client restore from another PC, Client restore direct from server bypassing the router, Client restore wizard running on the Server to the HDD via USB, Check-disk both computers and all drives, re formatted the disks, tried different disks, pretty much all variations.

     

    I decided to see if I could at least restore a different backup, and I was greeted with I/O Error. Oh Dear! I trolled most sites relating to these errors but none of the remedies seem to work. I fear the worst! That my backups have become corrupt? What can I do, all my PC run to the server, would reinstalling WHS help?

    Sunday, November 1, 2015 12:13 PM

All replies

  • WHS was definitively not released in 2003.

    IO error on the server can happen, if the database gets corrupt. This can happen due to a crash of the OS or due to hardware issues (unreadable sectors on a disk or a failed drive).

    Did you run ClientRestoreWizard as described in How to restore a client PC, if the network connection does not work in the CD based restore environment?

    Could you mount the volume from the backup?

    Are there any related errors in the event logs of the server?

    There have been a few cases, in which a tool named whsdbdatadump did help to access data direct from the WHS Backup database. I might still have a copy somewhere around.

    Best greetings from Germany
    Olaf

    Wednesday, November 18, 2015 3:02 PM
    Moderator
  • If you're attempting a bare metal restore and it's failing with "unknown network error" you should adjust your DHCP lease time out. I've found that some routers have a very short lease time which results in this failure. I don't think the bare metal client handles DHCP lease times correctly. If you can adjust your DHCP lease time on the router to 1 day (1440 minutes) you should be able to complete a bare metal restore.
    Thursday, November 19, 2015 4:08 PM
  • Olaf /w3w,

    Thank you very much for your replies;

    Olaf, you are right it certainly wasn’t 2003, more like 2008. Yes, I have tried client restore from other PCs, I even had an attempt straight from the server itself, but still with the same error, roughly at the same time during the restore process.

    w3w, I haven’t tried the DHP remedy because I thought that that if I used client restore it wouldn’t matter as it wasn’t going through a router, instead it runs through a Netgear Gb switch?

    Also,

    • BDBB, has had limited results, as I don’t seem to have all the backups?

    • The problem seems to be with certain backups as I have successfully restored to an earlier backup, but would mean I lose lots of data. Does this point to corrupt  data?

    • The only thing I have yet to try, which has been mentioned in pervious threads is; deleting my client backups from the folder and then pasting a backed up copy back into it

    Thank you for your help,

    Ian

    Friday, November 20, 2015 5:49 PM
  • Olaf,

    I reviewed and implemented your suggested steps in the thread "How to restore a client PC, if the network connection does not work in the CD based restore environment" but I cannot get the restore to complete.  Every time, regardless of what I try, during the restore (after choosing which volumes to restore where) during the phase where it is trying to estimate the length of time it will take to restore, it hangs up and then ends with an error message "an unknown network error has occurred during a full system restore. 

    I cannot use the "view log" button and clicking it doesn't display anything.  I've tried to locate the log file but cannot.

    I tried some of the hacks I have read about (leaving the diskmgmt.msc open during restore, and changing the router's DHCP lease expriation) but to no avail.

    I'm pretty sure that the error in NOT something to do with the network as I'm fully connected to the network and can browse the server's shared files during the restore.

    Any ideas on what I can do to get a restore to work?

    Best regards,
    Carl

    Sunday, January 28, 2018 10:12 AM