locked
WHS Console -- can't get it to work RRS feed

  • Question

  • I just bought an HP MediaSmart server, model EX495.  I am running Windows 7, my router is a D-link DIR-655 and I have a couple of d-link gigabit switches in the LAN.

    When I first started up and installed the server, WHS console worked fine, but shortly after, I could not log on.  I get an error message that is several sentences long starting with  "this computer cannot connect to your home server."  I can see the shares on my network and can access the server and music files no problem, but the console will not let me log in. Sonos can find shared folder and I can play all files.

    I have tried running discover.exe from the c:program\windows home server directory and it runs, checks off the two back up and the connection functions, but I get the message that "verifying port forwarding for your router failed", then the setup says I am connected but I can't get the console to run.

    My router is set up at address 192.168.0.1 and if I change it to 192.168.0.2,  I can then get the console to run, but I lose my connection to the internet.  If I repair the connection, the console then loses connectivity to the server, and I get the "port forwarding for your router failed" error again.  I can see the icon in the tray and still connect to the share files with the different router address.  The same thing happens if I switch the router address back to its original setting.

    Any suggestions for resolving this are really appreciated.  Thanks.

     

    ChrisG

    Friday, April 23, 2010 6:58 PM

Answers

  • I fixed the problem by doing a hard reset on my router.  Now I have to fix remote access. 
    Saturday, April 24, 2010 2:34 AM
  • Get an inexpensive gigabit switch (8-16 ports, depending on your network), plug that in to your router, and plug all your wired devices into the switch. You'll likely get much better reliability, given that your router stopped passing some traffic for reasons as yet unknown.

    As for remote access:

    • Give your server a static IP address, either through a DHCP reservation in your router or manual configuration of TCP/IP for your server's network adapter. If you do it manually, rather than through a reservation, make sure it's in the same range as the rest of your network, with the same net mask, DNS servers, etc. as other computers on your network.
    • In your router's admin pages turn off UPnP.
    • In your router's admin pages, manually configure port forwarding for ports 80, 443, and 4125 to the static or reserved IP address you set for your server.
    • In the console, turn off remote access, turn it back on, and reconfigure it.
    Remember to test from somewhere other than home, like a local library, Starbucks, etc., since a lot of consumer routers don't handle "loopback" connections correctly.
    I'm not on the WHS team, I just post a lot. :)

    Thanks Ken, that did the trick :)
    • Marked as answer by ChrisG59 Sunday, April 25, 2010 7:11 PM
    Saturday, April 24, 2010 8:23 PM

All replies

  • I just bought an HP MediaSmart server, model EX495.  I am running Windows 7, my router is a D-link DIR-655 and I have a couple of d-link gigabit switches in the LAN.

    When I first started up and installed the server, WHS console worked fine, but shortly after, I could not log on.  I get an error message that is several sentences long starting with  "this computer cannot connect to your home server."  I can see the shares on my network and can access the server and music files no problem, but the console will not let me log in. Sonos can find shared folder and I can play all files.

    I have tried running discover.exe from the c:program\windows home server directory and it runs, checks off the two back up and the connection functions, but I get the message that "verifying port forwarding for your router failed", then the setup says I am connected but I can't get the console to run.

    My router is set up at address 192.168.0.1 and if I change it to 192.168.0.2,  I can then get the console to run, but I lose my connection to the internet.  If I repair the connection, the console then loses connectivity to the server, and I get the "port forwarding for your router failed" error again.  I can see the icon in the tray and still connect to the share files with the different router address.  The same thing happens if I switch the router address back to its original setting.

    Any suggestions for resolving this are really appreciated.  Thanks.

     

    ChrisG

    Can you successfully ping your server, both by name and by IP address?
    Friday, April 23, 2010 8:47 PM
    Moderator
  • I just bought an HP MediaSmart server, model EX495.  I am running Windows 7, my router is a D-link DIR-655 and I have a couple of d-link gigabit switches in the LAN.

    When I first started up and installed the server, WHS console worked fine, but shortly after, I could not log on.  I get an error message that is several sentences long starting with  "this computer cannot connect to your home server."  I can see the shares on my network and can access the server and music files no problem, but the console will not let me log in. Sonos can find shared folder and I can play all files.

    I have tried running discover.exe from the c:program\windows home server directory and it runs, checks off the two back up and the connection functions, but I get the message that "verifying port forwarding for your router failed", then the setup says I am connected but I can't get the console to run.

    My router is set up at address 192.168.0.1 and if I change it to 192.168.0.2,  I can then get the console to run, but I lose my connection to the internet.  If I repair the connection, the console then loses connectivity to the server, and I get the "port forwarding for your router failed" error again.  I can see the icon in the tray and still connect to the share files with the different router address.  The same thing happens if I switch the router address back to its original setting.

    Any suggestions for resolving this are really appreciated.  Thanks.

     

    ChrisG

    Can you successfully ping your server, both by name and by IP address?

    Yes, w/ no errors


    Saturday, April 24, 2010 1:20 AM
  • Yes to both w/ no errors

     

    ChrisG

    Saturday, April 24, 2010 1:24 AM
  • I fixed the problem by doing a hard reset on my router.  Now I have to fix remote access. 
    Saturday, April 24, 2010 2:34 AM
  • Get an inexpensive gigabit switch (8-16 ports, depending on your network), plug that in to your router, and plug all your wired devices into the switch. You'll likely get much better reliability, given that your router stopped passing some traffic for reasons as yet unknown.

    As for remote access:

    • Give your server a static IP address, either through a DHCP reservation in your router or manual configuration of TCP/IP for your server's network adapter. If you do it manually, rather than through a reservation, make sure it's in the same range as the rest of your network, with the same net mask, DNS servers, etc. as other computers on your network.
    • In your router's admin pages turn off UPnP.
    • In your router's admin pages, manually configure port forwarding for ports 80, 443, and 4125 to the static or reserved IP address you set for your server.
    • In the console, turn off remote access, turn it back on, and reconfigure it.
    Remember to test from somewhere other than home, like a local library, Starbucks, etc., since a lot of consumer routers don't handle "loopback" connections correctly.
    I'm not on the WHS team, I just post a lot. :)
    Saturday, April 24, 2010 1:52 PM
    Moderator
  • Get an inexpensive gigabit switch (8-16 ports, depending on your network), plug that in to your router, and plug all your wired devices into the switch. You'll likely get much better reliability, given that your router stopped passing some traffic for reasons as yet unknown.

    As for remote access:

    • Give your server a static IP address, either through a DHCP reservation in your router or manual configuration of TCP/IP for your server's network adapter. If you do it manually, rather than through a reservation, make sure it's in the same range as the rest of your network, with the same net mask, DNS servers, etc. as other computers on your network.
    • In your router's admin pages turn off UPnP.
    • In your router's admin pages, manually configure port forwarding for ports 80, 443, and 4125 to the static or reserved IP address you set for your server.
    • In the console, turn off remote access, turn it back on, and reconfigure it.
    Remember to test from somewhere other than home, like a local library, Starbucks, etc., since a lot of consumer routers don't handle "loopback" connections correctly.
    I'm not on the WHS team, I just post a lot. :)

    Thanks Ken, that did the trick :)
    • Marked as answer by ChrisG59 Sunday, April 25, 2010 7:11 PM
    Saturday, April 24, 2010 8:23 PM