locked
Communicator could not connect securely to Edge server RRS feed

  • Question

  • Hi,

    We have installed a complete OCS environment with:

    OCS
    OCS Edge
    Exchange 2007
    Domain controller
    AD

    Logging on using a laptop with a registered user on the domain we are able to use Live Meeting and Office Communicator without any problem. Since the domain users are trusted the AD will supply a Root (chain) certificate automatically.

    Now I'm trying to log on with a Communicator via the Edge Server externally (not via domain log ) and I'm getting the error below:

    "Communicator could not connect securely to server <edgeserver.domain.name> because the certificate presented by the server did not match the expected hostname (<edge server.domain.name>).
     
     Resolution:
     If you are using manual configuration with an IP address or a NetBIOS shortened server name, a fully-qualified server name will be required.  If you are using automatic configuration, the network administrator will need to make sure that the published server name in DNS is supported by the server certificate.

    Zie Help en ondersteuning op http://go.microsoft.com/fwlink/events.asp voor meer informatie."

    * I was installing the root chain certificate on this laptop via the <ad_machine/certsrv/> before logging on via Edge using the communicator

    * the Edge Server can be resolved via nslookup

    * the Edge server is listening on port 443, 444 and 5061.. all ports are open from the firewall

    Is there something wrong with my root certificate?

    Do I need to apply another certificate for external connection via Edge? If yes, where/how to get it?

    Please advice.

    Regards,

    Thomas

    Friday, July 20, 2007 3:58 PM

Answers

  • Got it working!

    Seems that I was not entering the federation settings and edge server settings under "Global Properties" in the OCS Forest (see OCS console).

    After restarting OCS and Edge I was able to sign in using Communicator via Edge. So it seems that I have implemented the right root certificate.

    I'll keep you informed about the performance of the communicator via Edge.


    /Thomas.
    Friday, July 20, 2007 9:04 PM

All replies

  • Got it working!

    Seems that I was not entering the federation settings and edge server settings under "Global Properties" in the OCS Forest (see OCS console).

    After restarting OCS and Edge I was able to sign in using Communicator via Edge. So it seems that I have implemented the right root certificate.

    I'll keep you informed about the performance of the communicator via Edge.


    /Thomas.
    Friday, July 20, 2007 9:04 PM
  • Hello,

    I have installed OCS 2007 and  autority of certification in my server. This autority named "valideCertif" and I created a certificate thanks to OCS 2007 and named it "moncertificat".

    Then, I apply my certificate in IIS. In my customer, I go to htpp://myserver/certsrv
    and download a certificate named "certnew" from my server.

    I installed it.

    But communicator do not function. Do you have any ideas of my problem ? If you have the solution, could you give details about it please. I don't know certificate and server 2003.

    Regards.

    PS : sorry for my english
    PS : for the moment, it's just in local network
    Wednesday, March 4, 2009 3:57 PM