Microsoft Fix it Center install errors RRS feed

  • Question

  • 1. I downloaded FixitCenter_Run.exe, ran it and received the error:"Fix it Center Setup encountered an error. An unexpected error has ocurred. Please close and try to run Setup again later."

    2. I renamed the registry key:  "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf". Rebooted and ran FixitCenter_Run.exe again and received the error: "An unexpected error has occured. Setup can not continue. Please close and try again. Error: An attempt was made to access a socket in a way forbidden by its access permissions".

    I tried Microsoft's Autoplay Repair Wizard, N/G.

    The event viewer does not show Windows Logs.

    I installed Fixit on another computer and it worked. Before the install was complete I found a file called 188141.msi, that is an installer package for Fixit. It started to download Powershell 1.0 and quit. Next I downloaded Powershell 1.0 and installed it. Then I ran 188141.msi again, and received the following error msg: The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2356(This path component is invalid). So much for this idea.(added 5-11-2010) 

    I extracted the files from FixitCenter_Run.exe. The Autorun.inf shows 3 needed downloads(xp-x86 for me). 1. msxml6_x86.msi(received message - higher version already exists). 2. windowsxp-kb926139-v2-x86-enu.exe(PowerShell 1.0, it installed ok) 3. fixitcenter_setup_x86.msi(installed OK). I now have Microsoft Fix It Center installed, but with error message- unable to download troubleshooters, check your internet connection. My connection is OK? (added 5-12-2010)

    Download msxml6_x86.msi at http://go.microsoft.com/fwlink/?LinkID=186221

    Download windowsxp-kb926139-v2-x86-enu.exe(PowerShell 1.0) at http://go.microsoft.com/fwlink/?LinkID=164073

    Download fixitcenter_setup_x86.msi at http://go.microsoft.com/fwlink/?LinkID=1186221

    This info was found at http://win-lite.de/wbb/index.php?page=Thread&threadID=4118&l=3 other windows versions can be found at this URL.

    Operating system: XP Home, Anti-virus program: Windows Live OneCare, Anti-malware program: Spybot S&D


    Monday, May 10, 2010 8:44 PM

All replies

  • Dear Customer,

    Thank you for your interested in Microsoft Fix it Center (beta).

    The problem is being researched. We'll update this thread when we have more information.


    Daniel Chow
    Sr. Software Development Engineer
    Product Quality and Online

    This email is provided "AS IS" with no warranties, and confers no rights.
    Thursday, May 13, 2010 3:14 AM
  • And the answer is....?
    Wednesday, June 9, 2010 6:09 AM
  • Still no answer?. The problem appears to be with the MATS. A lot of people appear to be having this trouble.

    Vista, all updates, AVG intrenet security 8.5.437 full installation, 2 gb ram,350 gb free hd. 

    Saturday, June 12, 2010 12:28 PM
  • same problem here!

    Problem with the problem fixer- thats simply embarrasing for microsoft!



    Sunday, July 18, 2010 5:50 PM
    Monday, August 9, 2010 11:48 PM
  • In general I am lost on MicroSoft rather than Unix which if anyone thinks UNIX is hard stuff (it is!) it is easier than MS stuff by far. I just can't follow it, the registry, the fix(nothing).exe and all the what'ch-a-ma-call-it's software, fixes, patches, bugs etc. I am sorry I can't help and not suggesting UNIX, or the APPLE version of it but I certainly wish you luck,, you will need it!!! A lot of it! (and watch MS delete my message, I will be verh/VERY surprised if they don't - Thanks MR' BILL...)



    • Proposed as answer by eddyskettie 10 Tuesday, October 16, 2012 6:49 PM
    Friday, August 12, 2011 1:38 AM
  • PS Pleae note how they didn't update the "thread"...

    Friday, August 12, 2011 1:39 AM
  • Ah! they did automagically delete/filter out my reply, thanks MR. BILL...
    Friday, August 12, 2011 1:40 AM
  • November 19th, 2011 and still not updated
    • Proposed as answer by wiz19 Thursday, March 29, 2012 11:51 PM
    Saturday, November 19, 2011 8:31 PM
  • March 29th 2012...........................AND STILL.................NO ANSWER ! ! ! !

    What's up MS ???????

    Thursday, March 29, 2012 11:52 PM
  • argh :/
    Same problem  here...  microsoft Os its a nice maze/puzzl
    Looking forward to further development of this program,.. eventhough its a decenia or more overdue :S
    • Edited by HJB2012 Wednesday, April 4, 2012 5:40 PM
    Wednesday, April 4, 2012 5:37 PM
  • If our computer does not have errors why we would buy another one? This would slow down the industry around informatic...
    Wednesday, May 23, 2012 8:39 PM
  • Hmmmmm,  so this thread's been going on for over 2 years and still no solution from Microsoft?  Shame on them!  I think its about time they roll out a "Fixit" app for their Fixit Center . . . . I'm jus' sayin' . . . .  .  O_O
    Monday, June 25, 2012 6:37 AM
  • I have the same problem on my windows xp3 professional.  Darn are you right.  when ya gonna fix it microsoft?


    Thursday, October 4, 2012 3:17 AM
  • Just thought I would share a fix for this problem (in my case anyway):

    1. Make sure "Windows Installer" (Also seen it reported as "Windows Modules Installer") service is set to automatic (I've seen it randomly set to manual) and STOP the service.
    2. Go to C:\Windows\System32\wbem\
    3. Rename "Repository" folder to "Repository.old"
    4. Reboot PC.
    5. Verify that windows has rebuilt the Repository folder.

    Friday, December 7, 2012 11:10 PM
  • I found a fix that worked for me.

    Associated with the fixit error I also received a MATSVC error 2 (You can review these systems error logs by going to Start>Control Panel>Administrative Tools>Component Services>Event viewer and selecting a log, in this case the Applications log.)

    To fix the problem, go to Start>Control Panel>Administrative Tools>Services and right click on the Microsoft Automated Troubleshooter Service and select Properties. On the general tab, select startup type: automatic. On the logon tab, select "this account" radio button and enter NT Authority\system, followed by your system passwords. In the hardware profile I had undocked profile enabled.

    This got MS fixit working. 

    • Edited by waterboy9 Wednesday, December 12, 2012 1:57 PM
    Wednesday, December 12, 2012 1:38 PM
  • Hmmmmm,  so this thread's been going on for over 2 years and still no solution from Microsoft?  Shame on them!  I think its about time they roll out a "Fixit" app for their Fixit Center . . . . I'm jus' sayin' . . . .  .  O_O

    How can they answer if one can't even send in the report?  I agree, need a Fixit for the Fixit!!

    • Proposed as answer by soonerguy1967 Monday, January 7, 2013 11:00 PM
    • Unproposed as answer by soonerguy1967 Monday, January 7, 2013 11:00 PM
    Monday, January 7, 2013 9:33 PM
  • i have same problem like urs for the last yr nothing is fixing it
    Saturday, March 2, 2013 4:48 AM
  • ditto for enabling hibernate

    go back and answer blue launch "Did this fix the problem?"

    ps the above launch i tried, did not work but Give Feedback did.

    • Edited by azzlo Sunday, March 17, 2013 4:53 AM
    Sunday, March 17, 2013 4:36 AM
  • ditto for enabling hibernate after disk clean up tool...

    go back to feedback, 2 questions and explain if ("Did) this fixed the problem?"

    Sunday, March 17, 2013 5:04 AM
  • Same here, on two different physical machines both running Windows 8 Professional :-?

    One PC prompted for .Net 3.5 (since,unlike the other, it wasn't installed), and then the error occurred also.

    • Edited by spurr1 Friday, March 22, 2013 2:11 AM
    Friday, March 22, 2013 2:05 AM