none
Some problems in umxdot11(tx in Sora 2.0) tx failed RRS feed

  • Question

  • The UMXDot11.exe.ini was set as 

    [Modulation]
    Protocol = 802.11b.brick
    DataRate = 5500
    PayloadLength = 1000

    [Hardware]
    SampleRate = 44

    and the dos command was 

    F:
    cd F:\SoraSDK2.0\bin 

    dut start

    dut centralfreq --value 5200

    dut txgain --value 0x1000

    umxdot11 tx

    But the result is "tx failed"

    And I have checked the codes in F:\SoraSDK2.0\src\bb\UMXDot11 and found 

     HRESULT hr = SoraURadioTx(TARGET_RADIO, TxID);
        if (FAILED(hr))
        {
            printf("[dot11b:tx] tx failed\n");
            //break;

    I guess that the API SoraURadioTx was not successed. But in Sora SDK 1.6 ,it can be used successful. I don't know why.

    Hope to reply..

    Monday, October 14, 2013 9:15 AM

All replies

  • Could you provide below information for our diagnosis?

    1. What is your hardware? Single radio RCB board or Sora MIMO kits?

    2. Could you output the SoraURadioTx return value?

    3. Could you completely reboot the PC and reset the RCB board and the radio, then try again?

    Tuesday, October 15, 2013 3:15 AM
    Answerer
  • Sorry to reply too late.  

    1 Only single radio RCB board,not Sora MIMO.

    2 I have tried to add printf sentence in the code and built it using WDK,but Iwas failed I could not get the return value.

    3 I reset the RAB and restart the PC,it was still failed.

    By the way,I used it successfully only once before I posted the message,but the throught is very big.




    Thursday, October 17, 2013 11:09 AM
  • I just installed SoraSDK2.0 and ran UMXDot11.exe, it can work successfully.

    this is  my operation:

    ---------------------------------------

    UMXDot11.exe.ini:

    [Modulation]
    Protocol = 802.11b.brick
    DataRate = 5500
    PayloadLength = 1000

    [Hardware]
    SampleRate = 44

    ------------------------------------

    command line:

    dut start --radio 0

    dut centralfreq --value 5200 --radio 0

    dut txgain --value 0x1000 --radio 0

    umxdot11.exe tx

    It can work normally!

    I think you'd better make sure the radio has been started successfully after you typed "dut start --radio 0".

    Friday, October 18, 2013 6:09 AM
  • Plus: my hardware environment is single radio RCB board. In previous version Sora needn't dut start before UMXDot11.exe, but in SoraSDK2.0, this is neccessary. And in single radio RCB board the default radio is "radio 0'.

    Friday, October 18, 2013 6:43 AM
  • Thank you. I have tried as you said. It could send frames the first time. But it send more than 50000 frames one second,about 380Mbps. It was the same as the time I ever succeed.But it was not normal. And then it could not used. This is the information.I input the command and always show  Ret :0x00000000

       [iNFO] Mode :TX

       [INFO]Protocol: 802.11b

      [dot11b:tx] tx buffer: 002e0000

     [dot11b:tx] tx buffer size:00200000

     [dot11b:tx] Gensignal return 00000000

     ....    Signal bytes = 145664

    ....  transfer, h=80050003,id=0

    ..... Tx out.

    Clean user ext

    I guess the radio was not started successfully. Maybe Something wrong with the HW driver or the hardware. When I use umxsdrbrick adhoc mode,the frame send very  very slowly.

    Friday, October 18, 2013 8:46 AM
  • I can get some information from your description.

    a. I think it's not the reason of radio, which should be started successfully.

    b. "hr=80050003", you encountered the problem that you failed to transfer from PC to RCB.

    So I doubt if your PC's PCIE could support so high speed?

    Monday, October 21, 2013 8:34 AM
  • Sorry to reply so late. I think my PCIE could support high speed like 12Mbps,for example Iperf test on SDRminiport Driver .  But displaying 380Mbps is wrong,because it is not normal.
    Tuesday, October 29, 2013 2:14 AM
  • Hi,

    Could you provide more information of your PC, i.e. what is the motherboard?

    -Jiansong

    Sunday, November 3, 2013 1:51 PM
  • Sorry,it is not convenient to reply.Something was wrong with the reply panel.Here is my PC information. I bought it from the V3best.

    Hardware

    CPU : Intel Core i7 quad-core    3.40GHz
    Motherboard : Shuttle - Intel H67 (Cougar Point) [B3]
    Memory : A-DATA Technology 4G DDR3 SDRAM 1600 MHz Single Channel
    Graphics Card : Intel HD Graphics 2000 (Sandy Bridge GT1)
    Hard Drive : Seagate 1000GB 
    Sound Card : Intel Cougar Point PCH - High Definition Audio Controller [B3]
    NIC : RealTek Semiconductor RTL8168/8111 PCI-E Gigabit Ethernet NIC

    Wednesday, November 6, 2013 1:50 AM