Project Server 2003 - Task Button Fails on PWA RRS feed

  • Question

  • Problem: When you open PWA on Project Server 2003 and click on the "Tasks" Button, the Tasks page appears, and after one second the Browser jumps back to the "Home" page.   During that one second it looks like the grid is trying to build without any images and then it  drops back to PWA home  All other menu buttons work.  Just the "Task" with this behavior.

    Background: Project Server 2003, SP2 on Windows 2003 on single server, with SQL Server 2005 on another server.  Running for many years.  This week a large number of patches where applied from Microsoft auto update.

    I tried it with different users, and also with Users that have all Rights and a lot of assigned tasks. This is been tested on IE 7 and IE 8.  It is a trusted site and have lower browser security that enables all IE features for troubleshooting and no go.

    I remember seeing this particular behavior years ago and wish this old feeble mind could remember the fix.



    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA
    Friday, October 22, 2010 11:51 AM


All replies

  • Hi Michael,

    I remember I have seen this behaviour in the past. Unfortunately, I can't remember the exact solution :s

    I has something to do with the Tasks grid not being able to retreive the data from the database server.

    • Try opening PWA directly on the application and on the database server. Does this make a difference?
    • Check the event logs on both the application and database server (also for failing login attempts)
    • What SP is Windows Server 2003 on? It could be caused by the authentication loopback check.

    Anyway, if I remember correctly, you need to look for problems with the client not being able to communicate with the database server.

    I hope this helps,

    My EPM blog: Projectopolis
    Friday, October 22, 2010 11:13 PM
  • Hello HansH

    Thanks.  Yes I have tried opening from the different servers wit no success.   The event log is clean.

    I didn't check the loopback check, I thought that only pertained to opening PWA from the project server, but that's an option.

    The SP on windows 2003 should be up to date and will verify on Monday.



    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA
    Sunday, October 24, 2010 12:47 PM
  • Michael,

    One other thing I could think of: try disabling (temporary) anti-virus and firewall software on both client and server (McAfee for example has a nice history of interfering with Project Server 2003).

    You can also run a SQL Profiler to see if the request actually makes it to the server or not.


    My EPM blog: Projectopolis
    Sunday, October 24, 2010 8:59 PM
  • Hi Michael,

    We experienced this behavior and the SQL back end was the culprit.  I believe the logs were full or something of that nature and the second the SQL Admin took a look he was able to rectify in minutes.  Strange symptom, but you are describing exactly what we experienced.

    Check SQL events and errors.



    Wednesday, October 27, 2010 3:11 PM
  • This issue is already identified and documented here.


    If that doesn't help configure the /projectserver virtual directory permission as per the following article.





    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Friday, October 29, 2010 7:23 AM