locked
Windows 7 PC doesn't even try to go back to sleep after backup anymore RRS feed

  • Question

  • I seem to be having a problem with my Windows 7 PC, it's not going back to sleep after the nightly backup.

    Before Win7, I was running Vista x64 with WHS PP2. Everything worked great and most of the time, I'd get up in the morning and my computer would be sleeping (well, most of the time at least).

    In Oct, I then installed Win7 and upgraded my backup system to WHS PP3 beta. Now I found the sleep issue to be flaky. Sometimes I would wake up and it's sleeping, sometimes it's awake. When it's awake, digging through the event log shows that it went to sleep and something woke it back up, so I guess that's ok.

    Now with WHS PP3 Final, I've yet to see my computer go to sleep after doing the backups. Digging through the event viewer shows that it didn't even try to go back to sleep.

    I see the computer resume from sleep. A bunch of things enter the start state. A while later a bunch of things enter the stop state. And that's it. No message about going to sleep.

    So it's not sleeping and waking back up (like before), it's not even trying to sleep at all.

    Does anyone know what I can do to troubleshoot this issue?

    My computer is the exact opposite of "green" so that's why I like to keep it powered off as much as possible...
    Thursday, November 26, 2009 6:46 PM

All replies

  • Has the PC been rebooted since installing PP3 Final? Only some of the new features were working on my Win 7 PC until I rebooted it.

    There is a Windows 7 report that you can run that will analyze the system for support of various sleep states:

    powercfg -energy

    Run this from an elevated command prompt and wait for the report to finish; it takes a minute or two. The report may contain clues that will let you troubleshoot. Before running, do powercfg /? to see the syntax of the energy report command and to find out where the report will be saved.
    Thursday, November 26, 2009 8:19 PM
  • I don't believe that it has been rebooted... I'll give that a try! Will report back once I have some results (may take a day or two).
    Thanks!

    Friday, November 27, 2009 5:56 PM
  • Hi Mark,

    I've rebooted the system, and this morning, the computer woke up, did the backup, then stayed on again.

    Digging through the event viewer, I see a wake up event and no sleep event. It's still not even trying to go back to sleep.

    Everything worked well with Vista, things were a bit flakey with Windows 7 and WHS PP3 Beta, but at least, according to the log, it slept and something woke it back up.

    With WHS PP3 Final, I've still yet to see a sleep. Hopefully we can figure this out as my power bill is going to be a lot higher until it's resolved! lol

    I ran the energy report and didn't see anything that looked very bad. I can post it:

    Power Efficiency Diagnostics Report

    Computer Name DARKSIDE
    Scan Time 2009-11-28T18:12:18Z
    Scan Duration 60 seconds
    System Manufacturer System manufacturer
    System Product Name System Product Name
    BIOS Date 04/28/2009
    BIOS Version ASUS StrikerExtreme ACPI BIOS Revision 1901
    OS Build 7600
    Platform Role PlatformRoleDesktop
    Plugged In true
    Process Count 65
    Thread Count 897
    Report GUID {8de88b25-3870-4778-b59e-cec4fbb8de8c}

    Analysis Results

    Errors

    Power Policy:Power Plan Personality is High Performance (Plugged In)
    The current power plan personality is High Performance when the system is plugged in.
    Power Policy:Display timeout disabled (Plugged In)
    The display is not configured to turn off after a period of inactivity.
    Power Policy:Sleep timeout is disabled (Plugged In)
    The computer is not configured to automatically sleep after a period of inactivity.
    Power Policy:Disk idle is disabled (Plugged In)
    The disk is not configured to turn off after a period of disk inactivity.
    Power Policy:Minimum processor performance state is 100% (Plugged In)
    The processor is not configured to automatically reduce power consumption based on activity.
    Power Policy:PCI Express ASPM is disabled (Plugged In)
    The current power policy for PCI Express Active State Power Management (ASPM) is configured to Off.
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name USB Composite Device
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_046D&PID_C229
    Port Path 3,2,2
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name USB Composite Device
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_046D&PID_C228
    Port Path 3,2,1
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name USB Root Hub
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_10DE&PID_036D
    Port Path  
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name Generic USB Hub
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_05E3&PID_0607
    Port Path 3,2
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name USB Composite Device
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_1532&PID_000F
    Port Path 3,3
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name USB Input Device
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_046D&PID_C21C
    Port Path 3,2,4
    USB Suspend:USB Device not Entering Suspend
    The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
    Device Name Generic USB Hub
    Host Controller ID PCI\VEN_10DE&DEV_036D
    Host Controller Location PCI bus 0, device 11, function 1
    Device ID USB\VID_050D&PID_0307
    Port Path 3
    CPU Utilization:Processor utilization is high
    The average processor utilization during the trace was high. The system will consume less power when the average processor utilization is very low. Review processor utilization for individual processes to determine which applications and services contribute the most to total processor utilization.
    Average Utilization (%) 5.10

    Warnings

    Power Policy:802.11 Radio Power Policy is Maximum Performance (Plugged In)
    The current power policy for 802.11-compatible wireless network adapters is not configured to use low-power modes.
    CPU Utilization:Individual process with significant processor utilization.
    This process is responsible for a significant portion of the total processor utilization recorded during the trace.
    Process Name LCDClock.exe
    PID 3472
    Average Utilization (%) 1.47
    Module Average Module Utilization (%)
    \Device\HarddiskVolume2\Windows\System32\WindowsCodecs.dll 0.62
    \Device\HarddiskVolume2\Windows\winsxs\amd64_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.7600.16385_none_2b4f45e87195fcc4\GdiPlus.dll 0.25
    \SystemRoot\system32\ntoskrnl.exe 0.12
    CPU Utilization:Individual process with significant processor utilization.
    This process is responsible for a significant portion of the total processor utilization recorded during the trace.
    Process Name iexplore.exe
    PID 1992
    Average Utilization (%) 1.14
    Module Average Module Utilization (%)
    \Device\HarddiskVolume2\Windows\SysWOW64\mshtml.dll 0.48
    \SystemRoot\System32\win32k.sys 0.26
    \SystemRoot\system32\ntoskrnl.exe 0.11
    CPU Utilization:Individual process with significant processor utilization.
    This process is responsible for a significant portion of the total processor utilization recorded during the trace.
    Process Name LCDMon.exe
    PID 1236
    Average Utilization (%) 0.48
    Module Average Module Utilization (%)
    \Device\HarddiskVolume2\Program Files\Logitech\GamePanel Software\LCD Manager\LCDMon.exe 0.27
    \SystemRoot\system32\ntoskrnl.exe 0.10
    \Device\HarddiskVolume2\Program Files\Logitech\GamePanel Software\LCD Manager\LCDDevices\EDMBTDD.dll 0.05
    CPU Utilization:Individual process with significant processor utilization.
    This process is responsible for a significant portion of the total processor utilization recorded during the trace.
    Process Name LCDRSS.exe
    PID 3436
    Average Utilization (%) 0.39
    Module Average Module Utilization (%)
    \Device\HarddiskVolume2\Windows\System32\usp10.dll 0.17
    \SystemRoot\System32\win32k.sys 0.10
    \Device\HarddiskVolume2\Program Files\Logitech\GamePanel Software\Applets\LCDRSS.exe 0.04

    Information

    Platform Timer Resolution:Platform Timer Resolution
    The default platform timer resolution is 15.6ms (15625000ns) and should be used whenever the system is idle. If the timer resolution is increased, processor power management technologies may not be effective. The timer resolution may be increased due to multimedia playback or graphical animations.
    Current Timer Resolution (100ns units) 156000
    Power Policy:Active Power Plan
    The current power plan in use
    Plan Name OEM High Performance
    Plan GUID {8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c}
    Power Policy:Power Plan Personality (Plugged In)
    The personality of the current power plan when the system is plugged in.
    Personality High Performance
    Power Policy:Video quality (Plugged In)
    Enables Windows Media Player to optimize for quality or power savings when playing video.
    Quality Mode Optimize for Video Quality
    System Availability Requests:Analysis Success
    Analysis was successful. No energy efficiency problems were found. No information was returned.
    Battery:Analysis Success
    Analysis was successful. No energy efficiency problems were found. No information was returned.
    Platform Power Management Capabilities:Supported Sleep States
    Sleep states allow the computer to enter low-power modes after a period of inactivity. The S3 sleep state is the default sleep state for Windows platforms. The S3 sleep state consumes only enough power to preserve memory contents and allow the computer to resume working quickly. Very few platforms support the S1 or S2 Sleep states.
    S1 Sleep Supported true
    S2 Sleep Supported false
    S3 Sleep Supported true
    S4 Sleep Supported true
    Platform Power Management Capabilities:Processor Power Management Capabilities
    Effective processor power management enables the computer to automatically balance performance and energy consumption.
    Group 0
    Index 0
    Idle (C) State Count 1
    Performance (P) State Count 0
    Throttle (T) State Count 0
    Platform Power Management Capabilities:Processor Power Management Capabilities
    Effective processor power management enables the computer to automatically balance performance and energy consumption.
    Group 0
    Index 1
    Idle (C) State Count 1
    Performance (P) State Count 0
    Throttle (T) State Count 0
    Platform Power Management Capabilities:Processor Power Management Capabilities
    Effective processor power management enables the computer to automatically balance performance and energy consumption.
    Group 0
    Index 2
    Idle (C) State Count 1
    Performance (P) State Count 0
    Throttle (T) State Count 0
    Platform Power Management Capabilities:Processor Power Management Capabilities
    Effective processor power management enables the computer to automatically balance performance and energy consumption.
    Group 0
    Index 3
    Idle (C) State Count 1
    Performance (P) State Count 0
    Throttle (T) State Count 0
    Saturday, November 28, 2009 6:21 PM
  • I ran the energy report and didn't see anything that looked very bad. I can post it:

    Power Efficiency Diagnostics Report

    Analysis Results

    Errors

    Power Policy:Sleep timeout is disabled (Plugged In)
    The computer is not configured to automatically sleep after a period of inactivity.

    What happens if you set the power policy so that the PC automatically sleeps after some time period; say, 1 hour?
    Sunday, November 29, 2009 1:56 AM
  • I would hope that that isn't a requirement for the Windows 7 connector software.

    I've had that disabled since Vista because I don't want my computer to use a timer to go to sleep.

    Come to think of it, I do have a bunch of weird power configuration customizations... I'm going to reset the 'high power' option back to its defaults. This'll match what I did in Vista... maybe I touched something I shouldn't have.

    While at it, I just finished going through my devices in device manager to make sure that they can be shut down. Everything looks ok in there.

    I also read about undesired side effects from scheduled tasks so I went through the task scheduler and disabled a few things (all the application experience stuff and defrag - I'm running SSDs, defrag is set to skip all my drives anyways).

    Too bad there isn't a faster way to test this stuff out... guess I have to wait until the morning to see what happens...
    Sunday, November 29, 2009 7:09 AM
  • My suggestion was only for troubleshooting purposes. If you set the power policies so that the PC automatically sleeps after an hour of inactivity, and then find out that it doesn't enter sleep mode, then you have a bigger problem than the Connector software.

    Sunday, November 29, 2009 2:04 PM
  • Ah, you have a good point sir. I'll do that test, I thought you meant that to be a permanent solution! :)

    FYI, it would appear that all of the changes I made last night did not work. My computer was on again this morning.

    I'll try your timeout test (will set it to 20-30 min if I can so it'll happen faster) and report back with the results.

    Thanks again.
    Sunday, November 29, 2009 7:34 PM
  • Hi Mark,

    I set the computer to go to sleep after 10 minutes of inactivity then went away for a while. Came back and the computer was happily sleeping.

    So far we have:

    1. Put computer to sleep manually: works
    2. Put computer to sleep after 10 minutes of inactivity: works
    3. Put computer to sleep after backup is complete: broken

    The thing that's really bothering me is that after the backup, I don't see any event viewer entries for even attempting to sleep.
    Sunday, November 29, 2009 10:21 PM
  • Well, we're getting somewhere.

    Can you do the following test? Create a scheduled task using Task Scheduler. Click on "Create Task" (not create basic task) and fill out each of the tabs as follows:
    1. General -  enter a name for the task.
    2. Triggers - click "New", select "On a schedule", "One time" and set the timer for some convenient time in the future, like 15 minutes from now.
    3. Actions - click "New", select "Start a program", navigate to the WHS Backup task at "C:\Program Files\Windows Home Server\Backup Engine" and select this file. In the arguments box enter "a" (for automatic backup)
    4. Conditions - check the box "Wake the computer to run this task"

    Save the task, exit task scheduler, then put the PC into sleep mode. See if it wakes at the appointed hour, backs up, and then goes back to sleep 2 minutes after the backup completes. This will further test the power management capability of your PC. Any task that wakes the PC should, if there is no user activity (keyboard or mouse), cause the PC to go back to sleep 2 minutes after the task completes.

    If this is successful then it really points to WHS Connector as the culprit.

    Next question - did you uninstall the beta version of PP3 on your server before installing the final version?
    Sunday, November 29, 2009 10:46 PM
  • Hi Mark,

    I made a mistake with the flag so an error message popped up instead of the backup going off - I think I need to use "-a" instead of "a". But... I did leave the computer alone for an hour while I was grabbing dinner thinking it was being backed up. When I got back, it had not gone back to sleep after all of that inactivity.

    I recently read about the 120 sec wakeup inactivity timer... Do you think the problem is here? Strange that it didn't work when the 10 min timer I set in the power options did.

    Also, to answer your question: WHS PP3 wouldn't show up in Windows Update until I did an uninstall of WHS PP3 Beta. So I uninstalled WHS PP3 Beta, manually ran Windows Update and installed WHS PP3 Final. On the Win7 side, I was then getting 'incompatible connector' errors, which was to be expected. On my Win7 machine, I connected to WHS server port 88000 (I think?) and downloaded the new connector software. The installer, uninstalled the old connector software before installing the new one.

    I'm going to fix that flag and run the task again, but I have a feeling, the system won't be going back to sleep after the 2 minutes is up... very, very interesting... think we're onto something?

    Thanks again!
    Monday, November 30, 2009 12:36 AM
  • Hi again Mark,

    Some new info to add to my prior post.

    I just changed the arg from "a" to "-a" and reran so no error would occur (the "a" causes an error popup to appear).

    At the designated time, the computer came out of sleep, did something, then a few minutes later it went back to sleep.

    Does this mean that the connector is the culprit?

    PS. Perhaps I should have added this post as an "edit" to the prior one. It's showing up on top of the older post (at least in my view).
    Monday, November 30, 2009 12:49 AM
  • Sorry about the -a; you are correct.

    At this point I would suspect the Connector as the culprit, although to be honest, there are some machines that just will not cooperate with the automatic WHS backup mechanism. I have two of them on my network that I've had to come up with a workaround solution to get them to behave.

    You could try reinstalling the Connector software and then rebooting the machine. Or, you could go to plan B.

    Plan B is to edit the scheduled task so that it runs every night at a time of your choosing. Then go to the WHS tray icon and uncheck "Wake This Computer for Backup". By doing this you are putting the PC in control of the backup process. Since the Win 7 Task Scheduler is so versatile, and you now know that it works, it will be responsible for waking your PC, backing it up, and then going back to sleep.
    Monday, November 30, 2009 1:11 AM
  • Thanks Mark,

    Plan B is starting to look like a viable option if I can't get the connector issues sorted out. It's unfortunate because everything worked perfectly when I was running Vista x64.

    One concern is that when I ran the backupengine.exe -a in my task, it appears that nothing really happenned. According to my WHS machine, the last backup was done at 4:00 AM, so nothing happenned at 4:00 PM when my task went off.
    Monday, November 30, 2009 1:26 AM
  • That's not right. In the scheduled task, on the "General" tab, check off "Run with highest priviliges" and try again. After the backup completes, check in the WHS console to make sure that the backup ran.

    If this doesn't work, to troubleshoot further, run the command manually from an elevated command prompt:
    "C:\Program Files\Windows Home Server\BackupEngine" -a
    Monday, November 30, 2009 1:32 AM
  • Hi Mark,

    I checked "Run with highest priviliges" and reran the task and the samething happenned again. It appears that the backup did not kick off.

    I them openned an elevated prompt and ran the exe manually and it did work. Not sure why the task is unhappy.

    Here are some screenies of my settings:

    Monday, November 30, 2009 1:57 AM
  • Update:

    In addition to the posted settings, I also tried setting it to run whether or not the user is logged on... but still had no luck.

    I'd almost think that the task isn't getting elevated for some reason...?

    Update 2:

    I just ran it from within task schedule, but while I was still logged into the computer and everything works fine. The only difference is that this time, I didn't put my computer to sleep first.



    So, this would mean that I'm only running into trouble when I put my computer to sleep. For some reason, Plan B doesn't want to work if my computer is sleeping. Very strange!
    Monday, November 30, 2009 2:30 AM
  • Stan:

    On the "General" tab of the scheduled task, try changing the user to "System" and see if that works.
    Monday, November 30, 2009 3:15 AM
  • Hi Mark,

    Just tried running as system with the same result - no backup occurred.

    Interestingly the task is showing this:

    Last Run Time: 7:06
    Last Run Result: successful

    In my last test, the trigger, woke the computer at 7:22 to run the task, but it's not showing here.

    If I had to guess, it looks like the following is occurring:

    1. computer wakes up
    2. computer goes back to sleep

    The successful run at 7:06 was when I didn't put the computer to sleep and let the task go off while I was logged in and watching.

    EDIT:

    I just reran as Stan and the last run time now matches correctly.

    Last Run Time: 7:31
    Last Run Result: successful

    Unfortunately, it really wasn't successful despite what it says here, because no backup occurred.
    Monday, November 30, 2009 3:29 AM
  • Stan:

    Has any backup ever occurred during your tests today? If so, under which conditions?

    It's late here, so I'll have to get back to you tomorrow. In the mean time, try completely unistalling the connector software from your machine. Reboot, and then browse to the software folder on your WHS and try reinstalling. Reboot again. Then see if you can get any manual backup to complete.
    Monday, November 30, 2009 4:15 AM
  • Hi Mark,

    I've had only 2 backups go off during my tests today.

    1. Manual run in an elevated command prompt.
    2. A task that went off while I was still using the computer (not logged out and computer not asleep). Task settings had it run with elevated privaledges and from the Stan account.

    Unfortunately, none of these would work if the computer was asleep and don't involve putting it back to sleep.

    I'll uninstall and reinstall the connector tonight. Will see what happens in the morning. I'll probably be in late tomorrow so followup may be after you've called it a night.

    Thanks again for the help Mark, have a great night. Catch you tomorrow!
    Monday, November 30, 2009 4:28 AM
  • Stan:

    All that I can think of is that you may have the same problem that one of my PCs has - after resuming from sleep, it is not in communication with the server via the WHS Connector service. I thought that the PP3 update fixed that, and it sort-of did, but it created a new problem for me. The workaround is to restart the WHS connector service each time that the PC resumes from sleep. This can be done with a scheduled task that is triggered by resuming from sleep. Perhaps this will work for you also.

    I can post the details later today after you've had a chance to reinstall and re-test.

    Ironic, isn't it? Both my PC and yours worked perfectly on autopilot with Vista, and they both seem to have the same problem after updating them to Windows 7. I don't believe that the Win 7 sleep issue that was "fixed" with the PP3 connector upgrade works on all PCs yet. Probably on most, but not on all.
    Monday, November 30, 2009 2:17 PM
  • I am having the exact same problem which I was Googling and came across this thread. I have 3 different Win7 PC's set to wake for backup and not one of them goes back to sleep after it's done. None of these PC's ever had the PP3 beta installed. I was starting to think there was a configuration switch to enable the feature that I just haven't been able to find yet but I guess that's not the case.
    Monday, November 30, 2009 9:41 PM
  • Hi Mark,

    I reinstalled the connector software last night... did it the safe way - uninstall, reboot, install, reboot. This morning, I had a bit of a double failure. The system was not sleeping and also the backup failed. Error was that none of the drives could be read (first time I've seen this one). It may be coincidence. I manually kicked off a backup from the connector and everything seemed to backup fine, so it may have just been a quirk, will see when it tries again tomorrow.

    I, too, have noticed the connector sleep lag issue. When I resume from sleep, the connector goes grey for a bit before turning green. I'd assume that this is the period of no connectivity that you were talking about?

    I wonder if this has to do with the NIC powering down. If that's the case, I should try playing with the NIC power settings (like enabling WOL) to see if that prevents loss of contact with the server...?

    I'd love to check out the details on how to restart the task, looks like I may have to follow through with this route until Microsoft gets all of the issues worked out.

    Haha it truly is ironic that everything worked perfectly on Vista, of all operating systems! Hopefully Microsoft gets it all sorted out. I don't think I've ever seen a Connector upgrade that wasn't part of a Power Pack though... does that mean we're waiting for PP4 now? lol

    Thanks again for the help!
    Monday, November 30, 2009 9:41 PM
  • Stan:

    After reviewing all of the clues, I think we've established the following:

    1. The new connector works
    2. Your PC is capable of sleeping, waking from sleep, and going back to sleep after a period of inactivity
    3. Scheduled tasks work, including those that wake the PC
    4. Manually-initiated backups work when you have connectivity to the server
    5. When your machine wakes, it doesn't have connectivity to the server right away
    6. Automatic backups wake the machine but it then fails to go back to sleep

    I agree that item 5 may be caused by the NIC, its driver, or its settings, but this is only a hunch. Enabling WOL should not be necessary. At this point your symptoms are somewhat like mine, so I will outline the solution that has worked reliably for me for the past few months, both with PP2 and PP3 connectors.

    Workaround for no connectivity to the server when waking from sleep

    Set up a scheduled task to restart the WHS Connector Service each time the PC wakes from sleep. Create a new scheduled task with the following settings:

    General tab: Name - "WHS Connector Service Restart"; Description - "Restarts the WHS Connector Service each time the PC resumes from sleep. Due to a bug, the service is not working after resuming from sleep. To restart the service, a stop command is issued followed by a start command."; User - SYSTEM.

    Triggers tab:
    New trigger; Begin the task - On an event; Log - System; Source - Power-Troubleshooter; Event ID - 1; Delay task for - 10 seconds.

    Actions tab:
    Add two new actions in this order: Action 1 - Start a program; Program/Script - sc; Add arguments - stop WHSConnector; Action 2 - Start a program; Program/Script - sc; Add arguments - start WHSConnector.
    Note: after entry the commands should come out as sc stop WHSConnector and sc start WHSConnector

    Conditions tab: No boxes checked

    Settings tab: Check "Allow task to be run on demand"; leave the others at their defaults

    Save the task.

    Workaround for the PC failing to go back to sleep after backing up

    Set up a scheduled task so that the PC wakes itself and initiates its own backup.

    A) On the WHS tray icon, uncheck "Wake This Computer for Backup"
    B) In your prior reply with screen shots, make the following changes to your task:

    1. General tab: Name - "Backup"; Description - "Creates a backup to the Windows Home Server"; User - SYSTEM
    2. Triggers tab: Begin the task - On a schedule; Daily; then enter a time of your choice.

    Save the task.

    Tuesday, December 1, 2009 12:57 AM
  • Thanks Mark,

    I'll give this a try tonight, will post back tomorrow with the results.

    One quick note. User: SYSTEM seems to resolve into NT_AUTHORITY/SYSTEM when I put it in. Hope that's not a problem.

    Thanks again!
    Tuesday, December 1, 2009 1:32 AM
  • ...User: SYSTEM seems to resolve into NT_AUTHORITY/SYSTEM when I put it in...
    That's correct.
    Tuesday, December 1, 2009 1:52 AM
  • Hi Mark,

    It appears I forgot to set the backup task to wake the computer from sleep. Just fixed the task, but have to wait until tomorrow to see if it works! :)

    Will post as soon as I get some results!

    Thanks again,

    Stan
    Tuesday, December 1, 2009 4:45 PM
  • Hi Mark,

    The good news is that at the designated time, my PC woke from sleep and the did backup successfully.

    The bad news is that it was awake again in the morning!

    In the prior tests, we've seen that waking the computer via a task and not running a backup will result in a sleep after the timeout period.

    I wonder if:

    a) restarting the WHSConnector is causing it to stay up?
    b) the backup process itself is causing it to stay up? Even when it's finished?
    c) something odd is happenning in the 30 minutes that it's up?

    I've gone through the logs to confirm that it didn't go to sleep, wake up, go back to sleep, then wakup again for some reason. Only last night's sleep followed by this morning's wake is in there.

    Wow, this one is turning out to be a doozy!
    Wednesday, December 2, 2009 4:59 PM
  • Stan:

    On a), there's one way to find out:

    Temporarily disable the backup task (end it first and then disable it). Create a new task to wake the PC in 15 minutes. For an action, choose "Start a program" and then for the program, pick something innocuous like "Notepad". Save the task.

    Leave the task in place that restarts WHSConnector. Put the machine in sleep mode. See if it wakes up, opens Notepad, and then goes back to sleep in 2 minutes. Be sure not to bump the mouse or a key on the keyboard. If you do, the 2-minute user inactivity timer will expire and the PC will then stay awake until the power policy expires.

    Do you have a cat? This reminds me of a post that I read once where a user was finding his computer would fail to go back into sleep mode on its own. Turns out his cat liked to sleep on the desk near the mouse, and you guessed it. If you have a very sensitive optical mouse it may help to turn it upside-down during the test to be sure it isn't moving slightly with vibration.
    Wednesday, December 2, 2009 5:13 PM
  • Haha, that's actually something I thought of this morning. No cat, but I actually do have a very sensitive wireless optical mouse that works at 6000 dpi.

    At night, though, I have it on its pedestal charger - this prevents the mouse from sensing anything because the sensor is pointing out into infinity (essentially). As a test for tonight, I was thinking of turning the mouse off to see what happens. It wasn't an issue in Vista, but maybe the new Windows 7 drivers they released are being quirky - who knows? lol

    I'll try to get those tests done tonight. I'm expecting a possible late night at work, so results will probably be posted late as well.

    Thanks again for the help Mark!
    Wednesday, December 2, 2009 6:59 PM
  • Hi Mark,

    The plot thickens! I did a ton of testing and have some interesting results for you!

    I did a bunch more tests, but these are the most interesting ones...

    Test 1: WHSConnect reset + Notepad.exe
    This test woke the computer, openned notepad, then did NOT go back to sleep. At first, I thought that was bad, but it made sense. Turns out that the task opens notepad and since notepad never terminates the task stays active so the computer wouldn't go back to sleep with the active task running. Going into the task scheduler showed that the task status was 'running'.

    Test 2: WHSConnect reset + 'ping 127.0.0.1'
    So I swapped notepad for ping because the ping will terminate after 5 pings (about 5 sec). Sure enough, the computer woke up, did the pings (I think, since no evidence is left to see if it really did that), then went back to sleep in 2 minutes.

    Conclusions:
    1) WHSConnect reset task isn't doing anything bad
    2) the task needs to terminate in order for a sleep to be possible

    Test 3: WHSConnect + Backup task
    Computer woke up, then went to sleep 2 minutes later. Unfortunately, it appears the backup task doesn't actually work... no new backups are showing up on the WHS machine. But at least we know that it still allows the computer to sleep!

    Conclusions:
    3) backup task isn't keeping computer up
    4) backup task doesn't start a backup

    But... this morning, I noticed a new backup on the WHS machine!

    Theory:
    I think what happenned was that I had the machine wake up at 4:30 AM. It woke from sleep, then ran the backup task which did nothing. However 4:00AM to 7:00AM is when the WHS machine starts trying to backup the machines. I think it saw that the computer was awake during the time window and initiated the backup. Unfortunately, I also woke to see that the computer was not sleeping when it was done... I've also confirmed that the connector has the 'wake for backup' setting disabled.

    So...
    I wonder what this means. It would almost appear that by doing the backup, something is then preventing the machine from going back to sleep. Aside from user-input, we've seen that having running tasks can prevent a sleep. Maybe the backup task isn't cleaning up?

    Another thing that I find interesting is that it seems all of my attempts to schedule a backup always fail. The only time I've succeeded was when I was logged into the machine when the task went off... really weird because it should work unattended, but it's not.

    I'm going to run the WHSConnect reset + non-working backup combo again to see what happens. I'm also going to switch my mouse off via its power button in case it's somehow jittering. This'll run at 4:30 this morning when the WHS machine is listenning. I just want to make sure the mouse isn't doing anything weird.

    I'll edit this post and put the results below in the morning.

    START EDIT:
    *** results will go here ***
    END EDIT:

    Thanks again for the help!
    Thursday, December 3, 2009 8:46 AM
  • From 4 posts prior to this one:
    Hi Mark,

    The good news is that at the designated time, my PC woke from sleep and the did backup successfully.

    The bad news is that it was awake again in the morning!
    From one post prior to this one:

    Test 3: WHSConnect + Backup task Computer woke up, then went to sleep 2 minutes later. Unfortunately, it appears the backup task doesn't actually work... no new backups are showing up on the WHS machine. But at least we know that it still allows the computer to sleep!
    Aren't these two results inconsistent? It will be interesting to see what happened during your test last night. Once you are able to consistently get a backup to occur, the only remaining problem is that the PC does not go back to sleep. That should be easy to fix if we just force the issue.

    In your backup scheduled task, add a second action immediately following the BackupEngine -a action. For the second action, choose "Start a program". For the program, enter the following command: rundll32 powrprof.dll, SetSuspendState 0,1,0
    This should force the PC to go back to sleep.
    Thursday, December 3, 2009 1:05 PM
  • Hi Mark,

    Yeah, we've got some serious inconsistencies going on here.

    The result of my late night run (well 4:30 AM) is interesting. It appears to have made the backup then gone to sleep. Yet when I woke my computer in the morning, it wanted to do the backup again... so I now have a 4:30 AM backup and a 8:00 AM backup for today. Very strange.

    So now, I have all kinds of mixed results.

    Did turning off the mouse help? Maybe!

    But... all my attempts to do a backup fail when I'm sitting here testing prior to 4:00 AM. If my theory were correct, and the backup were done by the WHS machine at 4:00 then it shouldn't have insisted on a backup again at 8:00...

    It's like that guy on Mystery Men who can only turn invisible when no one's looking at him.

    I'm really confused! lol
    Thursday, December 3, 2009 4:45 PM
  • ...when I woke my computer in the morning, it wanted to do the backup again... so I now have a 4:30 AM backup and a 8:00 AM backup for today. Very strange.
    Actually, that makes sense. If your PC's WHS Connector Service communicated with the server during your 4 AM - 7 AM backup interval, it might have triggered a backup, and this probably occurred the next time that you resumed from sleep. Try changing the backup time in your scheduled task for a time that's outside of the WHS backup interval.

    Additionally, that's the same symptom that PP3 connector has induced on my Win 7 PC. Mine has a scheduled task set to make a backup at 1 AM, well before the 4 - 5 AM WHS backup interval. Prior to PP3 this worked for months. After PP3, I noted that the problem of no communication with the server after resuming from sleep had gone away, so I disabled the WHSConnector restart scheduled task. But then every time that I wake the PC in the morning it wants to do another backup. So I re-enabled the scheduled task to force a WHSConnector restart following a resume from sleep, and that has fixed the problem.

    The other inconsistencies I can't explain. You had mentioned previously that on Vista, the machine would usually, but not always, go back to sleep after the backup. I think the same may be happening now because it worked last night but not on other nights. My suggested fix for that is to force the PC to enter sleep mode following execution of the backup as outlined in my previous post. Try setting it up that way (with the WHSConnector restart task + backup task outside WHS backup interval + sleep task) for a couple of days and see if it's consistent.
    Thursday, December 3, 2009 5:01 PM
  • Hi Mark,

    Last night, I tried a WHSConnector restart + backup task run outside of my backup interval. The run was done around 10:00 PM. The results was the computer woke and went back to sleep, but no backup was done.

    For some reason, it seems that the unattended backup only works when it's done during the WHS backup interval.
    Thursday, December 3, 2009 5:14 PM
  • That symptom is really puzzling. A backup started from a command prompt (or in a scheduled task) should run any time regardless of whether during the backup interval or not.
    Thursday, December 3, 2009 5:27 PM
  • Hi Mark,

    I completely agree, it doesn't make sense. The only time I got it to run was the test when the scheduled event went off while I was logged in and using the machine. I think that test used the Stan account and not the System one, however. Aside from that, I've yet to be successful in getting a backup to work via scheduled task outside of the WHS backup duration.

    Since we're now pointing our fingers at the mouse, I think for the next AM test, I'm going to switch back to letting the connector wake the computer, but I'm going to leave the mouse off again.

    Thursday, December 3, 2009 6:40 PM
  • Good thought.

    However, the inability to execute a manually-triggered backup is troubling. Have you searched the logs on the server near the time of the attempted backups; for example last night around 10:00 PM, to see if there are any clues?
    Thursday, December 3, 2009 6:57 PM
  • Agreed, it is very troubling.

    I'll check the WHS logs tonight to see if there are any clues in there. Will post back with results.
    Thursday, December 3, 2009 7:21 PM
  • Hi Mark,

    Just finished digging through the WHS logs... don't see any problems in there. Only event that's showing up are the 4:30 AM events. Not my manual attempts (about 5 of them) around 10:00 PM.
    Friday, December 4, 2009 3:38 AM
  • Stan:

    What that means is that there was no communication between your PC and the server during your 10 PM tests. In thinking about this, I am suspicious about Windows networking. It could be that the network comes up too slowly on the machine when it wakes, or it could be Windows networking that's confusing the issue.

    If your Win 7 PC was the master browser on the network and you then put the machine to sleep, some other box on the network will assume the role of master browser and will build and publish the network's browse lists. I've seen it take many minutes after a master browser election before you are able to find machines by browsing the network or by using UNC paths. So if you are testing by putting the Win 7 machine to sleep and then having it wake a few minutes later, it could be that your tests occur too soon after a master browser election and your PC can't locate the server on the network because Windows networking isn't functioning yet. But when you test from your user account while the PC is awake and network browsing is functioning, then there is no problem locating the server. Also, when you test in the middle of the night, there has been plenty of time for the WHS to become the master browser.

    It would be interesting to test this theory. One way is to repeat your previous ping test tonight to find out. Set up a temporary scheduled task to wake the PC, have the task use the Stan user account, and have the task do a ping server > Desktop\ping.txt (substitute the name of your server). Put the PC into sleep mode and check the file on your desktop later for the ping results.

    If it's a Windows networking issue then there are fixes for that. The simplest is to use a static IP address on the server, and to put an entry in your hosts file for the server, referencing its fixed IP address. Another is to force the server to always be the master browser by a registry edit. But first test this to see if networking is the cause.

    Friday, December 4, 2009 3:56 AM
  • Hi Mark,

    I think you're onto something!

    Here's my ping result:

    Ping request could not find host homeserver. Please check the name and try again.

    I tested the task before sleeping and it worked, so this is a legit failure due to waking up.

    Is there a way to maybe delay the start of the backup task by a few minutes before going off?

    Or maybe, can I get around this by adding the server to my hosts file?
    Friday, December 4, 2009 4:46 AM
  • Stan:

    Bingo! This is probably at the heart of the issue with your tests in the evenings. Windows networking strikes again. If my suspicion is correct, the change of the master browser on the network right after your PC goes to sleep is the cause of the inability to communicate with the server. While you could delay after waking, it sometimes takes 10 - 20 minutes after a change in master browser has occurred and the new master browser has crawled the network looking for PCs and has gotten everything straightened out again. A better idea is to assign your server a fixed IP address and then enter it in the hosts file on all of your PCs.

    If you really want to kill the problem, set a fixed IP for the server and also force the server to always be the master browser. Do this by setting IsDomainMaster to true on the server and to false on all other PCs, and by setting MaintainServerList to true on the server and to auto on all other PCs. The registry keys are at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters.

    Here is an article with a description of how this works: http://www.windowsnetworking.com/kbase/WindowsTips/WindowsNT/RegistryTips/Network/PreferredMasterBrowser.html
    Friday, December 4, 2009 1:56 PM
  • Thanks Mark,

    Sounds like that should take care of the manual scheduler problems!

    As for the AM tests, it appears we've got the culprit nailed down... pointing the finger at the mouse is starting to look like the best bet.

    As you know, last night I disabled all the scheduled tasks and re-enabled the WHSConnector wakeup option. I also turned my mouse off (which unfortunately means I can't charge it, because the charger powers it if it's on the pedestal). Got up this morning and a backup was done *and* the computer was sleeping.

    I think I may be a victim of my mouse's sensitivity or drivers, I'm not sure which yet. I'm going to have to play around a bit with placement of the pedestal in order to see if it's a lift-off issue that can be solved by just moving things farther from the sensor.

    I'm also going to continue working on getting the scheduler option that we've been working on up and running as well. If all else fails, I'm probably going to have to resort to that since we can force the computer to sleep when we're done.

    I'll try to get those networking changes in later today to see if that'll clear up the wakeup problem.

    Thanks again!
    Friday, December 4, 2009 5:24 PM
  • Sounds like you're getting there. Is the mouse charged via USB when you put it in the cradle, or is it powered from a mains adaptor? If the latter, you could always just unplug the USB before you go to bed, leaving the mouse on charge.
    Sunday, December 6, 2009 4:26 PM
  • Hi Richard,

    Unfortunately, the cradle is powered by the USB port. The mouse is capable of operating in both wired and wireless mode (there's a cable that can be plugged in). When on the cradle it switched into wired mode and reactivates. The off switch only turns off the wireless mode.

    I think we have it solved, though... moved the cradle to increase the distance between the mouse and the stuff under it.
    Sunday, December 6, 2009 5:41 PM
  • Hi Mark,

    I think we have a winner.

    The problem appears to have been "solved" by repossitioning the charging pedestal for the mouse. There was a numeric keyboard under the mouse when it was on the charger. The keypad was about 1.5 inches away, so the sensor shouldn't have been able to pick it up. I think that the sensor was still barely registering the surface causing it to think movement had occurred at random intervals. I guess this thing has some crazy sensitivity / lift-off distance.

    By moving the pedestal, there's now nothing under the mouse for about 2.5 inches (that would be table) which appears to finally be far enough to lose the phantom movements.

    It's now been 3 days since I've done the move and I've had 3 mornings with the computer asleep each time.

    Thanks again for all of the help in trouble shooting the matter. I'm keeping our notes on the manual task in case the problem creeps back up again and I think I've learned a lot about task scheduler that can be useful for other things in the future.

    Thanks again!

    Stan
    Sunday, December 6, 2009 5:47 PM
  • Stan:

    That sounds great. Funny that it would turn out to be such a simple thing, although we got confused by the other symptom (unable to schedule a manual backup due to networking issues after resuming from sleep). You're right about Task Scheduler - it is extremely versatile. I have used it to "patch" little problems until they are officially fixed by Microsoft.

    I've enjoyed the troubleshooting exercise, so you're quite welcome.
    Sunday, December 6, 2009 5:58 PM
  • Thanks again Mark!

    Haha, I should have knocked on wood... it was awake again this morning. But... I'm pretty sure we've found an extremely strong correlation with the mouse. As I recall, I didn't have a 100% succeess rate in Vista either... will continue monitoring this over the next week to see what the trend is. :)

    Stan
    Tuesday, December 8, 2009 9:53 AM
  • Stan:

    Perhaps you need to make a special "mouse house" out of dark fabric to keep your little rodent warm at night (and in the dark).
    Tuesday, December 8, 2009 1:18 PM
  • Haha, that would be funny :)

    Got up this morning and the little guy was sleeping again like it's supposed to. Probably going to be hit or miss for a while as I try to figure the details out.

    4 in 5 isn't bad so far :P

    Stan
    Wednesday, December 9, 2009 9:08 AM