locked
Why does my client look for the old CRM server? RRS feed

  • Question

  • Hi.

    Due to various reasons we had to install a secondary server in our CRM "farm". The old server is called GONS908 and the new server is called GONS951. These both talk to a common SQL-server.

    The second server was installed by doing a custom install with both roles, pointing to an existing deployment on the SQL-server.

    After I turned off the old CRM server (GONS908) we noted that certain CRM-clients (that is, the Outlook plug in) could not connect to the CRM deployment (we are using an alias for the server and redirected this alias to the new server). When we run the configuration guide the guide complains that it can't find the GONS908 server.

    Earlier today I noticed that I had forgotten to delete GONS908 from the deployment but even after I deleted GONS908 the configuration guide still looks for it.

    The registry on the client does not mention GONS908 anywhere. I've done a complete uninstall/install of the CRM-client w/o any luck.

    I've even gone through the tables in the CRM config-DB trying to locate any mention of GONS908 but I can't find anything (even though I'm certain that there's one place that I'm missing but I can't find where to look even when googling for it).

    Any ideas on how to solve this? 
    Tuesday, December 15, 2009 1:15 PM

Answers

  • Oopss sorry =)

    Let me help you ...

    In the database MSCRM_config  look for DeploymentProperties table and select those 3 columns:

    'AsyncSdkRootDomain'
    'ADSdkRootDomain'
    'ADWebApplicationRootDomain'

    Use this sentence:

    SELECT
    ColumnName ,NVarCharColumn FROM dbo.DeploymentProperties
    WHERE
    ColumnName IN ('ADSdkRootDomain','ADWebApplicationRootDomain','AsyncSdkRootDomain')

    Please update those colunmns with the correct server and port that you use for ur crm implementation

    USE MSCRM_CONFIG
    Update DeploymentProperties SET NVarCharColumn = '<server>:<port>' WHERE ColumnName = 'AsyncSdkRootDomain'
    Update DeploymentProperties SET NvarCharColumn = '<server>:<port>' WHERE ColumnName = 'ADSdkRootDomain'
    Update DeploymentProperties SET NvarCharColumn = '<server>:<port>' WHERE ColumnName = 'ADWebApplicationRootDomain'


    Try to install crm for Outlook again ... and tells us if your problem has been resolved.


    Jimmy Larrauri
    • Proposed as answer by Mark-Masiak Monday, January 11, 2010 6:27 PM
    • Marked as answer by Jim Glass Jr Wednesday, January 20, 2010 5:43 PM
    Tuesday, December 15, 2009 4:47 PM
    Moderator

All replies

  • Hmmm......    That like is in Spanish.

    Yo no se.

    Curtis Spanburgh
    Tuesday, December 15, 2009 2:35 PM
    Moderator
  • Even though my Spanish is almost non-existing I got the basic idea and those were the settings I was looking for.

    It doesn't matter that I update them (via the Deployment Config Tool: http://support.microsoft.com/default.aspx/kb/947423) though. I changed them as follows:

    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain:gons951:80
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain:gons951:80

    The configuration client doesn't complain about not being able to connect to GONS908, instead it hangs for up to 5 minutes before reporting that the server isn't available (our client is in Swedish why I can't give you a useful error message).

    The server is available at GONS951 via ping. The web server on GONS951 has no host headers. The registry setting "ServerUrl" in GONS951 has the value http://<crm server alias>/MSCRMServices. The value for the "ADRootDomainScheme" entry in the config DB is "http".

    This is what the actual entries in the DB looks like for the RootDomains:
    ADSdkRootDomain gons951:80
    ADWebApplicationRootDomain gons951:80

    I'm slowly losing my marbles here so any and all help is very much appreciated.

    Thanks in advance.
    Tuesday, December 15, 2009 3:20 PM
  • Oopss sorry =)

    Let me help you ...

    In the database MSCRM_config  look for DeploymentProperties table and select those 3 columns:

    'AsyncSdkRootDomain'
    'ADSdkRootDomain'
    'ADWebApplicationRootDomain'

    Use this sentence:

    SELECT
    ColumnName ,NVarCharColumn FROM dbo.DeploymentProperties
    WHERE
    ColumnName IN ('ADSdkRootDomain','ADWebApplicationRootDomain','AsyncSdkRootDomain')

    Please update those colunmns with the correct server and port that you use for ur crm implementation

    USE MSCRM_CONFIG
    Update DeploymentProperties SET NVarCharColumn = '<server>:<port>' WHERE ColumnName = 'AsyncSdkRootDomain'
    Update DeploymentProperties SET NvarCharColumn = '<server>:<port>' WHERE ColumnName = 'ADSdkRootDomain'
    Update DeploymentProperties SET NvarCharColumn = '<server>:<port>' WHERE ColumnName = 'ADWebApplicationRootDomain'


    Try to install crm for Outlook again ... and tells us if your problem has been resolved.


    Jimmy Larrauri
    • Proposed as answer by Mark-Masiak Monday, January 11, 2010 6:27 PM
    • Marked as answer by Jim Glass Jr Wednesday, January 20, 2010 5:43 PM
    Tuesday, December 15, 2009 4:47 PM
    Moderator
  • Hi Jimmy.

    I have updated the variables in the DB to the correct ones although I used the Microsoft tool for doing it.

    Do I really need to reinstall the CRM-client for the changes to take effect? If so, why? Where does it store it's settings?

    EDIT: I forgot to mention in my other post that the url we use to access is in the form of https://organisation.crm.domain.com and not the GONS951 server name. Does this matter?

    Thanks.
    Wednesday, December 16, 2009 7:26 AM
  • Hi Martin,

    it looks like you are using IFD. Please check the settings for IfdRootDomainScheme, IfdSdkRootDomain and IfdWebApplicationRootDomain in the DeploymentProperties Table.
    You should use the IFDConfigTool in order to update these settings, if needed.
    • Marked as answer by Jim Glass Jr Tuesday, December 29, 2009 3:15 PM
    • Unmarked as answer by Martin Edelius Monday, January 11, 2010 1:15 PM
    Wednesday, December 16, 2009 4:08 PM
  • Hi Martin,

    Please check this url

    Look the second picture ... Configuration Wizard ..

    Check the values in Intranet url and external web adress .




    Jimmy Larrauri
    • Marked as answer by Jim Glass Jr Tuesday, December 29, 2009 3:15 PM
    • Unmarked as answer by Martin Edelius Monday, January 11, 2010 1:15 PM
    Wednesday, December 16, 2009 4:40 PM
    Moderator
  • We are not using IFD, just an alias for the CRM front end so that we don't have to update our clients everytime we change servers.

    Or are you saying that I need to use IFD just because I use a FQDN and not a specific single server name?
    Monday, December 28, 2009 9:32 AM
  • I have updated the IFD settings (despite us not using IFD) and it didn't help. I set domain root scheme to "https" and the sdk/webapp root settings to "GONS951:443" w/o luck.

    I edited them to "http" and "GONS951:80" and it didn't help.

    I cleared out the settings in the config DB for all domain root settings and no luck.

    No matter what I try I now get "Server was unable to process request" when I run the config client - no matter what address I use for the server.

    I've restarted the async service several times in between.

    The only error I have in the application log is from the AsyncService and concerns time outs to the SQL server (due to another problem we have with this installation).

    Any ideas?
    Monday, January 11, 2010 1:21 PM
  • Hi MArtin,

    have you try to reconfigure your CRM Settings in the Client with the configuration wizzard?

    Have you check the settings in the registry? The client stores his connection information in the registry.
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Monday, January 11, 2010 2:00 PM
  • This is when installing the client for the first time on a clean machine.

    I checked and there are no settings for MSCRMClient in the registry.
    Monday, January 11, 2010 2:35 PM
  • on your new server did you set the ifd ip range correctly? Is the new and old server in the same subnet?

    can you get to your crm server in IE with http://GONS951/


    SJ
    Monday, January 11, 2010 3:23 PM
  • I have not configured IFD as we are not using IFD. All servers are in the same subnet, the same as the clients.

    I can surf to the server at https://organisation.crm.domain.com but not at http://gons951, here I get a 401 unauthorized error.

    I now also get a 401 error when I run the configuration guide.
    Monday, January 11, 2010 3:38 PM
  • https://organisation.crm.domain.com is an IFD connection. None IFD would be http://computername/OrgName.

    set the registry key for ifdinternalnetworkaddress to your iprange. ip-subnet eg: 10.0.0.0-255.255.255.0

    set your IFD settings to use a domain.tld format and not the computername. You can use a fake domain name or erase the values.

    if you are getting 401 in both those locations chances are your async service is also.

    SJ
    Monday, January 11, 2010 4:19 PM
  • I was getting a similar error to you I had a missing entry in the database MSCRM_config  look for DeploymentProperties table and select those 3 columns:

    'AsyncSdkRootDomain'
    'ADSdkRootDomain'
    'ADWebApplicationRootDomain'

    In IIS I have configured three entries for the CRM:

    {default server}:5555  (so hostheader blank port 5555) http://GONS951:5555
    crm:80 (for intranet)
    crm.domainname.com (for external access)
    https:crm.domainname.com:5556 for secure

    --------------------------------
    I have a network ptocol watcher on my antivirus which shows that the configuration wizard looks for the entry in {'AsyncSdkRootDomain', 'ADSdkRootDomain', 'ADWebApplicationRootDomain'} for the Intranet Address and ignors what you put in there.
    ---------------------------------
    I would therefore suggest that you create the http 5555 entry in IIS for the server GONS951:5555 but you can use the secure https in the configuration which Outlook actually uses. I've just tested this and it works

    Mark Masiak Infologic.uk.com
    Monday, January 11, 2010 6:41 PM
  • @Sean: Ok, I was under the impression that an IFD involved more than just using a FQDN for accessing the server. I tried setting the registry key but it made no difference.

    What did you mean with " your async service is also"? Also what?

    @Mark: I assume you mean that I need to enter values for those three fields in the DB? If so, what values? I have "GONS951" in them all atm.

    I also added the host headers that you mention but now I'm back at "Server could not process request".
    Tuesday, January 12, 2010 12:29 PM
  • have you resolved this now Martin?
    Mark Masiak Infologic.uk.com
    Thursday, January 21, 2010 5:20 PM
  • Hi Mark.

    No, my previous reply still applies.

    I have not had time to pursue this further and will most likely enlist an external firm to solve this and my other CRM-related problem.

    Thanks for asking.
    Friday, January 22, 2010 10:39 AM
  • as there have been a number of changes can i get a heads up on what you have entered where:

    1. what do the database entries say in

    MSCRM_config  look for DeploymentProperties table and select those 3 columns:

    'AsyncSdkRootDomain'
    'ADSdkRootDomain'
    'ADWebApplicationRootDomain'

    2. can you navigate to the crm in the browser internally at:

     https://organisation.crm.domain.com???
     http://organisation.crm.domain.com
     :port??https://organisation.crm.domain.com
     :5555http://organisation.crm.domain.com
     http://GONS951:5555
     http://GONS951:80

    are there others setup in IIS and can you get to them?

    3. on the CRM Server run 'CRM Demployment Manager' what is listed under

    Servers: name/status/version/roles

    in the Organisation section is the instance Status 'Enabled' and click properties, is the SQL Server GONS951 and the SRS URL http://GONS951/reportserver

    4. in IIS for the 'Microsoft Dynamics' and 'default web site' and 'sharepoint'  [Web Site] tab [Adavanced] can you list the entries for: IP/Port/Host Header


    and the SSL Port


    5. in IIS [Directory Security] Authentication and Access control [edit] which boxes are ticked?



    6. what are the errors in the Event log CRM/SQL/IIS on the server inc 'async service'



    7. on the CRM Client install, just in case as some times the obvious is overlooked, has the user being installed got the correct security permissions set to use outlook with CRM



    8. is there anything in the Clients Hosts file relating to CRM/CRM Server or it's URLs?


    mail me if there is anything that you don't want published, mark.masiak@infologic.uk.com
    :80
    :port
    Mark Masiak Infologic.uk.com
    Friday, January 22, 2010 1:39 PM