locked
CRM Dynamics 2011 silent installation failure RRS feed

  • Question

  • Hello,

    I'm trying to deploy CRM Dynamics 2011 on a Windows7 32bit machine, using SCCM 2007.

    The commandline used is:

    "SetupClient.exe" /config "Default_Client_Config.xml" REBOOT=ReallySuppress ALLOWRUN=1 INSTALLLEVEL=3 /q /l "C:\Windows\System32\CCM\Logs\\MS Dynamics CRM Outlook Client_Install.log"

    On some machines the installation routine fails unexpected, according to the log file:

    14:43:11|   Info| === Setup bootstrap logging started 9/19/2012 2:43:11 PM ===
    14:43:11|   Info| Bootstrap version: 5.0.9690.1992.
    14:43:11|   Info| User: SYSTEM.
    14:43:11|   Info| Invoked with command line: "C:\Windows\system32\CCM\Cache\000008F6.1.S-1-5-21-119559289-1840127793-336618761-97149\MS Dynamics CRM 2011 REXIS Outlook Client EN\SetupClient.exe" /config "C:\Windows\system32\CCM\Cache\000008F6.1.S-1-5-21-119559289-1840127793-336618761-97149\MS Dynamics CRM 2011 REXIS Outlook Client EN\Default_Client_Config.xml" REBOOT=ReallySuppress ALLOWRUN=1 INSTALLLEVEL=3 /q /l "C:\Windows\System32\CCM\Logs\\MS Dynamics CRM Outlook Client REXIS 2011 EN_Install.log"
    14:43:11|   Info| Running Microsoft Dynamic CRM 5 for Outlook at : C:\Windows\system32\CCM\Cache\000008F6.1.S-1-5-21-119559289-1840127793-336618761-97149\MS Dynamics CRM 2011 REXIS Outlook Client EN
    14:43:11|   Info| Copying installer files to local directory: 
    14:43:11|   Info| Package: C:\Windows\system32\CCM\Cache\000008F6.1.S-1-5-21-119559289-1840127793-336618761-97149\MS Dynamics CRM 2011 REXIS Outlook Client EN\Client.msi, Options: ADDLOCAL="Installer" INSTALLDIR="C:\Windows\TEMP\MSCRM_{2F10E752-3691-406F-AF35-0DC04A18AA04}" TARGETDIR="C:\Windows\TEMP\MSCRM_{2F10E752-3691-406F-AF35-0DC04A18AA04}" ALLOWRUN=1
    14:43:18|   Info| Loading bootstrap library C:\Windows\TEMP\MSCRM_{2F10E752-3691-406F-AF35-0DC04A18AA04}\ClientSetup.dll
    14:43:18|   Info| Microsoft Dynamics CRM for Outlook is not currently installed.
    14:43:24|   Info| === Setup bootstrap logging ended 9/19/2012 2:43:24 PM ===

    14:43:18|   Info| Bootstrap version: 5.0.9690.1992.
    14:43:18|   Info| User: SYSTEM.
    14:43:18|   Info| Initializing COM.
    14:43:18|   Info| Initialized COM.
    14:43:18|   Info| Current OS Version: 6.1.7600
    14:43:18|   Info|   ServicePack:
    14:43:18|   Info|   System Type: Workstation
    14:43:18|   Info|   Suite Mask: 0x0100
    14:43:24|   Info| IsIeInstalled=1
    14:43:24|   Info| .NET version found is 4.0.30319.0
    14:43:24|   Info| IsDotNetInstalled=1
    14:43:24|   Info| Uninitializing COM.
    14:43:24|   Info| Uninitialized COM.
    14:43:28|   Info| Clean up the BITS downloader.

    ted 9/19/2012 2:43:24 PM ===
    14:43:24|   Info| Bootstrap version: 5.0.9690.1992.
    14:43:24|   Info| User: SYSTEM.
    14:43:24|  Error| Installation of Microsoft Dynamics CRM for Outlook failed.
    14:43:28|   Info| Clean up the BITS downloader.

    14:43:28|   Info| Clean up the BITS downloader.

    14:43:28|   Info| === Setup bootstrap logging ended 9/19/2012 2:43:28 PM ===

    As you can see, the log is rather short and is not giving any reason for the failure. I really don't know what's the issue there.

    Any hint is greatly appreciated.

    Cheers


    • Edited by dryce Thursday, September 20, 2012 6:49 AM
    Thursday, September 20, 2012 6:45 AM

All replies

  • Are you sure you are installing the base installation instead of just a Rollup? Can you install it manually successfully?

    MS CRM Bing'd - http://bingsoft.wordpress.com
    Dynamics XRM Tools CRM 4 to CRM 2011 JavaScript Converter Tool
    CRM 2011 OData Query Designer
    CRM 2011 Metadata Browser
    CRM Forum Guidance

    Monday, January 7, 2013 2:42 PM
    Moderator
  • Have you tried /LV instead of /L so you get a verbose log?

    In the folder where your log is, do you also have a crm50clientmsi.log which I think is created once the install bootstrap bit has done its "pre-flight checks" and hands off to the MSI to do the actual installation? (this is usually the case when installing directly from command line / batch file, not sure if it holds true for SCCM)


    Hope this helps.
    Adam Vero, Microsoft Certified Trainer | Microsoft Community Contributor 2011
    Blog: Getting IT Right

    Saturday, January 12, 2013 9:03 AM
  • I'm having similar issues that turned out to be a pre-requisite component was updated with windows update and is newer than the installer. As a result, the installter throws an error stating so and kills the installation. I've not figured out how to get around it yet, but was able to verify the issue in the error log as well as by running the install manually. Running the install manually and not using the /q switch let the error message pop up and you could view the install log from the interface to see that it was failing on the Microsoft Online Services Sign-in Assistant install though the error was a 1603 generic error.

    My thread is here if you're interested: http://social.microsoft.com/Forums/en-US/crmdeployment/thread/50a23662-1845-4c03-8b43-16f31694efa3

    I'm using the new CRM client installer that was released on 1/20 with all updates applied. Outlook 2010 on win 7 x64.


    • Edited by RSchauer77 Monday, February 4, 2013 7:11 PM
    • Proposed as answer by RSchauer77 Thursday, October 10, 2013 10:27 PM
    Monday, February 4, 2013 7:10 PM