locked
Crm 2013 form , getting error- Object doesn't support this property. error url-_common/JsProvider.ashx? RRS feed

  • Question

  • Hi Friends,

    Recently we migrated our organization to CRM 2013 from CRM 2011. After migration we are facing the issue in onload of form of one entity.

    It shows error on page messge at bottom and when we refresh(F5) the same form we are getting error dialog.

    Below are the error details.

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
       <Message>Object doesn't support this property or method</Message>
       <Line>2</Line>
       <URL>/_common/JsProvider.ashx?ids=1959345455-451858892-1713948411-1279630416-1250882489-367493978-19173614-574022791-696891199-2007586035-1552783829&ver=-547989949</URL>
       <PageURL>/main.aspx?etc=10073&extraqs=%3fetc%3d10073&pagemode=iframe&pagetype=entityrecord</PageURL>
       <Function>anonymous(control){if(IsNull(control))returnnull;for(var$v_0=Mscrm.RefreshPageHandler.get_uiManager().controls,$v_1=0;$v_1<control.length;$v_1++){var$v_2=control.eq($v_1).children().first();if(!IsNull($v_2)&&!IsNull($v_2.attr("id"))){var$v_3=$v_0.get($v_2</Function>
       <CallStack>
        <Function>anonymous(control){if(IsNull(control))returnnull;for(var$v_0=Mscrm.RefreshPageHandler.get_uiManager().controls,$v_1=0;$v_1<control.length;$v_1++){var$v_2=control.eq($v_1).children().first();if(!IsNull($v_2)&&!IsNull($v_2.attr("id"))){var$v_3=$v_0.get($v_2.attr("id"));if(!IsNull($v_3)&&$v_3.getVisible())if(!$v_3.get_disabled())return$v_3}}returnnull}</Function>
        <Function>anonymous(formData){Mscrm.Utilities.traceCurrentTime("FocusControlOnInitEntry");if(!this.isRefreshForm()||Mscrm.Utilities.isMobileRefresh())return;var$v_0=!IsNull(formData["_entitydisabled"])&&formData["_entitydisabled"]==="1";if(!$v_0&&IsNull(Mscrm.InlineEditUtilities.get_activeControl())){var$v_1=this.getRootControlsContainerForInitialFocus(formData),$v_2=this.getFirstEnabledControlView($v_1);if(IsNull($v_2)){$v_1=this.$4t_1();$v_2=this.getFirstEnabledControlView($v_1)}if(!IsNull($v_2))if(Mscrm.InlineEditDataService.isNew()){var$$t_4=$v_2;window.setTimeout($$t_4.$$d_goToEditState||($$t_4.$$d_goToEditState=Function.createDelegate($$t_4,$$t_4.goToEditState)),0)}else{var$$t_5=$v_2;window.setTimeout($$t_5.$$d_goToPreFocusState||($$t_5.$$d_goToPreFocusState=Function.createDelegate($$t_5,$$t_5.goToPreFocusState)),0)}}Mscrm.Utilities.traceCurrentTime("FocusControlOnInitExit")}</Function>
        <Function>anonymous(){if($$t_1.isRefreshForm()){$$t_1.focusControlOnInit($$t_1._formData);!IsNull(Mscrm.ActivityContainer)&&Mscrm.ActivityContainer.set_parentFormInitializationCompleted(true)}}</Function>
        <Function>anonymous(){var$$t_1=this,$v_0=function(){if($$t_1.isRefreshForm()){$$t_1.focusControlOnInit($$t_1._formData);!IsNull(Mscrm.ActivityContainer)&&Mscrm.ActivityContainer.set_parentFormInitializationCompleted(true)}};this.$3l_1($v_0);!this.$2N_1()&&$v_0()}</Function>
        <Function>anonymous(){returnb.apply(a,arguments)}</Function>
       </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
       <BrowserUserAgent>Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Pcy8.0.7601.17514-10512-1019-52)</BrowserUserAgent>
       <BrowserLanguage>en-us</BrowserLanguage>
       <SystemLanguage>en-us</SystemLanguage>
       <UserLanguage>en-us</UserLanguage>
       <ScreenResolution>1396x785</ScreenResolution>
       <ClientName>Web</ClientName>
       <ClientTime>2014-05-08T10:29:06</ClientTime>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>1033</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>1033</UserCulture>
        <OrgID>{064F1DC6-2F2D-E111-8179-005056A50018}</OrgID>
        <UserID>{057B8099-F499-E311-949F-005056A50018}</UserID>
        <CRMVersion>6.0.0.809</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

    But couldn't understand from where exactly this error is occuring. Did anyone face this issue?

    Looking for your support. Kndly help here..

    Thanks,

    Nithya



    Thursday, May 8, 2014 5:17 AM

All replies

  • still getting this error?
    Thursday, October 16, 2014 1:12 PM
  • No. The error was due to the Custom  aspx page in the Iframe.
    Saturday, November 1, 2014 6:31 AM
  • Thanks for let me know. I have an out-of-the-box iFrame.

    Monday, November 3, 2014 9:04 AM