locked
SigmaTel Audio Problems RRS feed

  • Question

  • Hi

    We are trying to configure the Conference XP Audio settings, on a Tablet PC which uses Sigma Tel Audio Hardware.

    On Audio/Video Settings window we get both 'Advanced Settings' and 'Test Audio' buttons disabled. And when we push the 'Troubleshooting Log' button we get the following exception:

    /***********************************************/

    Microphones

    SigmaTel Audio, @device:cm:{33D9A762-90C8-11D0-BD43-00A0C911CE86}\SigmaTel Audio

    Speakers

    Default System Device, @device:cm:{E0F158E1-CB04-11D0-BD4E-00A0C911CE86}\Default DirectSound Device

    SigmaTel Audio, @device:cm:{E0F158E1-CB04-11D0-BD4E-00A0C911CE86}\DirectSound: SigmaTel Audio

    Initializing microphone - SigmaTel Audio, @device:cm:{33D9A762-90C8-11D0-BD43-00A0C911CE86}\SigmaTel Audio

    Error no especificado

    System.Runtime.InteropServices.COMException (0x80004005): Error no especificado

    at MSR.LST.MDShow.IAMAudioInputMixer.put_Enable(Boolean fEnable)

    at MSR.LST.MDShow.AudioSource.set_InputPin(IPin value) in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Filters.cs:line 1558

    at MSR.LST.MDShow.Filter.InitializeInputPin() in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Filters.cs:line 693

    at MSR.LST.MDShow.Filter.AddedToGraph(FilgraphManager fgm) in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Filters.cs:line 445

    at MSR.LST.MDShow.SourceFilter.AddedToGraph(FilgraphManager fgm) in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Filters.cs:line 1003

    at MSR.LST.MDShow.CaptureGraph..ctor(FilterInfo fiSource) in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Graphs.cs:line 173

    at MSR.LST.MDShow.AudioCaptureGraph..ctor(FilterInfo fiSource) in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Graphs.cs:line 461

    at MSR.LST.ConferenceXP.AudioCapability.CreateAudioGraph(FilterInfo fi) in d:\sd\daily\lst\source\MSR.LST.ConferenceXP\AVCapabilities\AudioCapability.cs:line 536

    at MSR.LST.ConferenceXP.AudioCapability.ActivateMicrophone() in d:\sd\daily\lst\source\MSR.LST.ConferenceXP\AVCapabilities\AudioCapability.cs:line 152

    at MSR.LST.ConferenceXP.frmAVDevices.ActivateAudioCapability(FilterInfo fi) in d:\sd\daily\lst\source\MSR.LST.ConferenceXP\BarUI\frmAVDevices.cs:line 934

    at MSR.LST.ConferenceXP.frmAVDevices.cboMicrophones_SelectedIndexChanged(Object sender, EventArgs e) in d:\sd\daily\lst\source\MSR.LST.ConferenceXP\BarUI\frmAVDevices.cs:line 886

     /*****************************************************************/

    Any help would be appreciated. Thank you in advance.

     

    • Moved by Max Wang_1983 Thursday, April 28, 2011 10:36 PM Forum consolidation (From:Hardware)
    Wednesday, February 21, 2007 2:41 PM

Answers

  • Hi

    We were using ConferenceXP 3.5, but your question about the version made us install 4.0 version, and this solved the problem.

    Thanks for all.

    Nuria

    Thursday, February 22, 2007 12:49 PM

All replies

  • Well, that's not good.  :-(  I would like to know...

    Which version of ConferenceXP are you using?

    Which tablet?

    Have you installed the latest audio driver?

    Are you capable of debugging the code at MSR.LST.MDShow.AudioSource.set_InputPin(IPin value) in d:\sd\daily\lst\source\MSR.LST.MDShow\MDShowManager\Filters.cs:line 1558

    and following to see which pin it is trying to do the set on?

    Thanks.

    JVE

    Wednesday, February 21, 2007 3:52 PM
  • Hi

    We were using ConferenceXP 3.5, but your question about the version made us install 4.0 version, and this solved the problem.

    Thanks for all.

    Nuria

    Thursday, February 22, 2007 12:49 PM
  • Excellent.  That sounded very similar to a bug I fixed, which is why I was either a little surprised (that it wasn't fixed) or confused (about what the problem was).  :-)

    JVE

    Thursday, February 22, 2007 4:18 PM
  • ya me to experience the same problem ... thanks for the post..
    Wednesday, May 9, 2007 10:28 AM