locked
Cannot install connector software because of a windows installer problem RRS feed

  • Question

  •  

    I am having trouble installing the connector software on 4 of my 6 home computers.
    I have tried running setup.exe from the connector CD and from the  home server software share.  I get the same result each time.  Each time the windows installer menu comes on with only the choice to click OK.  That is as far as I can get.  On the one computer that it did install, I don't seem to have any issues. 
     
    I have reinstalled the windows installer and seem to have the most up-to-date version.  What do I need to do to get past this error?
     
    Can I turn on some advanced logging to see what the issue is?  Event viewer is not showing errors.

    Thank you,
    Jim
     
     
    Monday, December 3, 2007 5:43 AM

Answers

  • Interesting. It's memorable, and I"m always curious as to how those sorts of nicknames come about. Thanks!

    It sounds like rearranging your drives was a worthwhile exercise, so hopefully you're good to go now.
    • Marked as answer by StapleBench Friday, May 18, 2012 4:43 PM
    Monday, August 25, 2008 2:19 AM
    Moderator

All replies

  • You could try copying it to a local disk on the computer you are tying to install it from and run it instead of off the share (ie desktop)..  No reason why it shouldn't work by running it from the share, but it's worth a try.
    Monday, December 3, 2007 7:01 AM
  • I ran into a similar issue with my media Center PC.

    Turned out that DNS was not registering properly.

    I simply added the name resolution to the hosts file and away it went.

    I am running static IPS in my home because I am doing quite a bit of tasks on all machines.

    For some reason my 1 out of 5 machines decided that the DNS was not going to talk to the WHS server via name resolution and only by IP.

    So I forced it down its throat and it worked.

    You might want to try and disable anti virus and spyware programs as well.

    The software makes a bunch of outbound connections on some uncommon ports.

    If your running Symantic Security sweet then chances are by default ports are being blocked.

    Try disabling this stuff and re run setup.




    Monday, December 3, 2007 12:58 PM
  •  

    Tried running it from my local hard drive and got the same result. 

     

    I can reach the \\homeserver from every computer without any delay.  I added an entry into the host file and even have WINS working so I don't think it is a connection issue.  My whole network is setup for static IP.  All my workstations can get into the file shares I created.  I can even access the home server from the outside over the internet.

     

    I tried the suggestion about disabling virus/malware protection and got the same result.  (Have not used a symantec produduct since y2k )

     

    I have reinstalled the newest windows installer and that did not help.

     

     

     Below is the text from the windows installer window that pops up after I run setup.

     

     

    Windows ® Installer. V 3.01.4000.1823

    msiexec /Option <Required Parameter> [Optional Parameter]

    Install Options

    </package | /i> <Product.msi>

    Installs or configures a product

    /a <Product.msi>

    Administrative install - Installs a product on the network

    /j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]

    Advertises a product - m to all users, u to current user

    </uninstall | /x> <Product.msi | ProductCode>

    Uninstalls the product

    Display Options

    /quiet

    Quiet mode, no user interaction

    /passive

    Unattended mode - progress bar only

    /q[n|b|r|f]

    Sets user interface level

    n - No UI

    b - Basic UI

    r - Reduced UI

    f - Full UI (default)

    /help

    Help information

    Restart Options

    /norestart

    Do not restart after the installation is complete

    /promptrestart

    Prompts the user for restart if necessary

    /forcerestart

    Always restart the computer after installation

    Logging Options

    /l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>

    i - Status messages

    w - Nonfatal warnings

    e - All error messages

    a - Start up of actions

    r - Action-specific records

    u - User requests

    c - Initial UI parameters

    m - Out-of-memory or fatal exit information

    o - Out-of-disk-space messages

    p - Terminal properties

    v - Verbose output

    x - Extra debugging information

    + - Append to existing log file

    ! - Flush each line to the log

    * - Log all information, except for v and x options

    /log <LogFile>

    Equivalent of /l* <LogFile>

    Update Options

    /update <Update1.msp>[;Update2.msp]

    Applies update(s)

    /uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>

    Remove update(s) for a product

    Repair Options

    /f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>

    Repairs a product

    p - only if file is missing

    o - if file is missing or an older version is installed (default)

    e - if file is missing or an equal or older version is installed

    d - if file is missing or a different version is installed

    c - if file is missing or checksum does not match the calculated value

    a - forces all files to be reinstalled

    u - all required user-specific registry entries (default)

    m - all required computer-specific registry entries (default)

    s - all existing shortcuts (default)

    v - runs from source and recaches local package

    Setting Public Properties

    [PROPERTY=PropertyValue]

    Consult the Windows ® Installer SDK for additional documentation on the

    command line syntax.

    Copyright © Microsoft Corporation. All rights reserved.

    Portions of this software are based in part on the work of the Independent JPEG Group.

    Monday, December 3, 2007 6:34 PM
  • If you go to the cmd prompt and type msiexec you get the same window I get if I try to run setup.exe to install the connector software. 

     

    I am stumped. 

    please help me out.

    Thursday, December 6, 2007 3:47 AM
  •  

    Why don't you try and run the install from the command line, like you did with msiexec as follows.

     

    msiexec /i "\\<yourservername>\software\Home Server Connector Software\whsconnector.msi"

    Thursday, January 24, 2008 10:29 PM

  • I believe that the problem was related to Autopatcher.  I sometimes got weird results on systems that had updates and features installed by Autopatcher.  The only clue though is on systems that did not have the autopatcher installed, the connector software worked.  If the system was patched with Autopatcher, then the connector software did not work. 

    Since my original issue, my trial ran out and I have reloaded most of my client computers without running Autopatcher.  I purchased WHS and I am in the process of manually backing up all my shares before I add the drives that were in the pool before, back in.  Reinstalling WHS documentation made it seem like the drive pool would magically be there after the reinstall but in my case they were not.  The drives were listed and I can add them but it seems to want to erase them first.  I will but first I want my data off.  I my have missed something about how to add the "old drive pool" back in without losing data.  In a few hours, I will have a backup and then I can move my "old pool" back in the current pool.  Once i have all my bits in the right place I will mess with the connector.

    Anyway, the connector install issue was most likly caused by the Autopatcher software.  It used to be a tech's best friend and having everything on windows update on disk save bandwidth and time. 
    Sunday, August 24, 2008 12:39 PM
  • Staple Bench (what kind of parents name their child Staple? Smile), when you need to do a reinstallation, you have to supply any storage drivers required for setup to see your drives in the initial graphical setup phase. And you should not have any non-storage pool drives connected at that time. If setup sees all your drives at that time, it should give you the option of a server reinstallation. Note that if you needed drivers to see your system disk, you'll need them again right after the first reboot into text-mode setup for Windows Server 2003 (at the "Press F6" prompt).
    Sunday, August 24, 2008 1:39 PM
    Moderator
  •  

    A long time ago my great great grandfather moved out west and started ranching.  The brand he used was a staple over a bench and has been registered and used for over a hundred years.  Sort of like a family trademark.  Now it is also used as a logo for my business and hence staple bench. 

     

    I did the reinstall option and it saw all my drives.  I screwed it up most likley when it was in the tombstone process of setup.  I was tired and it seemed stuck.  I rebooted and it restarted but I left it alone untill it compleated.  I did get my data off of the largest drive backed up but chose to rearrange my drives and start over fresh with a new install.  It seems to run much faster now anyway and my landing drive is much larger.  I will add my drives back into the pool and restore my data manually.  Hopefully all will be good.

     

    Thank you for the help all.

    Monday, August 25, 2008 12:00 AM
  • Interesting. It's memorable, and I"m always curious as to how those sorts of nicknames come about. Thanks!

    It sounds like rearranging your drives was a worthwhile exercise, so hopefully you're good to go now.
    • Marked as answer by StapleBench Friday, May 18, 2012 4:43 PM
    Monday, August 25, 2008 2:19 AM
    Moderator