none
Remote Posting Web Address Problem

    Question

  • Hi,

    I am not able to set up windows live writer. When I get to

    "Select blog type"

    I select wordpress (it is my own wordpress website hosted on hostgator/not a wordpress.com site)

    then it says:

    "Remote posting web address for your blog:

    http:// <hostname>  /  <wp_path>/smlrpc.php

    I have tried typing in everything I can think of; I have read every post I can find on the internet. It has now been six hours and I'm exhausted. You can't say I don't have perserverance.

    I type in http://www.myblogname.com/xmlrpc.php

    I have gone into my wordpress and enable remote access via xmlrpc.

    When I click "next" it says:

    "can't connect to your blog service:

    Server Error - The server reported an error with the following web address

    http://  popularlovequotes.com/ smlrpc.php

    503 Service Unavailable

    Please try fixing the problem and then try again"

    I would appreciate any help anyone could give me. I just don't know what else to try. I have tried many combinations of enteries.

    Thank you so much for taking the time to read this.

    **** the spaces in the url's are intentional as this forum does not allow links.

    Monday, September 24, 2012 12:48 AM

All replies

  • I too am having this issue although my error message is:

    Network Connection Error - Error attempting to connect to blog at:

    http://mysite.com/xmlrpc.php

    MovedPermanently: Moved Permanently

    You must correct this error before proceeding.

    Wednesday, November 28, 2012 1:51 AM
  • If you have not made changes to the remote posting URL in wordpress is http://itproguru.com/xmlrpc.php

    You also want to make sure remote publishing is enabled.   You can check this from inside your wordpress settings

    Dashboard - Settings - Writing - Remote Publishing  (<a href="http://<YourSite>/wp-admin/options-writing.php)">http://<YourSite>/wp-admin/options-writing.php)  Make sure <strong> XML-RPC </strong> checkbox is enabled.


    Saturday, December 8, 2012 1:57 PM
  • Look for the file xmlrpc.php in your wordpress folder structure.  It should be in the root of your website YourSite.com/xmlrpc.php  You will have to copy this file back to the root of your folder. I put a copy of a file up from a blog at http://ITProGuru.com/wp-content/uploads/2012/12/xmlrpc_php.txt You would need to rename the file to xmlrpc.php

    You also want to make sure remote publishing is enabled.   You can check this from inside your wordpress settings

    Dashboard - Settings - Writing - Remote Publishing  <a href="http:///wp-admin/options-writing.php">http://<YourSite>/wp-admin/options-writing.php  Make sure XML-RPC checkbox is enabled.

    Saturday, December 8, 2012 2:08 PM
  • I know this is an old post but the way i fixed this was to create a sub domain and then redirect the main domain to that domain and it all worked fine

    Thursday, November 22, 2018 5:04 PM