locked
CRM 2015 for Outlook SiteMap RRS feed

  • Question

  • Hi guys,

    I've implemented direct links to views in the CRM 2015 sitemap for a client. This works great when accessing CRM via the web, however; when using the Outlook client, clicking one of the links directs the user to the default view in an Outlook tab instead.

    I use the following format in the "url" attribute in the subarea tags:

    "/_root/homepage.aspx?etn=<entity>&viewid=%7b<id>%7d&viewtype=1039"

    Is there any way to get CRM for Outlook to default to the link in the URL, or perhaps another format I should be using?

    The CRM is set up with a "my information" area and a "manager information" area, which show either your own records or records of employees you manage. This is why directly linking the specific view is important. This is not something I can manage by limiting access view the security role, as everyone needs access to every view.

    Thanks!

    Tuesday, August 8, 2017 2:51 PM

Answers

  • I figured out a fix for this.

    Linking directly to "main.aspx?etn...." displays the subgrid in Outlook, but the command bar was missing.

    I wrote an HMTL web resource which accepted a ViewId and Entity Name. From there, it would then redirect to the "main.aspx" page with the entity name, view type, page type, and view id parameters. Redirecting via iframe caused the command bar to show up, so I went ahead and updated the entire sitemap to use this web resource to route to the correct subgrid. Now everyone can correctly access their views and all custom ribbon bar functionality still works as intended. 

    Perhaps a bit complicated, but it ended up working out in the end.

    • Marked as answer by VsSl Thursday, August 10, 2017 2:07 PM
    Thursday, August 10, 2017 2:07 PM