locked
Microsoft Dynamics CRM has encountered an error RRS feed

  • Question

  • Hello,

    Since we installed patch 4 for CRM 4.0 we get errors when saving activities, e-mails, phonecalls, ...
    A webpage dialog pops up with the message

    Microsoft Dynamics CRM has encountered an error.
    Please tell Microsoft ... etc


    When we click on "View the data that will be sent to Microsoft" this is what we see:

    Microsoft Dynamics CRM Error Report Contents

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
        <Message>Object expected</Message>
        <Line>1</Line>
        <URL>/Apollo&#47;activities&#47;appointment&#47;edit.aspx&#63;id&#61;&#123;FDDC762C-7B70-DE11-8B21-001EC9D6F895&#125;</URL>
        <PageURL>/Apollo&#47;activities&#47;appointment&#47;edit.aspx&#63;id&#61;&#123;FDDC762C-7B70-DE11-8B21-001EC9D6F895&#125;</PageURL>
        <Function>function anonymous&#40;&#41;&#10;&#123;&#10;TrySetFocusOnSubject&#40;&#41;&#10;&#125;</Function>
        <CallStack>
          <Function>function anonymous&#40;&#41;&#10;&#123;&#10;TrySetFocusOnSubject&#40;&#41;&#10;&#125;</Function>
        </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
        <BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 8.0&#59; Windows NT 5.1&#59; Trident&#47;4.0&#59; InfoPath.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; .NET CLR 1.1.4322&#59; .NET CLR 3.0.04506.648&#59; .NET CLR 3.5.21022&#59; .NET CLR 3.0.4506.2152&#59; .NET CLR 3.5.30729&#41;</BrowserUserAgent>
        <BrowserLanguage>en-us</BrowserLanguage>
        <SystemLanguage>nl-be</SystemLanguage>
        <UserLanguage>nl-be</UserLanguage>
        <ScreenResolution>1280x1024</ScreenResolution>
        <ClientName>Web</ClientName>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>2067</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>1033</UserCulture>
        <OrgID>&#123;4E5EFA47-FA00-4D05-8894-ED306E91732F&#125;</OrgID>
        <UserID>&#123;3A359FF1-8A46-DD11-82F7-001EC9D6F895&#125;</UserID>
        <CRMVersion>4.0.7333.3</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

    We have no clue what that object could be that is expected.
    Even opening earlier activities, e-mails, phonecalls, ... and saving them without changing them generates this error.

    Thanks


    Thursday, August 6, 2009 11:44 AM

Answers

  • Hi,

    we also got same errors on some entities when we installed Update rollup 4.0 and 3.0 also , so we decided to wait for next rollup which is rollup 5.0 and we installed it now.
    Vilas http://www.mscrm-vilas.blogspot.com
    Thursday, August 6, 2009 2:33 PM

All replies

  • It is difficult to tell from the description you have provided. It would be good if you paste your Trace details here. Here is how you would enable the trace in CRM .

    http://support.microsoft.com/default.aspx/kb/907490

    Regards,
    Amol
    Jai Ho CRM http://mscrmkb.blogspot.com Skype - amol.gholap
    Thursday, August 6, 2009 11:50 AM
  • install the CRMDIAGTOOL and enable dev errors.
    See if you get a better error description,post that description
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Thursday, August 6, 2009 12:58 PM
  • Hi,

    I enabled the trace in CRM

    This is what I traced:

    [2009-08-06 16:14:15.8] Process: w3wp |Organization:4e5efa47-fa00-4d05-8894-ed306e91732f |Thread:    8 |Category: Application |User: 00000000-0000-0000-0000-000000000000 |Level: Error | ScriptErrorWebService.SendScriptErrorReport
     at ScriptErrorWebService.SendScriptErrorReport(String fileName, String lineNumber, String function, String errorReport, Boolean addServerInformation, Int32 errorReportingPreference)
     at RuntimeMethodHandle._InvokeMethodFast(Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
     at RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
     at RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
     at LogicalMethodInfo.Invoke(Object target, Object[] values)
     at WebServiceHandler.Invoke()
     at WebServiceHandler.CoreProcessRequest()
     at SyncSessionlessHandler.ProcessRequest(HttpContext context)
     at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
     at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
     at ApplicationStepManager.ResumeSteps(Exception error)
     at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
     at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
     at HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
     at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
    >Uploading script error report to Watson reporting site.
    ><CrmScriptErrorReport>
    >  <ReportVersion>1.0</ReportVersion>
    >  <ScriptErrorDetails>
    > <Message>Object expected</Message>
    > <Line>1</Line>
    > <URL>/Apollo&#47;activities&#47;appointment&#47;edit.aspx&#63;id&#61;&#123;FDDC762C-7B70-DE11-8B21-001EC9D6F895&#125;</URL>
    > <PageURL>/Apollo&#47;activities&#47;appointment&#47;edit.aspx&#63;id&#61;&#123;FDDC762C-7B70-DE11-8B21-001EC9D6F895&#125;</PageURL>
    > <Function>function anonymous&#40;&#41;&#10;&#123;&#10;TrySetFocusOnSubject&#40;&#41;&#10;&#125;</Function>
    > <CallStack>
    >   <Function>function anonymous&#40;&#41;&#10;&#123;&#10;TrySetFocusOnSubject&#40;&#41;&#10;&#125;</Function>
    > </CallStack>
    >  </ScriptErrorDetails>
    >  <ClientInformation>
    > <BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 8.0&#59; Windows NT 5.1&#59; Trident&#47;4.0&#59; InfoPath.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; .NET CLR 1.1.4322&#59; .NET CLR 3.0.04506.648&#59; .NET CLR 3.5.21022&#59; .NET CLR 3.0.4506.2152&#59; .NET CLR 3.5.30729&#41;</BrowserUserAgent>
    > <BrowserLanguage>en-us</BrowserLanguage>
    > <SystemLanguage>nl-be</SystemLanguage>
    > <UserLanguage>nl-be</UserLanguage>
    > <ScreenResolution>1280x1024</ScreenResolution>
    > <ClientName>Web</ClientName>
    >  </ClientInformation>
    >  <ServerInformation>
    >    <OrgLanguage>1033</OrgLanguage>
    >    <OrgCulture>2067</OrgCulture>
    >    <UserLanguage>1033</UserLanguage>
    >    <UserCulture>1033</UserCulture>
    >    <OrgID>&#123;4E5EFA47-FA00-4D05-8894-ED306E91732F&#125;</OrgID>
    >    <UserID>&#123;3A359FF1-8A46-DD11-82F7-001EC9D6F895&#125;</UserID>
    >    <CRMVersion>4.0.7333.3</CRMVersion>
    >    <BuildFlavor>RELEASE</BuildFlavor>
    >  </ServerInformation>
    ></CrmScriptErrorReport>
    >
    Thursday, August 6, 2009 2:19 PM
  • Hi,

    we also got same errors on some entities when we installed Update rollup 4.0 and 3.0 also , so we decided to wait for next rollup which is rollup 5.0 and we installed it now.
    Vilas http://www.mscrm-vilas.blogspot.com
    Thursday, August 6, 2009 2:33 PM
  • And is the problem solved by installing rollup 5.0?
    Thursday, August 6, 2009 2:46 PM