locked
Problems importing customizations RRS feed

  • Question

  • I am currently in the process of migrating from Dynamics CRM 4.0 Online to a hosted version of 4.0. I have exported my customizations, but cannot import them to the hosted instance. Each time I try, I receive the message "Either the file could not be uploaded, or this is not a valid Customization file."

    I'm not sure what I am missing.
    Tuesday, January 5, 2010 9:23 PM

Answers

All replies

  • Some ideas:

    1. Migrating CRM Online to Hosted/OnPremise is support via the following process (migrate both data/customization):
    Microsoft CRM Online Data Migration to Microsoft Dynamics CRM 4.0 on-premise
    http://www.microsoft.com/downloads/details.aspx?FamilyID=54961d25-98d9-4736-bd7e-b5608ecfa2ab&DisplayLang=en

    2. If migrating customizaton only (not data), check that the hosted version has the latest Update Rollup (UR8 as of this date)
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=c53b2916-6b93-4092-bdd3-a394c96ca000

    3. Try to export and import 1 entity first such as Account or Contact or Lead, etc.  Does that work?


    Follow Workopia on Twitter

    http://www.workopia.com/Links.htm

    • Marked as answer by Jim Glass Jr Tuesday, January 5, 2010 10:04 PM
    • Unmarked as answer by ShawnHarrison Wednesday, January 6, 2010 5:11 PM
    Tuesday, January 5, 2010 9:39 PM
    Moderator
  • Well, since I am just interested in moving the customizations, I skipped the first step. We really didn't have much data in there. I tried the second suggestion, but got the same error. I tried a few of the customizations one by one and that doesn't work either.
    Tuesday, January 5, 2010 10:24 PM
  • You say you did check to make sure you had identical rollup levels BEFORE exporting, correct?
    Tuesday, January 5, 2010 10:53 PM
  • Correct. I installed the latest rollup to make sure it was identical to the online version.

    I also contacted Microsoft and they had informed me that there are lines in the xml code exported by the online version that refers to internet marketing; a feature not available in the hosted version. I went through and deleted those as well, but still, no dice.
    Wednesday, January 6, 2010 3:55 PM
  • There is something wrong in the xml file format that we will not be successful in troubleshooting in the forum.  You'll need to open a ticket with Microsoft Support or you can try a systematic approach to see if you can identify the issue.  For example, you can try to export just one entity from the Online application like Account or Lead, something with little to no customization, custom relationships or custom field mapping is probably best.  See if you can import just that one entity into the hosted environment.  Another thing to check, just to ensure the hosted application is working as expected, export the customization file from the hosted application and try re-importing it.


    Best Regards, Donna
    Wednesday, January 6, 2010 5:52 PM
  • Thanks for your response. I am beginning to think that it could be a error in the program as Microsoft is testing on their side with my xml. I did export and then import an xml from the hosted server yesterday with no issues, so I'm out of ideas. Even trying one entity customization at a time is unsuccessful. I have another call with Microsoft tech support today. I will be sure to post an update just in case anyone else ever encounters the same issue.
    Wednesday, January 6, 2010 6:03 PM
  • Hi Shawn,

    It looks like Microsoft has released the fix.  See KB Article ID: 976978 for the details.
    Best Regards, Donna
    • Proposed as answer by Donna EdwardsMVP Tuesday, January 12, 2010 2:22 PM
    • Marked as answer by Jim Glass Jr Tuesday, January 12, 2010 8:33 PM
    Tuesday, January 12, 2010 2:22 PM