locked
Sync Framework problem when deploying project… RRS feed

  • Question

  • Ok i have a project using couple of SQLCE databases...and i have another one using some SQLEXPRESS databases, the first "portable" project synchronizing using the Microsoft Sync Framework. While i run the project from the folder i copy to the client computer in my dev computer everything works perfectly.

    Then copying the applications with the databases into the client pc, attaching the databases to SQLEXPRESS make some operations, run the portable application, making sync operation and I get this exception.

    Unable to enumerate changes at the DbServerSyncProvider for table 'Table1' in synchronization group 'Table1SyncTableSyncGroup'.

    This is not really clear for me, and problem is I can't reproduce it on my computer. The copy is with the same exactly databases, nothing really changes with my computer to the client's computer.

    Microsoft Sync used in its simple form. Nothing special, change tracking enabled and its just works.

    Anyone has some idea or faced this again?

    Thank you.

    Thursday, January 20, 2011 10:59 PM

Answers

  • Thanx, i have fixed that, i think that something was missing, so i copied the debug folder and seems ok now.

     

    Thanx for the profiler.

    • Marked as answer by G.Tas Sunday, January 23, 2011 1:33 PM
    Sunday, January 23, 2011 1:33 PM

All replies

  • have you tried profiling SQL Express to check if your app is actually able to connect and send SQL commands to your SQL Express installation?

    Friday, January 21, 2011 10:00 AM
  • Thanks for answering,

    Profiling tool is not installed in SQL Express.

    I still cant find the solution about this and its crazy,

     

    installed the redistributables, the connection strings are ok, on my dev pc works, on client no. I don't know

    how to reinitialize the database since the sql scripts sync created are just enable and disable change tracking.

     

    Any ideas?

    Friday, January 21, 2011 9:56 PM
  • try this so you can run profiler http://sites.google.com/site/sqlprofiler/

     

    Sunday, January 23, 2011 7:33 AM
  • Thanx, i have fixed that, i think that something was missing, so i copied the debug folder and seems ok now.

     

    Thanx for the profiler.

    • Marked as answer by G.Tas Sunday, January 23, 2011 1:33 PM
    Sunday, January 23, 2011 1:33 PM