locked
security RRS feed

  • Question

  • how do i secure my folders in XP
    Monday, May 28, 2007 8:07 AM

Answers

  • I didnt get you.....You want the folders to be hidden or u want it to be in a safe location so that a virus dosent have effect on it....anyways i will try to answer of what i think u are trying to ask...

     

     

    You cannot password protect individual folders in XP. You restrict access by assigning
    permissions to drives, folders and files.

    To do this, you must be running NTFS as your file system on the drive in question. If your hard disk/partition is not NTFS you will need to convert it. To do this, open a Command Prompt window and enter the following command:

    CONVERT X: /FS:NTFS

    Where X: is the drive letter you wish to convert. You may also want to see
    http://www.aumha.org/a/ntfscvt.htm to ensure that you're getting the optimal conversion.

    After this step is completed and you've rebooted the computer, if necessary:

    XP PRO: In Windows Explorer, go to Tools, Folder Options, View and uncheck Use Simple File Sharing. Now, when you right click on a drive, folder or file (on an NTFS partition) and select Properties, you'll see a Security tab. Here you can assign or deny permissions based on user name or user group membership.

    XP Home: By default, you can only make files and folders under My Documents "private". This is done by right clicking a folder or file and selecting Properties, Sharing. To change the
    permissions on other folders, you need to boot the computer to Safe Mode and log in on the built in Administrator account. In this mode, you'll see the Security tab in Properties, and you can assign permissions based on user name or group membership.

    Monday, May 28, 2007 8:11 AM

All replies

  • I didnt get you.....You want the folders to be hidden or u want it to be in a safe location so that a virus dosent have effect on it....anyways i will try to answer of what i think u are trying to ask...

     

     

    You cannot password protect individual folders in XP. You restrict access by assigning
    permissions to drives, folders and files.

    To do this, you must be running NTFS as your file system on the drive in question. If your hard disk/partition is not NTFS you will need to convert it. To do this, open a Command Prompt window and enter the following command:

    CONVERT X: /FS:NTFS

    Where X: is the drive letter you wish to convert. You may also want to see
    http://www.aumha.org/a/ntfscvt.htm to ensure that you're getting the optimal conversion.

    After this step is completed and you've rebooted the computer, if necessary:

    XP PRO: In Windows Explorer, go to Tools, Folder Options, View and uncheck Use Simple File Sharing. Now, when you right click on a drive, folder or file (on an NTFS partition) and select Properties, you'll see a Security tab. Here you can assign or deny permissions based on user name or user group membership.

    XP Home: By default, you can only make files and folders under My Documents "private". This is done by right clicking a folder or file and selecting Properties, Sharing. To change the
    permissions on other folders, you need to boot the computer to Safe Mode and log in on the built in Administrator account. In this mode, you'll see the Security tab in Properties, and you can assign permissions based on user name or group membership.

    Monday, May 28, 2007 8:11 AM
  • create the following batch files.....

    lock.bat

    content:

    ren <foldername> <foldername>.{21EC2020-3AEA-1069-A2DD-08002B30309D}

     

     

    key.bat

    content:

    ren <foldername>.{21EC2020-3AEA-1069-A2DD-08002B30309D} <foldername>

    Monday, May 28, 2007 1:22 PM
  • i am not sure if the above thing works....
    Monday, May 28, 2007 1:28 PM
  • i have tried it out and am sure that it works.....i can bet i can assure,

     

    dont just say without trying....

    Monday, May 28, 2007 1:59 PM
  • hahahah....................that is what i was trying to say to u anoop regarding the CON folder.......
    Monday, May 28, 2007 2:02 PM