locked
WGA Problems RRS feed

  • Question

  • In the last 2 weeks, we have had 3 different machines come up with this
    "You may be a victim of software counterfeiting".  At first, we thought that it might just be a problem with the computer, but this is not the case (apparently)

    We purchased these three computers through a valid reseller who built them from scratch.  I can see the OEM WIndows XP Pro stickers on the sides of each machine, so I know that they are valid. 

    On the machine that I am writing to you today on, it has worked fine since June '06.  Today, we ran an automatic update on the system and now this "geniune" ***.  I called MS tech support but they told me that they are not offering phone tech support for this issue at this time and that everything had to be dealt with online. 

    I went to the www.microsoft.com/geniune/diag/ page and ran the program.  It said that my MS product was geniune (see below for the diag tool info).  However, I still get the "is not geniune" prompt from MS on login and the blue star in the lower right hand corner.  This is exactly the same thing on all 3 machines.  All three of these machines were purchased at different times, and all three have the MS CD Key sticker on the side.

    {PASTE FROM DIAG TOOL}

    Diagnostic Report (1.5.0540.0):
    -----------------------------------------
    WGA Data-->
    Genuine Validation Status: Genuine
    Windows Product Key: *****-*****-BT6JH-QHP39-46826
    Windows Product Key Hash: GNn1LceQZOZQPua/cjshhvRI4Ec=
    Windows Product ID: 76487-OEM-2261836-68406
    Windows Product ID Type: 3
    Windows License Type: COA/Sysem Builder
    Windows OS version: 5.1.2600.2.00010100.2.0.pro
    Download Center code: GR868W6
    ID: 0bf83219-438e-4c9f-b0b4-40ecad3e4824
    Is Admin: Yes
    AutoDial:
    Registry: 0x0
    WGA Version: Registered, 9.3.265.0
    Signature Type: Unknown.
    Validation Diagnostic: 63BB5E84-811-80004005_E2AD56EA-111-800d_E2AD56EA-112-2eff_BB5C1257-47-80004005

    System Scan Data-->
    Scan: Complete
    Cryptography: Complete

    Notifications Data-->
    Cached Result: 5
    Cache refresh Interval: 467 seconds
    Extended notification delay(non-genuine): N/A
    Extended notification delay(un-activated): N/A
    All disabled: N/A
    Reminder reduced: N/A
    File Exists: Yes
    Version: 1.5.540.0
    Signatue Type: Microsoft

    OGA Data-->
    Office Status: 100
    Office Diagnostics: E2AD56EA-341-6010_E2AD56EA-342-0_16E0B333-57-80004005_B4D0AA8B-836-80004005

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>0bf83219-438e-4c9f-b0b4-40ecad3e4824</UGUID><Version>1.5.0540.0</Version><OS>5.1.2600.2.00010100.2.0.pro</OS><PKey>*****-*****-*****-*****-46826</PKey><PID>76487-OEM-2261836-68406</PID><PIDType>3</PIDType><SID>S-1-5-21-796845957-2000478354-839522115</SID><SYSTEM><Manufacturer>System manufacturer</Manufacturer><Model>System Product Name</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>0501   </Version><SMBIOSVersion major="2" minor="3"/><Date>20051005000000.000000+000</Date></BIOS><HWID>08F63A870184B76C</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Central Standard Time(GMT-06:00)</TimeZone></MachineData>   <Software><Office><Result>100</Result><Products><Product GUID="{91CA0409-6000-11D3-8CFE-0150048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office Small Business Edition 2003</Name><Ver>11</Ver><Val>92192BB8367E784</Val><Hash>N5Z0BNPrMEuBeyhzLVj0pdX/5mY=</Hash><Pid>70160-OEM-5696225-97961</Pid></Product></Products></Office></Software></GenuineResults> 

     

    If you will notice, it says "Genuine Validation Status: Genuine".  I have even tried to reboot the computer after the online diag validation, but still no go.  So now what?

     

    Thanks!

     

    Shayne

    Thursday, August 31, 2006 6:33 PM

Answers

  • Where did you get your version of WGA Validation "LegitCheckControl.dll?"

    You're currently using a modified/hacked binary, that is not Microsoft supported. Thus, its not letting you bypass validation. To resolve this issue, click start, then run, then type in "regsvr32 -u \system32\legitcheckcontrol.dll". Afterwards, go to your c:\windows\system32 directory and delete "legitcheckcontrol.dll".

    Afterwards, manually reinstall the latest version of WGA at http://go.microsoft.com/fwlink/?linkid=69498.

    Let me know if this works for you, if not, I'll need to know where you downloaded your version of legitcheckcontrol.dll so it can be investigated.

    Thursday, August 31, 2006 6:43 PM

All replies

  • Where did you get your version of WGA Validation "LegitCheckControl.dll?"

    You're currently using a modified/hacked binary, that is not Microsoft supported. Thus, its not letting you bypass validation. To resolve this issue, click start, then run, then type in "regsvr32 -u \system32\legitcheckcontrol.dll". Afterwards, go to your c:\windows\system32 directory and delete "legitcheckcontrol.dll".

    Afterwards, manually reinstall the latest version of WGA at http://go.microsoft.com/fwlink/?linkid=69498.

    Let me know if this works for you, if not, I'll need to know where you downloaded your version of legitcheckcontrol.dll so it can be investigated.

    Thursday, August 31, 2006 6:43 PM
  • Not sure where I got the .dll from.  But I'll try this and see if this works or not. 

    Thank you.

    Shayne

    Thursday, August 31, 2006 10:00 PM
  • That seemed to fix it.  I'm not sure where the .dll came from as I don't recall ever downloading it.  However, the properties of the file stated that it was created Feb 16, 2006 if that helps at all.  Now I'm going to try this on the other 2 pc's that we are having this exact same issue on.

    Thanks again!

    Shayne

    Thursday, August 31, 2006 11:37 PM