none
CRM 2011 - Deleting Reports in a Managed State

    Question

  • With regard to CRM 2011, it is my understanding that reports which exist in a managed "state" cannot be deleted from an instance under any circumstances.  This is a problem in two specific situations:
    1. The 54 default reports (per language pack enabled on an instance) which are included in every instance are in this managed "state", and therefore exist in every CRM 2011 instance.  This creates a lot of "sample reports" which cannot be deleted from CRM.  Say, for example, there were 3 language packs enabled on a particular instance.  In this case, there would be 54 x 3 = 162 "sample reports" built into the instance, forever.  One can go through and hide reports individually by opening them up, one by one, and setting many of their attributes equal to null, such as (1) Description, (2) Categories, (3) Related Record Types, (4) Display In, and (5) Languages.  This is the best one can do to hide the reports as much as possible.  It is a process which is slow, error-prone, and unprofessional (imagine doing it in scale across multiple instances).
    2. When reports are imported into an instance as part of a managed solution, all reports which are imported create the same problem as the "sample" reports.  As of late, I have not been able to import managed solutions which include reports; this is a problem in its own right, but is not the topic of discussion for this thread.  However, in the past, I have successfully imported managed solutions which included reports, and I can say with confidence that attempting to delete custom reports which are in a managed state will prompt the user with the same error message they will receive if they attempt to delete a "sample report": "You cannot complete this action for this component because of the configuration of its managed properties".  By the way, this error message have nothing to do with security roles, as a user with a system administrator role will receive it just as a user with a different role will receive it.  Also, overwriting a managed solution which does not contain any reports in it will definitely not delete existing managed reports, so there is no solution for deleting custom managed reports either.

    Have I missed something, or is it impossible to delete reports in a managed state?  I searched for information about this topic both on this forum and on google, and, while I have seen others complain about this and similar issues, I have not seen a solution to the problem.


    • Edited by RST Dev Friday, October 28, 2011 9:02 PM
    Friday, October 28, 2011 8:59 PM

Answers

  • Hi

    The Product team is aware of this issue and working on fixing it for the future. The default behaviour should have been any solution component which is Managed and "Customizable = False" can't be deleted. But any Managed component with Customizable = True can be deleted. In this particular case, eventhough Out of box reports have been set to Managed and Customizable = True, you are not able to delete them and that is the bug to be fixed.

    For managed solutions, the publisher can restrict deletion of their components by marking Customizable = False.

    Thanks

    • Marked as answer by RST Dev Monday, October 31, 2011 3:55 PM
    Friday, October 28, 2011 9:45 PM

All replies

  • Hi

    The Product team is aware of this issue and working on fixing it for the future. The default behaviour should have been any solution component which is Managed and "Customizable = False" can't be deleted. But any Managed component with Customizable = True can be deleted. In this particular case, eventhough Out of box reports have been set to Managed and Customizable = True, you are not able to delete them and that is the bug to be fixed.

    For managed solutions, the publisher can restrict deletion of their components by marking Customizable = False.

    Thanks

    • Marked as answer by RST Dev Monday, October 31, 2011 3:55 PM
    Friday, October 28, 2011 9:45 PM
  • I was afraid I might get that response. Oh well. Thanks for the quick reply.
    Monday, October 31, 2011 3:54 PM
  • Hi

    I have a similar issue in that I have a number of reports that I have deleted from my solution that have not been deleted from the customer's version of the Managed Solution when I released it.  I now have a confusing mess of superceded reports on my customer site that I am unable to tidy up.

    Hopefully the Product Team may include this in the next Rollup?


    David
    Tuesday, November 29, 2011 2:48 PM
  • Same situation over here.

    Ten years after the first release of this product, the reporting integration still causes me headaches :-)

    I migrated from 4 to 5, not able to cleanup the reporting section. Confusing for users please fix.

    Wednesday, January 04, 2012 10:31 AM
  • It does not appear that this issue was resolved with Rollup 6, which was just released.  Is there an ETA for when we will see a solution for this issue?  Until then, I have worked around this issue by editing the 'Display In' field on each report to not contain any value.  This prevents the reports from displaying by default; however, it doesn't keep them from being returned by the quick find.
    Friday, January 13, 2012 5:16 PM
  • Afaik still no real solution from Microsoft. Our workaround is as described above Deleting the Display in the reportlist, forms and entities and to "recycle" reports, that means every time we develope a new report simply changing the name and source of an obsolete one rather than upload it as new.
    Tuesday, August 21, 2012 8:20 AM
  • Hi,

    We did following to remove managed report and it worked like a charm. Although, SQL queries are unsupported but we wanted to remove the reports to avoid confusions.

    delete

    from ReportCategoryBase where ReportId in (select ReportId from ReportBase where Name in ('<Name of the Reports>'))

    delete

    from ReportEntityBase where ReportId in (select ReportId from ReportBase where Name in ('<Name of the Reports>'))

    delete

    from ReportLinkBase where ReportId in (select ReportId from ReportBase where Name in ('<Name of the Reports>'))

    delete

    from ReportVisibilityBase where ReportId in (select ReportId from ReportBase where Name in ('<Name of the Reports>'))

    delete

    from DependencyNodeBase where ObjectId in (select ReportId from ReportBase where Name in ('<Name of the Reports>'))

    delete

    from Dependencybase where DependencyId in

    (

    select DependencyId from Dependency where RequiredComponentObjectId in (select ReportId from ReportBase where Name in ('<Name of the Reports>')))

    delete

    from SolutionComponentBase where ObjectId in (select ReportId from ReportBase where Name in ('<Name of the Reports>'))

    delete

    from ReportBase where Name in ('<Name of the Reports>')

    Thursday, November 29, 2012 6:42 AM
  • Hi,

    regarding unsupported solutions, I prefer setting the state to unmanaged and deleting via CRM interface.

    When you don't have many reports use the Edit top 200 function of you SQL Management Studio. (You can click on SQL and modify the statement to TOP x should you need it)

    Search for your report and the field IsManaged and set it to False (or 1). Close the Management Studio and delete the report in the CRM 2011 reports list.

    You can also open the report, press STRG+N, extract the GUID from the link (XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX)

    and execute the following statement in your Database:

    Update ReportBase Set [IsManaged] = 1 where ReportId= 'XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX'
    The advantage of using the GUID is that reports with the same name (from multiple solutions for example) don't get lost.
    • Edited by itara Thursday, January 17, 2013 3:06 PM typo
    Thursday, January 17, 2013 2:53 PM
  • Hi Mesganaw

    Is this bug still there or fixed in any rollup?

    I am getting same error while deleting one Report.

    Thanks in advance

    Abhijeet


    abhijeet kk

    Wednesday, January 23, 2013 12:59 PM
  • To delete reports successfully you need to set IsManaged to 0, not 1.

    This worked for me.
    Wednesday, April 19, 2017 2:39 PM