locked
DisableIM setting via Communicator.adm / GPO RRS feed

  • Question

  • Okay - the customer has a need to disable the IM capabilities of Communicator.  I found KB# 954648 and it gave me the instructions.  (Note, the update that it references is really 16 December instead of 24 October.  Also, the change needs to be made in HKLM instead of HKCU.)

    So, my question is, does anyone know if the Communicator.adm file has been updated with this setting?  If so, where can I find it?  I did look at the Office Communicator 2007 Group Policy Settings page, but it hasn't been updated with the DisableIM policy.  I can write my own custom ADM file, but was hoping that there is an official one from Microsoft that has all of the settings, including DisableIM.
    Tuesday, December 23, 2008 4:46 PM

Answers

  • Found out that there is a new Communicator.ADM file that was released on 5 Feb 2009 for OCS 2007 R2.  Although the new ADM has a few additional settings, it does not appear to have the DisableIM portion.  I am including the code below in case anyone want to add it to their ADM file.

    CLASS MACHINE
    CATEGORY "Microsoft Office Communicator Policy Settings"
      CATEGORY "Microsoft Office Communicator Feature Policies"
        POLICY !!PolicyDisableIM
        EXPLAIN !!ExplainText_DisableIM
        KEYNAME "Software\Policies\Microsoft\Communicator"
        VALUENAME "DisableIM"
            VALUEON   NUMERIC  1
            VALUEOFF  NUMERIC  0
        END POLICY
      END CATEGORY
    END CATEGORY;

    [strings]

    PolicyDisableIM="Disable Instant Messaging"
    ExplainText_DisableIM="Prevents user from sending or receiving instant messages.\n\nEnabling this policy will disable instant messaging, while disabling this policy will return Communicator to it's default behavior.\n\nNote: The 16 December 2008 hotfix for Communicator must be installed on the workstation, older versions of the client will ignore this setting.\n\nSee KB article 957707 for more details:
    http://support.microsoft.com/kb/957707"

    • Marked as answer by Sick Freak Tuesday, March 3, 2009 5:20 PM
    Tuesday, March 3, 2009 5:12 PM

All replies

  • David,

    Take a look at this article for details on how to add it to a quick custom ADM file, as the communicator.adm file has not been updated with the setting yet.
    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=34

    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Friday, December 26, 2008 1:27 PM
    Moderator
  • Found out that there is a new Communicator.ADM file that was released on 5 Feb 2009 for OCS 2007 R2.  Although the new ADM has a few additional settings, it does not appear to have the DisableIM portion.  I am including the code below in case anyone want to add it to their ADM file.

    CLASS MACHINE
    CATEGORY "Microsoft Office Communicator Policy Settings"
      CATEGORY "Microsoft Office Communicator Feature Policies"
        POLICY !!PolicyDisableIM
        EXPLAIN !!ExplainText_DisableIM
        KEYNAME "Software\Policies\Microsoft\Communicator"
        VALUENAME "DisableIM"
            VALUEON   NUMERIC  1
            VALUEOFF  NUMERIC  0
        END POLICY
      END CATEGORY
    END CATEGORY;

    [strings]

    PolicyDisableIM="Disable Instant Messaging"
    ExplainText_DisableIM="Prevents user from sending or receiving instant messages.\n\nEnabling this policy will disable instant messaging, while disabling this policy will return Communicator to it's default behavior.\n\nNote: The 16 December 2008 hotfix for Communicator must be installed on the workstation, older versions of the client will ignore this setting.\n\nSee KB article 957707 for more details:
    http://support.microsoft.com/kb/957707"

    • Marked as answer by Sick Freak Tuesday, March 3, 2009 5:20 PM
    Tuesday, March 3, 2009 5:12 PM