locked
Problems with Domain Login over VPN RRS feed

  • Question

  • Not sure where to post this one so here are the details:

    Client: Windows 7 Professional.

    Server: Windows Server 2008 R2

    VPN Connection via ADSL to a remote Draytek Router at server end.  Once the VPN tunnel is established the router directs traffic coming in over the VPN to the server.

    The VPN credentials are different to the domain credentials.

    Before attempting windows login we can successfully establish a VPN tunnel (using switch user etc) from the client to the router using Windows DUN VPN client.  I think that the client is being registerd to the domain as we briefly see the "Registering Computer to Domain" message and there are successful Keberos ticket requests from the client in the server security log.  In the security log we can also see a failed login attempt using the VPN credentials.

    At the next step, using domain credentials to login to the client and domain the VPN connection is dropped. The login to the client succeeds but the event log shows that domain login failed and therefore cached credentials are being used.

    Post client side login we can reopen the VPN tunnel to the router (that was how we registered the client PC to the domain in the first place) and us RDC etc but as the user is logged in using cached credentials the client side applications cannot access domain resources.

    What is likely to be causing the VPN to drop as windows login is attempted? Any way around it? I've done multiple searches on the ineternet but can't find any hints on this problem.  Plenty on making the initial VPN connection before logging in but that is working OK for us.

    Thanks for your help.

    Dale

     

     

    Thursday, October 13, 2011 3:58 PM

Answers

  • Thanks Richard. I have reposted in the partner Windows 7 forum as I think it is a client side issue
    • Marked as answer by DaleWV Saturday, October 15, 2011 4:07 PM
    Friday, October 14, 2011 2:35 PM

All replies