locked
CRM 2011 Change URL RRS feed

  • Question

  • Hi I have a question regarding to CRM 2011. When I have installed CRM I have address simillar to this one: http://servername/organizationname/

    I would like to change the Servername to CRM. I have tried to bind name in IIS7. Then change in registry the servername for new one. And in deployment manager change URL address but it didn't helps. I also add CRM entry in DNS server to indicate the server but it also didnt help.

    Could you please help me to solve it.

     

    Thanks

    Tuesday, September 6, 2011 10:48 AM

Answers

  • Thanks Jamie for help. This article give me direction to another article. Now I solved the issue. If anybody would like to find here are steps:

     

    • Update the IIS bindings for the CRM 2011 website on the server running CRM to the new value you want to use
      • Open IIS Manager
      • Select the Microsoft Dynamics CRM website
      • Click ‘Bindings’ in the action panel at the right of the screen
      • Select the binding to modify
      • Click ‘Edit’ and modify the host name and port to the new value.
      • Close the dialog and IIS Manager.
    • Update the ServerURL registry entry with the new URL you want to use. The registry entry can be found at KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM. Note that the key value should be of the form http(s)://<New URL>:<Port Number>/MSCRMServices
    • Modify the global settings for CRM from within the Microsoft Dynamics CRM Deployment Manager*:
      • Start the Microsoft Dynamics CRM Deployment Manager
      • Right-click on the ‘Microsoft Dynamics CRM’ entry at the top of the left pane of the window shown
      • Click ‘Properties’
      • Select the ‘Web Address’ tab on the dialog which is shown
      • Modify the addresses shown appropriately. Note that if the binding type is modified from HTTP to HTTPS you will need to install the appropriate certificate into IIS as well.
      • Click OK to close the dialog and close Microsoft Dynamics CRM Deployment Manager
    • Restart the Microsoft Dynamics CRM Asynchronous Processing Service, or restart the server

     

    Then Add entry to DNS :

    sth, crm, dev, auth, to indicate to server IP

    Then go to registry:

    In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Right-click Lsa, point to New, and then click DWORD Value.
    Type DisableLoopbackCheck, and then press ENTER.
    Right-click DisableLoopbackCheck, and then click Modify.
    In the Value data box, type 1, and then click OK.
    Quit Registry Editor, and then restart your computer.

    Thanks all for help.

     

    • Marked as answer by dborkiewicz Monday, September 12, 2011 1:23 PM
    Monday, September 12, 2011 1:23 PM

All replies

  • If you are only trying to change the server name it would probably work to back up your databases, unistall CRM, reinstall CRM after re-naming your server, and then re-import your organization in deployment manager.  There is probably an easier way to do this, but that is the one way I am pretty sure it would work.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, September 6, 2011 2:47 PM
    Moderator
  • Hi Jamie,

     

    Maybe I didnt told it clear but I don't want to change server name itself. I would like to change name of URL address (now it is showing servername) but I would to change only the URL address. For example http://crm/default.aspx inside the company. The servername can be the same like it was.

     

    Thanks

    Tuesday, September 6, 2011 3:14 PM
  • What are you trying to change it to?  Generally you cannot change the URL format in CRM.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, September 6, 2011 3:35 PM
    Moderator
  • In Crm v4.0 you were able to change URL address by changing the IIS moreless like this one:

    http://hassanhussain.wordpress.com/2009/05/10/change-ms-crm-url/

    Here the only possibility that I have found was this:

    http://blogs.blackmarble.co.uk/blogs/adawson/archive/2011/06/13/changing-crm-2011-url-after-installation.aspx

    But it doesnt work's

    It's not the format of all address. But only allow the users to write http://crm and they will be able to work with CRM. I don't want to tell users to write

    http://SQL01VPN for example.

     

    Tuesday, September 6, 2011 3:41 PM
  • Hi,

    The problem wasn't solved yet if anybody has any idea please write.

    Wednesday, September 7, 2011 9:11 AM
  • That isn't really a supported customization even in CRM 4.0.  That URL format of org.servername.com is reserved for IFD installations only.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Wednesday, September 7, 2011 2:13 PM
    Moderator
  • Hi,

     

    I am not telling that it is supported in CRM 4.0. But it was very simple just add binding in IIS and it was working. Here same procedure just dont want to.

    But I am sure there must be different possibility.

     

    Thanks

    Thursday, September 8, 2011 7:03 AM
  • The only reason I am against your methodology is because if you were to try to upgrade it might cause problems later as updates and upgrades might have something hard-coded looking for a certain URL scheme.  You could configure your implementation as IFD to potentially get what you are looking for.  Here is a tutorial:

    http://www.interactivewebs.com/blog/index.php/server-tips/microsoft-crm-2011-how-to-configure-ifd-hosted-setup/


    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Thursday, September 8, 2011 3:05 PM
    Moderator
  • Thanks Jamie for help. This article give me direction to another article. Now I solved the issue. If anybody would like to find here are steps:

     

    • Update the IIS bindings for the CRM 2011 website on the server running CRM to the new value you want to use
      • Open IIS Manager
      • Select the Microsoft Dynamics CRM website
      • Click ‘Bindings’ in the action panel at the right of the screen
      • Select the binding to modify
      • Click ‘Edit’ and modify the host name and port to the new value.
      • Close the dialog and IIS Manager.
    • Update the ServerURL registry entry with the new URL you want to use. The registry entry can be found at KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM. Note that the key value should be of the form http(s)://<New URL>:<Port Number>/MSCRMServices
    • Modify the global settings for CRM from within the Microsoft Dynamics CRM Deployment Manager*:
      • Start the Microsoft Dynamics CRM Deployment Manager
      • Right-click on the ‘Microsoft Dynamics CRM’ entry at the top of the left pane of the window shown
      • Click ‘Properties’
      • Select the ‘Web Address’ tab on the dialog which is shown
      • Modify the addresses shown appropriately. Note that if the binding type is modified from HTTP to HTTPS you will need to install the appropriate certificate into IIS as well.
      • Click OK to close the dialog and close Microsoft Dynamics CRM Deployment Manager
    • Restart the Microsoft Dynamics CRM Asynchronous Processing Service, or restart the server

     

    Then Add entry to DNS :

    sth, crm, dev, auth, to indicate to server IP

    Then go to registry:

    In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Right-click Lsa, point to New, and then click DWORD Value.
    Type DisableLoopbackCheck, and then press ENTER.
    Right-click DisableLoopbackCheck, and then click Modify.
    In the Value data box, type 1, and then click OK.
    Quit Registry Editor, and then restart your computer.

    Thanks all for help.

     

    • Marked as answer by dborkiewicz Monday, September 12, 2011 1:23 PM
    Monday, September 12, 2011 1:23 PM
  • I am glad you found your answer, feel free to come back and mark my posts as helpful.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Monday, September 12, 2011 1:26 PM
    Moderator
  • Hi,

    Currently my url is somehow like this: http://crmdev:5555/testcrm/

    Now i want to change org name only....like http://crmdev:5555/crm/

    how can i achieve this ?

    Monday, September 12, 2011 2:18 PM
  • You should start a new question so this doesn't get confused.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Monday, September 12, 2011 4:00 PM
    Moderator
  • It's not changing the server URL but the organization name. During installation you could choose if you want testcrm or only crm.

    You need to use the CRM Deployment Manager, disable your organization and Edit > Rename it.

    Try this if this will not work I will give you other solution

    Tuesday, September 13, 2011 11:36 AM
  • Hi,

    I'm new to configuring DNS.

    How do you do this?

    "sth, crm, dev, auth, to indicate to server IP"

    Thanks, 

    For your help

    Kristoper

    Tuesday, August 20, 2013 8:13 AM