none
XPS viewer crashes with copy/paste operation on FCU (16299) and above. RRS feed

  • Question

  • The XPS viewer still crashes when initiating a copy/paste operation in FCU (16299) and above.  This feature has worked properly since the dawn of WPF and the XPS Viewer functionality and is now broken.  I have a ton of XPS documents that are now harder to utilize because of this bug.

    This bug affects every FCU user (and above) that happens to need the copy/paste capability of the XPS viewer.

    Monday, March 5, 2018 4:24 AM

All replies

  • For help with applications included in Windows 10 please post in the Windows 10 forums on http://answers.microsoft.com . For bug reports please use the Feedback Hub and provide clear repro steps. The Feedback Hub will often allow you to log events while reproducing the crash to make it easier to diagnose and follow up.

    The Developing Universal Windows apps forum is for developers to discuss writing their own apps.


    Monday, March 5, 2018 5:19 PM
  • I have used the Feedback Hub.  All I get is push back, zero action, or excuses.  At least here, there is greater public visibility which alerts others to existing problems and occasionally results in action taken.  Feedback Hub has been a bust for me personally.  Posting bugs here has resulted in a surprising number of fixes that were never addressed through Feedback Hub.  So here I am again.

    The benefit here is that there is more public accountability for the PMs that should be fixing problems.  In Feedback Hub, PMs get to hide out.  As you may recall our exchanges have been rather painful Rob.  You're always pushing back on issues that should actually get fixed ASAP.  This is one such issue.

    • Edited by _Noemata_ Monday, March 5, 2018 6:03 PM
    Monday, March 5, 2018 6:00 PM
  • >The XPS viewer still crashes when initiating a copy/paste operation in FCU (16299) and above. 

    It occurs for me when I select some text in an XPS file and invoke Copy.

    The viewer application closes and restarts after invoking Copy from the context menu. I assume that's what happens for you also?

    FWIW, this is still the same in B17112 :(

    There are a few reports on this on the Feedback Hub, dating back 5 months now, they've obviosuly not got enough votes to get them
    off the stupid -100 point starting block.

    Very bad form Microsoft! :(

    Dave

    Monday, March 5, 2018 9:39 PM
  • This is Rob Caplan's fault.  I think he is single handedly trying to undermine the company he works for.  I was able to patch the XPS binary to correct the bug.  So it's not that hard to fix if it's doable at the binary level.  Oh well, yet another Windows 10 flaw that will never be resolved.
    Friday, June 7, 2019 1:04 PM