locked
Remote access: One system available the other connection disabled RRS feed

  • Question

  • I'm having problems accessing one of my PC's remotely.  It is in a Connection Disabled state.
    I can RDP from the homeserver to the PC (FAMILY-PC) and visa versa. 

    I've been though hours of research on the Internet and found a lot of material but haven't been able to find the answer.   I've tried disabling my firewall on FAMILY-PC and it still has the same problem.  

    Anybody have another idea on what to check?
     
     FAMILY-LAPTOP
    Windows Vista Ultimate Edition
     Available for connection
     FAMILY-PC
    Windows Vista Ultimate Edition
     Connection disabled
    Thursday, February 12, 2009 6:17 PM

All replies

  • Remote Access has to be enabled on the PC. On XP, you do this by:
    • Right click My Computer.
    • Select Properties from the pop-up menu.
    • Select the Remote tab.
    • Place a check mark next to Allow users to connect remotely to this computer.
    • Select one or more users, and make sure the firewall is correctly configured.
    Vista is similar; I don't have a computer with Vista handy however.

    I'm not on the WHS team, I just post a lot. :)
    Thursday, February 12, 2009 6:34 PM
    Moderator
  • Thanks for the quick reply.

    All has been confirmed. 

    As stated in my first post, I can RDP from the server to the PC that is not working.  I believe that this confirms that the firewall is configured  correctly as well as remote access.
    Thursday, February 12, 2009 6:41 PM
  • Hi Ken,
    since Brad states, that he can RDP from Windows Home Server to the PC, Remote Desktop seems to be allowed already.

    Brad,
    which security suite do you have installed on that client? Would uninstalling this change the behavior?

    Best greetings from Germany
    Olaf
    Thursday, February 12, 2009 6:43 PM
    Moderator
  • I run Mcafee Security Center on both PC's (Family-Laptop and Family-PC).  I went ahead and uninstalled Mcafee on the Family-PC.  Rebooted.  It still shows up as 'Connection Disabled'.  Any other ideas?
    Thursday, February 12, 2009 7:02 PM
  • Hi Brad,
    after uninstalling the Mc Afee suite - enable the Windows Firewall and check, if the Remotedesktop exception is configured properly.
    If this also does not help - are both systems in the same IP subnet?
    Best greetings from Germany
    Olaf
    Thursday, February 12, 2009 7:21 PM
    Moderator
  • Thanks for the suggestions.

    I have enabled windows firewall and have the exception checked for remote access.  I have verified that I can RDP to the machine still.  It still shows up in a Connection disabled state.

    Machines are in the same subnet - 192.168.1.xxxx with a mask of 255.255.255.0.

    Any other ideas?

    Thursday, February 12, 2009 7:31 PM
  • And all machines are in the same subnet - 192.168.1.xxxx w/subnet mask of 255.255.255.0.
    Thursday, February 12, 2009 7:33 PM
  • Hi Brad,
    on the client also check in the Remote settings, if Allow connections from computers running any version of Remote Desktop (less secure) check box is selected.
    Hmm - soon running out of ideas.
    Best greetings from Germany
    Olaf
    Thursday, February 12, 2009 7:39 PM
    Moderator
  •  Allow connections from computers running any version of Remote Desktop is checked.  Thanks for the ideas!
    Thursday, February 12, 2009 8:43 PM
  • Hi Brad,
    a workaround in this case would be to add port forwarding to port 3389 to either your home server or the client directly, redefine the scope for the RemoteDesktop exception on that target machine to allow connections from all networks and use the Remote Desktop client on your location, to access one of both machines.
    Best greetings from Germany
    Olaf
    Thursday, February 12, 2009 9:14 PM
    Moderator
  • Thanks again Olaf for your comments.

    Your proposed alternative works -- but I want it to work the way WHS was designed - via the remote option website.

    Anybody else have other suggestions?


    Thursday, February 12, 2009 9:54 PM
  • Olaf, How do you redefine the scope for the RemoteDesktop exception on that target machine to allow connections from all network?
    Thursday, February 12, 2009 10:25 PM
  • Hi Brad,
    unfortunately I just run German Vista here at home, so the translations back may not be ideal:
    • In Control Panel/Administrative Tools open Windows Firewall with Advanced Security.
    • Navigate to Incoming Rules and select Remotedesktop (TCP incoming).
    • Click the Scopes tab and verify, that "All IP addresses" is selected.
    • Check also the other tabs if there is someting unusual (or different to your laptop).
    Did this start to happen recently? If yes, you could try a system restore on the client to a time before this happened.
    Or was an update applied to the home server the starting point for the issue?

    Best greetings from Germany
    Olaf
    Thursday, February 12, 2009 10:39 PM
    Moderator