locked
Bug: Username with special character RRS feed

  • Question

  • On the Windows XP SP2 machine of my parents, which is connected to WHS for backup-reasons, I set up the username "Mom & Dad". This works fine on XP and it never told me I shouldn't use special characters for usernames, but now I want to set up a folder on WHS for them, and of course use the same username/password as I use in XP. Now WHS tells me that a username must not contain a "&"-character and it doesn't let me create an account with this name.
    Any workaround for this bug?
    Friday, December 28, 2007 5:57 PM

Answers

  • I struggled with this EXACT same problem myself.  I found a nice, easy workaround.

     

    Make a user account on WHS with no special characters - maybe MomAndDad.  Give it a password.

     

    On the client PC with the "Mom & Dad" user account, map a public WHS share as a network drive.  For example, maybe map the "Photos" share as P:.  When you map the drive, the "Map Network Drive" dialog box includes a link to "Connect using a different user name".  Click this link and specify user MomAndDad and the password you chose for that user account on WHS.

     

    Just like that, you will now access all the WHS shares as MomAndDad.  This will give them access to the shared user folder you created for the MomAndDad account on WHS.

     

    Kevin.

     

    Friday, December 28, 2007 8:52 PM

All replies

  • That’s a nifty find.

     

    Given the Home Server Console wont let you create the user... you’ll need to create it manually, to do so on a client PC:

    1. Click Start -> Run, type mstsc and hit enter to launch the Remote Desktop Client
    2. Connect to your Windows Home Server and login with the Administrator account
    3. On your Windows Home Server, Click on the Start button, then right click on My Computer and Select Manage
    4. Expand Local Users and Groups
    5. Right click on Users and select New User
    6. Type in the user name you want
    7. Specify a password you want
    8. Uncheck User must change password at next logon
    9. Check Password never expires
    10. Double click on new user created in Users folder
    11. Select Member Of tab
    12. Click Add button
    13. Click Advanced button
    14. Click Find Now button
    15. Locate Windows Home Server Users group at the end of the list and double click on it
    16. Click the OK button to close Select Groups window
    17. Click OK to close the users properties window
    18. Close the Computer Management window

    From here it will be up to you to create a share folder for the user (if desired) as well as to use the User Accounts tab in the Server Console to give the account rights to any existing shares.

     

    For note though... you will not be able to create a shared named Mom & Dad with the Console as it also  appears to prevent the & char in a share name... even though it can be done in Windows Explorer (which is not recommended)

    Once you've got this working... please head on over to the Home Server Connect site and report this issue to increase it's chances of being fixed.
    Friday, December 28, 2007 8:29 PM
    Moderator
  • I struggled with this EXACT same problem myself.  I found a nice, easy workaround.

     

    Make a user account on WHS with no special characters - maybe MomAndDad.  Give it a password.

     

    On the client PC with the "Mom & Dad" user account, map a public WHS share as a network drive.  For example, maybe map the "Photos" share as P:.  When you map the drive, the "Map Network Drive" dialog box includes a link to "Connect using a different user name".  Click this link and specify user MomAndDad and the password you chose for that user account on WHS.

     

    Just like that, you will now access all the WHS shares as MomAndDad.  This will give them access to the shared user folder you created for the MomAndDad account on WHS.

     

    Kevin.

     

    Friday, December 28, 2007 8:52 PM