PC Restore Successful from WHS but not Bootable RRS feed

  • Question


    I'm running the release version of WHS with all patches.  Had a PC with a hard drive start to go bad.  Ordered a new drive and while waiting for it to arrive reformatted the bad drive, reinstalled Windows, and all software.  The drive was mostly fine, was just experiencing some read errors.  After the reformat and reinstall it was working fine.  Was a 40GB PATA drive while the new one is a 250GB SATA drive.  Put in the new drive and did a restore.  During the process did a format, created partition, etc.


    WHS restore software said everything was fine.  Restore completed successfully.  PC would not boot.  Suspect the MBR (master boot record) was not restored.  Tried it twice.  Read of others have issues on another site and one person recommended using Acronis True Image.  I downloaded the 15 day trial version 11 of it and used it to copy the old drive to the new and it booted up fine on the new drive.


    One of the reasons for me buying WHS was to be able to restore a PC to a new drive in case of a total drive failure.  If my old drive went totally out how could I have brought back this PC from WHS?  Is this a known bug in WHS restore?


    Friday, March 7, 2008 2:22 AM

All replies

  • Did the original drive you have multiple partitions? Specifically, was there a partition preceding the main partition you were restoring? Many manufacturers are shipping systems with small partitions that contain restore files, configurations, bios backups, etc. If you restore onto a new drive and format it with a single partition, then the BOOT.INI file needs to be changed before the PC will boot. I ran into this issue recently. More info can be found here

    Friday, March 7, 2008 3:08 PM
  • Interesting.  The original drive was one I purchased and installed.  It did have a second partition but was extremely small and did not have anything on it.  I'm fairly certain it was setup that way due to a partition size limitation of 40GB using FAT at the time.  The link describes a situation where Windows complained at bootup time.  The symptoms I saw was the PC not even attempting to read from the drive.  It might have hit it quickly but drive light would not light up.  No Windows loading message or errors.  Just a black screen.

    Saturday, March 8, 2008 7:07 PM
  • I noted in my initial message that I used Acronis True Image to get a bootable image on the new drive.  It did fix the bootup issue; however, I noticed that everytime WHS would try to backup the machine after booting with the new drive it would result in a BSOD bad_pool_header error.  Found on this thread http://www.techspot.com/vb/topic94820-5.html that Acronis True Image apparently has a bug.  By following the instructions in the thread to remove the storage volumes on the PC (Windows will then readd them which requires a reboot afterwards) I'm now able to not only bootup the PC but back it up to WHS.  Note all came about due to the issue with the WHS restore to a new drive not being bootable.

    Sunday, March 9, 2008 12:12 AM
  • Hey Jody,


    Same problem here.

    Restore "successful", but no boot.

    WHS sucks.

    Will someone from MS care to address this issue?


    Sunday, March 9, 2008 9:42 AM