locked
What is the point of enabling duplication if it doesn't stop/fix conflicts? RRS feed

  • Question

  • I came home to find a bunch of file conflict errors on my whs (PP3), for some reason one of my TB drives stopped communicating with my server.

    I rebooted the server, verified that SMART said the drive was fine and brought the system back up.  The management console shows the drive is working just fine but I still have a bunch of files showing as having conflicts and these files are in folders that have duplication enabled.

    So I ask, what is the point of duplication if a drive dies and any files that are supposed to be duplicated die with it? 

    From the WHS Help link in folder properties describing folder duplication:

    "Folder Duplication is a technology that duplicates folders and files across multiple hard drives. Any folder that has Folder Duplication enabled uses twice the amount of server storage.

    If you enable Folder Duplication and then one hard drive fails, you do not lose any files that are stored in a shared folder. You should remove and replace a failed hard drive as soon as possible."

    In my own experiences this is ____.  I lost entire albums and artists from my Music folder when I had a HD die a few months back and the Music folder had duplication activated.

    Tuesday, May 25, 2010 2:40 AM

All replies

  • If a drive dies, you remove it from the storage pool (possibly replacing it, if you don't have enough free space) and your files will be accessible again, assuming they were in duplicated folders.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, May 25, 2010 3:01 AM
    Moderator
  • I expect your files are not lost, WHS just missing the primary storage location for a number of files, making them appear incaccessible.

    When you brought the system back up did WHS recognize the disk as part of the storage pool? If not the disk probably got formatted somewehere during the process causing the diks serial to change.

    To resolve file conflicts you should remove the disk from the WHS storage pool using the WHS console, Storage tab. Removing the disk from the storage pool does not require the disk to be present i the system. Please note this process may take a fairly long time, dependant on the amount of data that was present on the disk. Normally this should resolve all file conflicts. If it doesn't please post here before doing anything else, there are other ways to access and save your files in case this procedure doesn't work.

    Tuesday, May 25, 2010 6:44 AM
    Moderator
  • brubber - yes, when I rebooted the server last night the drive did come back into the pool and it showed that the drive was fine...  I then tried to remove the drive from the pool last night from within the console while RDP'd into the WHS, it's a 1TB drive at around 80% capacity, but the removal froze over night.

    This morning I remoted into my desktop at home and found the frozen removal.  I rebooted the whs again and the drive was again showing as missing.  I tried to do the removal but received a warning that I should reconnect the drive before removing it.  I rebooted once more and it's again shown as missing.  I've since just shut the whs down in order to not totally burn out this drive.

    With this drive missing I get a new series of file conflicts for data that is not in a duplicated folder.  Rut roh!  I guess if I am unable to get WHS to identify the drive I can pull it, throw it in the SATA dock on my desktop and try to copy off the files that way- assuming the drive works enough.

    When I get home tonight I'm going to put in a new 1TB drive, add it to the pool and then try to remove this drive again through the interface.  I'm hoping that I can just get into the BIOS, have it recognize the drive, and then maybe WHS will see it again long enough for me to remove it.

    I'll post my results.  Thanks guys.

    Tuesday, May 25, 2010 2:24 PM
  • I pulled the drive and put it into a USB sata dock, tried to access the share folders and had cyclic redundency errors.  I put a new TV drive and connected the bad drive to the WHS with the same usb SATA dock but it treated it as a new drive and I couldn't read it there- it wanted me to partition the drive.

    I was able to remove the missing drive from the pool and now I have a backup database repair running.

    EDIT: Database repair finished.  I lost some backups (no big deal).  I guess I'm going to repartition this bad 1tb, format it and try to recover it.

    Wednesday, May 26, 2010 1:29 AM