locked
Adding xap with WCF service to crm 2011 RRS feed

  • Question

  • I have Dynamics on-premise and have also created a silverlight app that uses WCF Services to connect to two separate SQL databases.

    All works well when I run it in Visual Studio 2010, however when I upload it to web services the form appears but any thing that should show data, e.g. combo boxes, when clicked cause Visual Studio just in-time debugger to run which states:

    "An unhandled exception ('Unhandled Error in Silverlight Application Load operation failed for query 'Get_Projects'.  The remote server returned an error: Not Found. as System.serviceModel.DomainService.Client.OperationBase.Complete"

    If I run Fiddler, when running the app in Visual Studio all is well.  If running fiddler a key is shown with HTTP Error 401 - Unauthorised: Access is denied, further down the list is an exclamation mark and the error message for this is "There is a problem with the resource you are looking for. and it cannot be displayed.".

    Questions I have are:

    * The WCF service I have added, is that a localised service from my machine and do I need to do one from the server where the webresource is run?

    * How do I create this service?

    * Do I need visual Studio on the Servers?

    * I have two App servers, how will this work if the service is specific?

    * The connection info to one of the external database has hard coded crudentials, what should I be doing to protect these / remove from the list of issues?

    Any help appreciated as I am a novice to all this.

    regards,

    Matt

    Friday, January 24, 2014 3:37 PM

All replies

  • it seems your crm server not able to access your wcf service

    try to hit your wcf service on crm server explore directly.

    use below link to debug

    https://community.dynamics.com/crm/f/117/t/104446.aspx


    Hope this helps. ----------------------------------------------------------------------- Santosh Bhagat If this post answers your question, please click "Mark As Answer" on the post and "Vote as Helpful"

    Saturday, January 25, 2014 4:27 AM
  • I have a issue as soon as the form loads as it should connect and retrieve some data straight away.

    Thus as soon as I click the web link I get "An unhandled exception ('Unhandled Error in Silverlight Application Load operation failed for query 'GetTbl_Projects'. The remote server returned an error: NotFound. at System.ServiceModel.DomainServices.Client.OpertaionBase.Complete'.

    It then asks if I want to debug in VS2010 and then a 'Find Source: eval code' open file dialog box appears.  Any advice on what to do next?

    Matt

    Monday, January 27, 2014 9:38 AM