locked
CRM 2015 'Unable to load plug-in type' RRS feed

  • Question

  • We had a CRM 2011 organization which imported fairly easily into a 2013 test CRM, this was then updated to the latest service pack and the database then imported into a new server with a 2015 test CRM, the import worked (as far as the import wizard was concerned) but it is not possible to open the default CRM web page when running on the 2015 server, the web page error is:

    "Unable to load plug-in type" with button based options of 'Try Again' or 'Close'

    The 2011 CRM tracing tool generates a log file on the 2015 server which includes the following:

    ExceptionConverter.DumpExceptionToTrace  ilOffset = 0x11
    >----- dump exception/fault tree (TryConvertToFaultExceptionInternal: after) -----
    >>>>>> EXCEPTION: 0
    >Type: System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.BaseServiceFault]
    >Message (141): System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #ABBF6A5F
    >StackTrace <null>
    >no PluginTrace
    >>>>>> FAULT: 0
    >ErrorCode: 0x80040216: ErrorCodes.UnExpected
    >Message (141): System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #ABBF6A5F
    >Timestamp: present
    >TraceText <null>
    >CallStack <null>
    >>>>>> FAULT: 1
    >ErrorCode: 0x80044190:
    >Message (82): Unable to load the plugin type: Microsoft.Crm.ObjectModel.AddressComputationPlugin
    >Timestamp: present
    >TraceText <null>
    >CallStack <null>
    >InnerFault <null>
    ><<<<< FAULT: 1
    >InnerException <null>
    ><<<<< EXCEPTION: 0

    I extracted the 2015 CRM SDK onto the server and tried to connect to the imported organzation with it's plugin registration tool but it spat out the following error:

    Unhandled Exception: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

       at Microsoft.Crm.Tools.Libraries.OrganizationHelper.GetLoggedOnUser(CrmOrganization org)

       at Microsoft.Crm.Tools.PluginRegistration.Helper.<>c__DisplayClass5.<OpenConnection>b__1(Object o, DoWorkEventArgs e)

    Any advice to help identify the problematic plugin and disable it or otherwise troubleshoot this would be appreciated, we have full access to the underlying SQL database or can make changes in the 2013 organization and re-export it but can't do much with the 2015 installation.

    Monday, December 15, 2014 5:19 AM

All replies

  • Did you ever figure out the problem on this? I just did a test upgrade from CRM 2013 to CRM 2015 and have the same error.

    Monday, January 26, 2015 9:13 PM
  • I'm also having the same issue, any fix?
    Friday, February 20, 2015 8:28 PM
  • Same error here, has anyone fixed this?

    Friday, April 3, 2015 5:36 PM
  • Hello,

    It seems that the culprit is a standard plugin: Microsoft.Crm.ObjectModel.AddressComputationPlugin, so disabling it won't bring us victory.

    A very similar error is documented here: Microsoft Dynamics CRM 2011 Upgrade from RTM to UR6 breaks 4.0 plugins or workflow assemblies

    This post suggests this error is caused by a corrupt web.config file. Could the Dynamics CRM Web application reference older or incorrect CRM SDK libraries after the upgrade process? Beware that the required version for Dynamics CRM 2015 is 7.0.0.0.

    Wednesday, April 8, 2015 10:02 AM
  • Same issue here with CRM2013 that was working until this morning.  The error I'm getting when I run tracing is 

    Unable to load the plugin type: Microsoft.Crm.Common.ObjectModel.AddressComputationPlugin 

    Anyone found a solution yet??

    Friday, April 24, 2015 8:32 PM
  • Hello,

    Did any one got a solution for this error?


    Fernando

    Tuesday, September 29, 2015 7:27 AM
  • Also looking for an answer to this... Any solutions from Microsoft?

    Microsoft CRM Consultant

    Monday, October 5, 2015 11:07 PM
  • > Unable to load the plugin type: Microsoft.Crm.ObjectModel.AddressComputationPlugin
     This issue is related to corruption during the upgrade process. If you make a select on plugins on a vanilla (working) CRM, you will see that plugin is actually of type: Microsoft.Crm.Common.ObjectModel.AddressComputationPlugin

    Your organization is missing "Common".

    select
    "plugintype0".Name as "name"
    , "plugintype0".AssemblyName as "assemblyname"
    , "plugintype0".CreatedBy as "createdby"
    […]
    from
    PluginType as "plugintype0"
     I would suggest re-installing CRM and attaching the affected organization later.

    Replacing the plugin names in the database, can work but I don't think it will be a good idea.

    Tuesday, October 6, 2015 7:49 AM
  • Don't suppose anybody got anywhere with this? I have a 2013 to 2015 installation in limbo... Exact error..Thanks

    Tuesday, November 10, 2015 1:13 PM