none
problems with margins in Blazor RRS feed

  • Question

  • I am using a number of Blazor Components, each inside the next.  The one at the top is in a div and is centered and has a width of X.

      This works great, but the Components within the components within the components within the components don't seem to know correctly where they are supposed to be writing text to, so I ended up with about an inch of text where it doesn't belong on both sides of the div that is wrapping the first compoennt.

    It was able to get it to be where I want by assigning margins all throughout, but that doesn't seem like the right way to do it.  What am I missing?

    Friday, March 6, 2020 3:03 AM

All replies

  • Hi danielsn,

    Welcome to MSDN forum.

    Based on my research, I suppose this issue are more about Blazor and our forum is to discuss the Visual Studio General Questions issues, I suggest you could ask Stack Overflow tagged blazor forum for a more professional help.

    If you have any more Visual Studio General Questions issues in the future, please feel free to let us know.

    Sorry for any inconvenience and thanks for your understanding. 

    Best Regards,

    Anna

    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com



    Friday, March 6, 2020 9:02 AM
  • Thank you Anna,

    A few years ago when the Bot framework first came out I posted my first and only post on Stack Exchange, and in it I complimented the Microsoft Developers of the Bot Framework.  They had released the code and I said how I thought the developers had done an amazing job.

    A Microsoft hater with Stack Exchange longevity marked my post as fake, and froze my account.  So, I am banned from asking questions on Stack Exchange.

    I will look around for a more appropriate forum though, 

    thanks,

    Daniel

    Friday, March 6, 2020 2:17 PM
  • Hi danielsn,

    Sorry for my delay reply.

    I'm sorry to hear that your account is frozen. If you can't post in the Stack Overflow site, I suggest you log in with a different account and post your issue in this forum.

    Hope it helps.

    Sincerely,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, March 10, 2020 3:29 AM