none
Can't get Live Writer to 'sync' with my Wordpress.com blog

    Question

  • Recently Wordpress.com introduced a new theme which is now the new default theme called Twenty Ten. After setting it up, I then tried to get Live Writer to sync with the settings etc. Unfortunately it won't sync correctly. It places the Writing area to the left hand side of the compose screen, and any photos/pictures will not let you place them to the left or right for text wrapping.

    If I want to do this, I have to tell Live Writer to not do a dummy post, but then I can't see what my post will look like when posted. (WYSIWYG.) I have tried numurous times to get it to work correctly, but to no avail.

    Windows 7, current version of Live Writer, Dell XPS420

    Friday, April 30, 2010 7:28 PM

Answers

  • I've had plenty of themes not work with Windows Live Writer. This new theme issue with WORDPRESS is no different than any other theme that doesn't work.

    Windows Live Writer works sometimes, and others not so much. I have learned to adapt my blogs with Windows Live Writer when it doesn't pick up the themes correctly.

    It's infuriating for sure, but because Microsoft/Windows Live Writer team has failed to address it, it's something that's up to the community to figure out and work around.

    I hope this helps...

     

    Until next time,

    LEHenryJr

    LEHSYS.com

     

    • Marked as answer by technogranny Wednesday, May 05, 2010 7:49 AM
    Monday, May 03, 2010 2:06 AM

All replies

  • Windows Live Writer doesn't always detect the themes correctly, and its terribly irritating to come across this issue.

    But you SHOULD still be able to use Windows Live Writer with those themes; you just need to make some manual adjustments. I've an article that are some options for Windows Live Writer users to try to help them with their theme issues.

         http://www.lehsys.com/2010/02/windows-live-writer-creating-a-custom-template/

    I hope this helps...

    Later,

    Larry

     

     

    Sunday, May 02, 2010 3:20 AM
  • Thanks Larry I'll give this a try. It needs sorting though because this theme is the new 'default' theme in Wordpress.com. Also the picture/photo thing needs sorting on there and I have found that this is a problem with quite a few of their themes, meaning that you then have to go hunting around for the themes that DO allow text wrapping around your pics.

    Why this occurs with some themes and not others I can't imagine.

    thanks again

    TG

    Sunday, May 02, 2010 5:23 AM
  • I've had plenty of themes not work with Windows Live Writer. This new theme issue with WORDPRESS is no different than any other theme that doesn't work.

    Windows Live Writer works sometimes, and others not so much. I have learned to adapt my blogs with Windows Live Writer when it doesn't pick up the themes correctly.

    It's infuriating for sure, but because Microsoft/Windows Live Writer team has failed to address it, it's something that's up to the community to figure out and work around.

    I hope this helps...

     

    Until next time,

    LEHenryJr

    LEHSYS.com

     

    • Marked as answer by technogranny Wednesday, May 05, 2010 7:49 AM
    Monday, May 03, 2010 2:06 AM
  • I knew it couldn't just be me having this problem! When you click on Source and look at the source code, Live Writer displays all pictures as INLINE rather than left/right and doesn't use text wrapping. I'm going to have to stop using Live Writer with my helluo librorum (http://frohock.wordpress.com) blog. I really hate that, because I love the way Live Writer works.

    I'm using Windows XP Professional 2002 at work and at home. I love the Twenty Ten theme and I intend to continue to use it, but I can't use Live Writer to write my posts anymore.

    I'd love to know if they could fix this issue!

    Wednesday, May 19, 2010 3:09 PM
  • Teresa,

    It's not Windows Live Writer... It's the CSS from the theme.
    Windows Live Writer doesn't always get it right... It's sad, but it's true.

    But your problem is fixable; here's proof it can be done:

    http://lehenryjr.wordpress.com/2010/05/19/windows-live-writer-test/

    and here's how you fix it.

    http://www.lehsys.com/2010/05/windows-live-writer-test/

     

    it's very simple and you only have to highlight 4 characters, press delete and save the file. Done.

    I hope this helps...

    Until next time,
    LEHenryJr
    LEHSYS.com 
    Thursday, May 20, 2010 2:29 AM
  • lehenryjr In that link for the proof, your inserted picture was still not dispaying text wrapping. Teresa, I am currently in touch with someone from Wordpress.com about why some of their themes don't work right in Writer and they are investigating. There are more than Twenty Ten that don't let you place your photos to the left or right hand side. Some do and some don't.

    Why I haven't a clue. I am using Vigiance instead at the  moment and funnily enough, its practically the same layout, etc as Twenty Ten. Fully 'syncs' fine with that.

    Thanks lehenryjr for trying to help with this problem.

    TG

    Thursday, May 20, 2010 6:51 AM
  • Technogranny has it right. It's about word wrap, not placement.

    For some reason, Twenty Ten is converting my word wrap commands to INLINE. Here's how the Windows Live Writer HTML is showing up in my older posts:

    <a href="http://frohock.files.wordpress.com/2010/05/booklove_normal.jpg"><img style="border-bottom:0;border-left:0;display:inline;border-top:0;border-right:0;margin:5px;" title="booklove_normal" border="0" alt="booklove_normal" align="left" src="http://frohock.files.wordpress.com/2010/05/booklove_normal_thumb.jpg" width="52" height="52" /></a>

    (The word "inline" is not showing up as bold, I just bolded it so you could see it better.) If I change "inline" to left, center, or right, it still does not enable word wrap. The text is shown as INLINE, meaning no word wrap.

    When I create a NEW post in the Twenty Ten theme in Wordpress' edit box, I get the following HTML:

    <a href="http://frohock.files.wordpress.com/2010/05/joe-mckinney.jpg"><img src="http://frohock.files.wordpress.com/2010/05/joe-mckinney.jpg" alt="" title="Joe McKinney" width="200" height="211" class="alignleft size-full wp-image-2656" /></a>

    Do you see the difference? The second example looks beautiful on any computer that I look at it on, but the first set of HTML (that Windows Live produces) shows INLINE and the word wrap function does not work.

    Does that explain it better?

    Teresa

     

    Thursday, May 20, 2010 1:47 PM
  • That's fine- I understood it the first time...

    But I had a screenshot on my site showing the text 'wrapping' around the image.

    I tested it in several  different browsers [Firefox, Chrome, Opera and Safari]. I don't use Internet Explorer- never will. If your using Internet Explorer- it explains your problem. Internet Explorer is the lowest rated browser and doesn't comply with the rest of the world on W3C standards.

    I  understand the concept of INLINE , but I also understand the concept behind CSS ... themes for Wordpress are very CSS intensive; they affect a great many things. Not understanding these things can result in a sizable argument. Basically anything with a label or content CSS affects; overriding HTML code.

    If the team over at Wordpress is working on it, that's great; but in the mean time- this should work ...  and I would consider it a 'workaround' until Wordpress or Windows Live Writer development  do something.

    I'm not holding my breath... It's only been almost 2 years between releases on Microsoft Windows Live Writer. So far, I've seen no great strides to do any better.

    In the meantime, I'm able to download and 'sync' my twenty ten theme and post just fine and have the text wrap around images without issues. I tested it several times.

    Just trying to help...

     

    I hope you have a nice day!

    Thanks,
    LHenryJr.
    www.lehsys.com

     

    Thursday, May 20, 2010 7:00 PM