locked
Local Network Problems - Home computers unable to access home server RRS feed

  • Question

  • I usually lurk and try my best to find the answer...I've been so close but its time to call in the big dogs.

    The Background
    After a patch Tuesday updated my NIC drivers and reboot the WHS, I lost connectivity.  Fooled around with 2nd NIC, disabled things, re-enabled, cable swappings, and finally driver re-installations...WHS can finally can see the network.

    The Problem
    All machines on the network (including the Home Server) are unable to ping the server by name.  The IP does resolve.  This means remote desktop works by IP but not by name, WHS Connector software will not connect with the typical "This computer cannot connect to your home server."  The web connection works great and can even get to the WHS console.  As you'd expect Remote Access isn't working and a bit more surprising, selecting Shared Folders (through the web) just sits there (page refresh but nothing happens).  Shared folders link works fine but copying the target from the shortcut and pasting in Run box \\server\share doesn't work.

    Attempted Solutions
    This solution looked so close but host files are all fine (empty), UPnP & DDNS disabled/reenabled, router reboots galore, unconfigured and disabled web pages from console settings, DHCP looks great with nothing reserved, and firewall perused ... nada

    After lots and lots of tinkering, \\{server_name}\shared folders is actually bringing up the shares (didn't before) while \\{server_name} gets boggled (that has stayed the same).  Ok, that's inconsistent for no good reason.

    Assumption
    Obviosuly some sort of DNS, netbios issue.  But no reason to go in and mess with host files and bastardize the concept of "7 steps from install to disconnect the keyboard and forget about it."

    Does this qualify for a stumper?

    Shawn

    Friday, January 16, 2009 4:37 AM

Answers

  • Hi Shawn,
    in the past I have read about some issues with NVidia network cards in the server, so that this adapter may be a cause for the issues.
    Besides the fact, that I dislike the plain Broadcast type of your node type entry (which means nothing, as long as the machines are in the same subnet and no dedicated name server exists), your configuration looks normal.
    But I see, that you have not disabled your second network adapter, only disconnected. Since it seems to respond earlier, it may happen that it tries sometimes to answer via this adapter and can't.
    So please try to do that first:
    • Login to your server.
    • In Control Panel open Network Connections.
    • Right click on Local Area Connection 3 and select Disable.
      (On the same place you also could click Advanced/Advanced Settings and check, if the wanted adapter is in the top position (which would only matter if both adapters are active).
    • Reboot your server and try, if it works now.
    Best greetings from Germany
    Olaf
    Saturday, January 17, 2009 12:06 PM
    Moderator

All replies

  • Hello,
    would be helpfull for diagnostics to open a command prompt on one client and the server, type
    ipconfig /all
    and post the output here.
    A quick workaround would also be to alter the hosts file on the client by adding a line for your server:
    ipaddress   servername
    I don't see this as a mess, but there is a risk, that if the server changes its IP address (which may happen on a power outage of the router, if the address is assigned via DHCP), you have forgotten about this change and have to start again troubleshooting. (On the other hand I tend myself to assign fixed IP addresses to my servers, so this doesn't matter a lot.)
    Best greetings from Germany
    Olaf
    Friday, January 16, 2009 8:08 AM
    Moderator
  • Thanks Olaf,  I will go ahead and try this when I get home.  Guess I was just being stubborn insisting on finding the root cause for this. 

    So, this means I should go to C:/windows/system32/drivers/etc/host. and add the IP address of my server on each and every client machine that connects to my network.  This should then allow the clients to resolve the server by name.  Hmm.

    That still doesn't explain why the web is unable to drill into the top level shared folders.  It serves up all the correct folders based on my permissions but doesn't go deeper.

    Oh, that reminds me.  When I try to go to \\server from the server itself, it can't find itself.  Seems wierd that I would also have to modify the host file locally.

    Shawn
    Friday, January 16, 2009 2:26 PM
  • "Guess I was just being stubborn insisting on finding the root cause for this."

    this is what I would like to see your ipconfig.
    The strange part according to your description is, that \\server fails, but \\server\share still works. This should exclude name resolution issues besides maybe if you have a dns suffix configured, which would try to resolve the server name always against an external DNS server. While \\server\share assumes a NetBIOS name first.
    Best greetings from Germany
    Olaf
    Friday, January 16, 2009 3:37 PM
    Moderator
  • Yeah, that is wierd...must be something cached or something...beats me.  I did just remember that when I first started having problems, I shared out the shares folder since it wasn't.  Of course all the shares are individual at the lower level.  After removing that share, the server\share stopped working.   
     
    From client machine:

    C:\Users\Shawn>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Vista-9950
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Broadcast
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
       Physical Address. . . . . . . . . : 00-22-15-73-53-B3
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::a8fc:9419:161c:74ac%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.0.192(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Thursday, January 15, 2009 9:32:24 PM
       Lease Expires . . . . . . . . . . : Saturday, January 17, 2009 9:36:59 PM
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCP Server . . . . . . . . . . . : 192.168.0.1
       DNS Servers . . . . . . . . . . . : 192.168.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 6:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{3D0B9A96-9BDC-428B-AF8B-2556EBD7E13D}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 02-00-54-55-4E-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:34c4:1d7c:3f57:ff3f(Preferred)
       Link-local IPv6 Address . . . . . : fe80::34c4:1d7c:3f57:ff3f%11(Preferred)
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled


    From WHS:

    C:\Documents and Settings\Administrator>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Too-Much-Info
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Broadcast
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 3:

       Media State . . . . . . . . . . . : Media disconnected
       Description . . . . . . . . . . . : 3Com 3C920B-EMB Integrated Fast Ethernet
    Controller
       Physical Address. . . . . . . . . : 00-26-54-0C-76-C7

    Ethernet adapter Local Area Connection 2:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : NVIDIA nForce MCP Networking Controller
       Physical Address. . . . . . . . . : 00-0C-6E-33-C6-EF
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IP Address. . . . . . . . . . . . : 192.168.0.186
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCP Server . . . . . . . . . . . : 192.168.0.1
       DNS Servers . . . . . . . . . . . : 192.168.0.1
       Lease Obtained. . . . . . . . . . : Friday, January 16, 2009 6:47:02 PM
       Lease Expires . . . . . . . . . . : Saturday, January 17, 2009 6:47:02 PM

    Saturday, January 17, 2009 4:14 AM
  • Hi Shawn,
    in the past I have read about some issues with NVidia network cards in the server, so that this adapter may be a cause for the issues.
    Besides the fact, that I dislike the plain Broadcast type of your node type entry (which means nothing, as long as the machines are in the same subnet and no dedicated name server exists), your configuration looks normal.
    But I see, that you have not disabled your second network adapter, only disconnected. Since it seems to respond earlier, it may happen that it tries sometimes to answer via this adapter and can't.
    So please try to do that first:
    • Login to your server.
    • In Control Panel open Network Connections.
    • Right click on Local Area Connection 3 and select Disable.
      (On the same place you also could click Advanced/Advanced Settings and check, if the wanted adapter is in the top position (which would only matter if both adapters are active).
    • Reboot your server and try, if it works now.
    Best greetings from Germany
    Olaf
    Saturday, January 17, 2009 12:06 PM
    Moderator