locked
Microsoft Outlook client keeps disconnecting RRS feed

  • Question

  • Help!

    We have recently rewritten our application using Microsoft CRM 4.0 as the platform. Our application is designed to run on-premise.

    Our sales guys now want to go round showing clients our hard work and we have been tasked with supplying them with a stand-alone laptop for that purpose.

    We have set up a well specified laptop (8GB of memory, SSD, fast processor etc.) running Windows 7. We have created a Virtual PC with the following installed:

    • AD
    • SQL Server
    • MS CRM 4.0 (rollup 12)
    • Outlook 2007 SP2
    • MS CRM 4.0 Outlook client

    Whilst this is perhaps not a recommended set-up having a single VM makes things a lot easier for our sales staff. Each could have a copy on their laptop and they don't need to worry about internet connectivity, multiple machines etc.

    Everything is working fine apart from the Outlook client which disconnects itself at random intervals. Accessing the website works absolutely fine and the client works fine while it is connected. Sometimes it seems to die completely, other times I can re-enable it if I wait for a while.

    I've checked the event viewer and there are no messages. I've also switched on client tracing but it doesn't seem to give any useful information. There are errors in the trace but from looking on the web these look unrelated.

    There does seem to be a pattern in the messages when the problem occurs but they don’t seem to give any indication of a cause.

    The messages below seem to suggest some sort of Network issue. Originally we had a loopback adapter installed on the VM itself but we couldn’t get the Outlook Client to Install at all. I now have the loopback adapter installed on the host laptop and virtual PC adapter pointing to it. It has a fixed IP address as does the VM.

    [2010-11-08 16:54:26.198] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Configuration' State execution SUCCEED.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 79

    [2010-11-08 16:54:26.199] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Initialize' State is going to execute.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 71

    [2010-11-08 16:54:26.199] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | Reading registry key 0B1A001A-9351-43d0-A6C0-44A8D711E020 failed Function: FReadDWORDRegKeyValue File: c:\bt\17621\src\application\outlook\addin\..\Common\utility.h Line: 209

    [2010-11-08 16:54:26.199] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Initialize' State execution SUCCEED.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 79

    [2010-11-08 16:54:26.199] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Network' State is going to execute.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 71

    [2010-11-08 16:54:26.200] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | Reading registry key 0B1A001A-9351-43d0-A6C0-44A8D711E020 failed Function: FReadDWORDRegKeyValue File: c:\bt\17621\src\application\outlook\addin\..\Common\utility.h Line: 209

    [2010-11-08 16:54:26.524] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Network' State execution FAILED.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 79

    [2010-11-08 16:54:26.524] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Offline' State is going to execute.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 71

    [2010-11-08 16:54:26.524] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | Reading registry key 0B1A001A-9351-43d0-A6C0-44A8D711E020 failed Function: FReadDWORDRegKeyValue File: c:\bt\17621\src\application\outlook\addin\..\Common\utility.h Line: 209

    [2010-11-08 16:54:26.525] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Offline' State execution FAILED.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 79

    [2010-11-08 16:54:26.525] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | StateManagerSpy: 'Disable' State is going to execute.  Function: CStateEngine::Execute File: c:\bt\17621\src\application\outlook\addin\stateengine.cpp Line: 71

    [2010-11-08 16:54:26.525] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | Reading registry key 0B1A001A-9351-43d0-A6C0-44A8D711E020 failed Function: FReadDWORDRegKeyValue File: c:\bt\17621\src\application\outlook\addin\..\Common\utility.h Line: 209

    [2010-11-08 16:54:26.643] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | Reading registry key TrustedServerUrl failed Function: FReadDWORDRegKeyValue File: c:\bt\17621\src\application\outlook\addin\..\Common\utility.h Line: 209

    [2010-11-08 16:54:26.643] Process:OUTLOOK |Thread:4744 |Category: Unmanaged.Platform |User: PlatformUser |Level: Info | Reading registry key UnblockedServerUrl failed Function:

     

     

    Tuesday, November 16, 2010 11:28 AM

All replies

  • I've now downloaded the CRM demo VM which includes the Server and Outlook Client install on a single VM. I have tried to set up the networking, Active Directory etc. to be the same on my VM but now I can't get the CRM client to start at all.

     

    I have two network adapters in the Virtual PC settings, one set to "Internal Network" and one to "Not Connected" - exactly the same as the MS VM.

    I set up a loopback adapter on the VM itself with a fixed IP address if 192.168.0.50, subnet mask 255.255.255.0, default gateway 192.168.0.1 and preferred DNS server of 192.168.0.50. All the same as the Microsoft VM.

    I've also added the WINS server feature and created a reverse lookup zone as per the Microsoft VM.

    Now I'm running out of ideas. The Microsoft VM is Server 2003 with CRM rollup 11 whereas ours is Server 2008 rollup 12.

     

    I notice that on my VM the network says "Limited Connectivity" whereas the Microsoft VM says "Connected". I'm not sure if this is just server 2008 having a more accurate message or whether there is a genuine difference between the two?

    Monday, November 22, 2010 4:20 PM