locked
Bug: News items appear in wrong order RRS feed

  • General discussion

  • Minor one this but looks like a bug nonetheless.

    Check out the screenshot here: http://cid-550f681dad532637.skydrive.live.com/self.aspx/Public/Misc/mesh%7C_screenshot.jpg

    It shows my Mesh newsfeed and, behind it, the newsfeed for a folder on my Live Desktop. I've written 2 comments against the folder but as you can see in the newsfeed in the Mesh client they appear in a different order (they are in the correct order on the Live Desktop).

    Now take a look at the times of the comments (I hope it shows up enough on the screenshot). On the Live Desktop they are timed at 4:28pm and 4:30pm (which is correct). On the Mesh client newsfeed they are both timed at 7:58pm (the time is cut off from the second one so you'll have to trust me on that).

    In other words, the times don't agree between the live desktop and the Mesh client. Just to reiterate - the Live Desktop shows the correct info and in the correct order.

    I am guessing this is because I wrote the comments while I was offline.

    HTH

    -Jamie

    http://jamiethomson.spaces.live.com/ | http://blogs.conchango.com/jamiethomson
    Thursday, June 19, 2008 7:12 PM

All replies

  • nudge.

    Any reply here? Is this acknowledged as a bug? Shall i raise it on Connect?

    http://jamiethomson.spaces.live.com/ | http://blogs.conchango.com/jamiethomson
    Monday, June 30, 2008 3:19 PM
  • Hi Jamie,

    Sorry for the delay.  This is a bug.  Please go ahead an file a Connect report.

    Thanks,

    Ben.
    Monday, June 30, 2008 5:59 PM
  • Ben - Live Mesh said:

    Hi Jamie,

    Sorry for the delay.  This is a bug.  Please go ahead an file a Connect report.

    Thanks,

    Ben.



    Done.
    https://connect.microsoft.com/feedback/ViewFeedback.aspx?FeedbackID=354454&SiteID=425
    http://jamiethomson.spaces.live.com/ | http://blogs.conchango.com/jamiethomson
    Tuesday, July 1, 2008 8:01 AM
  • Thanks Jamie.  We're tracking it now.  :)

    Ben.
    Tuesday, July 1, 2008 5:18 PM
  • Ben - Live Mesh said:

    Thanks Jamie.  We're tracking it now.  :)

    Ben.



    Hmmm...I didn't think much of the reply though to be honest. Basically it was "Yeah, it happens".

    Well I would rather it didn't. I'd like them to appear in the right order. Plus the issues about the times being completely wrong hasn't been addressed.

    -jamie
    http://jamiethomson.spaces.live.com/ | http://blogs.conchango.com/jamiethomson
    Tuesday, July 1, 2008 7:33 PM
  • Hi Jamie,

    I apologize if I sounded flippant.  I did not mean to trivialize the bug you're reporting.  Of course you would prefer that the news items appeared in the right order, and had the correct times affixed.  So would we.  I'm afraid, however, that I do not currently have any more information about why this might be happening.  I see that Tim has already contacted you through Connect (and that you have replied), and we will continue to follow up through that channel as we learn more.

    We very much appreciate both the time that you are taking to help us test Live Mesh, and the time you've taken to report issues that you've found.  Again, you have my apologies if that appreciation was not being made clear.

    Ben.
    Tuesday, July 1, 2008 8:05 PM
  • Ben - Live Mesh said:

    Hi Jamie,

    I apologize if I sounded flippant.  I did not mean to trivialize the bug you're reporting.  Of course you would prefer that the news items appeared in the right order, and had the correct times affixed.  So would we.  I'm afraid, however, that I do not currently have any more information about why this might be happening.  I see that Tim has already contacted you through Connect (and that you have replied), and we will continue to follow up through that channel as we learn more.

    We very much appreciate both the time that you are taking to help us test Live Mesh, and the time you've taken to report issues that you've found.  Again, you have my apologies if that appreciation was not being made clear.

    Ben.



    Ben,
    No need to apologise. I wasn't referring to your reply here, I was referring to Tim's on the Connect submission and I was rather too abrupt in my reply above so it should be me that is apologising.

    I'll look forward to seeing it fixed in the future. I know there's a long way to go till we're out of beta.

     

    -Jamie


    http://jamiethomson.spaces.live.com/ | http://blogs.conchango.com/jamiethomson
    Tuesday, July 1, 2008 8:09 PM
  • Jamie,

    What timezone are you in? Are all your PCs on the same timezone? I noticed that one of the messages has a time that seemed like 3.5 hours later than the original post, and that makes me wonder whether there's a server timezone offset or something coming into play. I'm not sure where the Live Mesh cloud servers are, or whether that matters. I do know that I've had issues in the past with timezones between server and PCs being a contributing factor to problems in getting things to show up properly, in the correct chronological order.
    Tuesday, July 1, 2008 8:15 PM
  • GuyWithDogs said:

    Jamie,

    What timezone are you in? Are all your PCs on the same timezone? I noticed that one of the messages has a time that seemed like 3.5 hours later than the original post, and that makes me wonder whether there's a server timezone offset or something coming into play. I'm not sure where the Live Mesh cloud servers are, or whether that matters. I do know that I've had issues in the past with timezones between server and PCs being a contributing factor to problems in getting things to show up properly, in the correct chronological order.



    I only have Mesh installed on one machine and that is running at GMT. Although the screenshot doesn't show it actually both updates were 3.5 hours later than the original posts. If I remember correctly those times represent the time that the dta got synced because, remember, I was offline when I wrote them. I probably should have said that more explicitly earlier.

    -Jamie
    http://jamiethomson.spaces.live.com/ | http://blogs.conchango.com/jamiethomson
    Tuesday, July 1, 2008 9:44 PM