locked
CRM Command bar buttons inactive. RRS feed

  • Question

  • Hello,

    I've got a difficult issue that I need some help on, or I'll have to resort to a hack to fix it.

    So, we have CRM 2015 and we're using the new quick entry forms in it and they're giving us issues.  We have it set up so that business names are a separate entity from an Order.  So we create a business name entity and associate that to the order.  After we use the quick entry form and it goes away everything on the order page refreshes as expected, but the command bar buttons are unclickable.  If I use developer tools and push F12 I see the following divs:

    <div id="perceivedRibbonManager" style="height: 62px;" key="Newlayout.aspx--10008--fdb882df-a6b0-4e61-baf7-5b169c291bf1--1033--{13121829-85D8-E011-A364-001EC94FFE7F}--{A59563F3-C4D7-E011-A364-001EC94FFE7F}">

    <div id="commandContainer8" style="display: inline;">

    <ul class="ms-crm-CommandBar-Menu">

    <li tabindex="-1" title="Save (CTRL+S) &#10;&#10;Save this Business Filing." class="ms-crm-CommandBarItem ms-crm-CommandBar-Menu ms-crm-CommandBar-Button" id="mnsos_businessfiling|NoRelationship|Form|Mscrm.Form.mnsos_businessfiling.Save" style="display: inline-block; white-space: pre-line;" command="mnsos_businessfiling|NoRelationship|Form|Mscrm.SavePrimary">

    <span tabind

    ...


    and 

    <div id="transparentCover" style="top: -62px; height: 62px; ; z-index: 1; opacity: 0;"></div>

    If I remove both of these elements the crmRibbonManager comes back up to the top and is clickable.

    Of course this only happens on certain user's accounts, but once it starts happening it happens every time.  When I do it on my machine it works fine, the perceivedRibbonManager div is empty and the transparentCover div doesn't exist.

    So my hack is to just remove these 2 divs from the DOM with javascript after the quick entry form is closed.

    Is this a CRM bug?

    Thanks,

    Aaron

    Friday, January 22, 2016 7:45 PM

All replies

  • Hi Aaron,

    Please look for customized buttons on the entity, where you experienced this behaviour. In my case, the system was missing the ToolTipTitle from my customized buttons. After providing this informationen, the buttons never gone inactive.

    Hope this helps.

    Christian

    Wednesday, April 13, 2016 3:13 PM
  • I don't have any customized buttons under my entity.  Where would I find that?
    Wednesday, April 13, 2016 5:58 PM
  • Hello,

    Simply select a standard button then use right-click > Customize Button.


    Cornel Croitoriu - Senior Software Developer

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Biz-Forward.comCroitoriu.NET

    Thursday, April 14, 2016 3:43 PM
  • Where would I do that?  Are you talking about in the form designer?  I can't click on any buttons in that, and I can't access the buttons there anyway because they're CRM default buttons.
    Monday, April 18, 2016 2:11 PM
  • Aaron,

    I've run in to this same situation where we are doing a Quick Create from the Case entity and once they Quick Create form closes the ribbon breaks. Did you ever find a resolution for this?

    Thursday, March 23, 2017 2:55 AM