locked
WHS Health reported "at Risk" - a PC has a new Hard Drive - Won't Remember Settings after PP2 RRS feed

  • Question

  • My server was updated to PP2 (and all my PC's got new connector software updates).

    One of the PC's has a USB drive connected to it.  The drive is not always turned on.  The first time I turned it on after the upgrade I got the health warning that there was a new hard drive.  I figured it was no problem, that I would just reconfigure the backup for that PC and tell it not to back up the external drive.  I did that and thought that would be the end of it.

    However, every time I turn on this external drive when the PC is already running and is connected to WHS, everyone on the network gets the health warning.  I have reconfigured the backup several times to exclude that drive, but it doesn't matter and the error reappears the next time the drive is turned on.

    I don't want to ignore the message because I am not sure if any drive added to any PC on my network would then be ignored.  I am almost certain that with PP1, when I set the backup configuration to exclude the external drive it did not have to be ignored.  But, I might be wrong and even with PP1 I may have finally gotten fed up and ignored it.

    Anyone know for sure if there's been a change or not?

    Thanks.
    Saturday, March 28, 2009 12:31 AM

All replies

  • Unfortunately the same applies to my client pc as well.
    After upgrading it does the same, on newly installed drives which I don't want to backup.
    Anyway, it doesn't really bother me, thereby I ignore it.
    I would recommend doing the same, unless someone else comes up with a specific solution.

    Regards,



    Andreas

    • Marked as answer by VSMN1 Saturday, March 28, 2009 7:59 PM
    • Unmarked as answer by VSMN1 Saturday, March 28, 2009 7:59 PM
    Saturday, March 28, 2009 6:25 AM
  • I figured it out by borrowing another external drive from a friend and connecting it to a different computer.   I told it to ignore my original drive, and I still got a notification for a drive connected to a different PC.   Each instance of a USB drive being connected appears to be tracked independently by the network health process.  So, I can ignore the one connected to one PC and I will still get a notification if one I might want to back up is connected to a different PC.

    It's all good.

    • Marked as answer by VSMN1 Saturday, March 28, 2009 8:04 PM
    • Unmarked as answer by VSMN1 Saturday, March 28, 2009 8:19 PM
    Saturday, March 28, 2009 8:04 PM
  • Sorry for my confusion, but upon continued testing, this is still a problem.  After ignoring it, if you turn the drive off and back on, the warning reappears.  So, it does not remember to ignore the USB drive.

    So, my choice is to either turn off health warnings or load the console every time I connect a USB drive to ignore the warning.
    Saturday, March 28, 2009 8:22 PM
  • I am experiencing the same problem.  I have a portable USB hard drive that I take to and from work.  Everytime I plug it into my home computer, which is running the WHS client, I get the network health is at risk alert, saying that my computer has a new hard drive.  This is annoying, but the real problem is that the portable hard drive is automatically added to the list of drives to be backed up.  Every time I go into the console and uncheck that drive, but the next time I reconnect it, I have to go through the same process again.

    This bug needs fixing ASAP.

    Thank you.
    Tuesday, April 21, 2009 1:54 AM
  • What you describe is a function of the drive, not of Windows Home Server. I have several USB drives, some bare drives I placed in enclosures and some from various manufacturers. None of them has the problem you describe.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, April 21, 2009 4:18 AM
    Moderator
  • How would it be a function of the drive?  It's just a WD portable hard drive.  It's not running any special software.  Nothing runs automatically when I plug it in.  (I didn't install any of the WD software that came on the drive.)  I also have a Maxtor desktop USB drive and WHS says the same thing when I plug it in (and automatically re-adds it to the list of drives to be backed-up, which I then have to log back in and un-select everytime).  And how would a hard drive be making WHS do anything?  It's WHS (or the WHS connector) that's "forgetting" the drive and popping up the message (and re-adding the drive to the list).  Vista doesn't go through the new hardware install process everytime.

    The fact that you're not experiencing the problem indicates to me that there's a bug in WHS or the connector that occurs in certain configurations/situations.  We (or the WHS team) just have to figure out what's going on.
    Wednesday, April 22, 2009 3:44 PM
  • I think it is a function of the connector software.  I have several USB drives on three different PC's.  These drives are mostly "home built" by installing drives into USB2 enclosures, but there is one Maxtor USB/FW drive (connected via FW). 

    All of them started having this problem when PP2 was installed.  I have reinstalled the connector s/w on two machines (one Vista/one XP Pro) and it did not change anything.
    Thursday, April 23, 2009 12:32 PM
  • I also have this problem since PP2. I have 3 portable hard drives that I use for a WD TV HD Media Center. They typically are not connected to my desktop. Whenever I do connect them, I get the "at Risk" warning. I have set up these drives to each use a unique NTFS folder on my D: drive and to not assign any drive letters. I thought if I connected all three and configured backup to exclude them, then I would not have a problem. BUT.... not the case, everytime I connect one, I still get the "at Risk" warning.

    On my system, the only drive that I want WHS to backup is my C: drive and no others. I selectively backup stuff on the other drives using SyncBack, to file shares on the home server so that they are available to other computers in the house (music, pictures, videos, etc.). I manually backup the portable hard drives whenever I add media to them. I don't want them included in the WHS automatic backup.

    There needs to be a way to tell WHS that it should always ignore any new drives. At the very least, it should allow me to acknowledge and cancel the warning from the connector instead of having to go through the lengthy process of connecting to the WHS console and selecting a computer and configuring backup. Also, once I tell it not to backup a specific drive, that setting should stick. This is definitely a bug and did not occur pre-PP2. I also use TrueCrypt for financial data. When I mount a TrueCrypt volume, it also causes the "at Risk" even if I had told WHS to ignore that specific drive letter previously.

    I really like my home server but this is a pain! I hope Microsoft will fix this.

    Reproduction Steps.
    o Connect two portable USB hard drives
    o configure each to mount to a unique NTFS directory with no drive letter
    o Shutdown and reboot
    o Plug in Drive 1
    o Configure backup on WHS to exclude it
    o Unplug it and plug in Drive 2
    o Configure WHS to exclude it
    o Unplug it and plug in Drive 1 again
    o WHS says "Network At Risk"

    Wednesday, April 29, 2009 3:01 AM
  • Thank you for that excellent post, Rick!  My WHS came with PP2 installed on it (or it downloaded right when I set it up), so it's good to know that this is a new problem.  Hopefully it won't take too long to fix.

    Ken (or any other guru): Is there a better way to let the WHS team know of the problem, if they don't already?  (I can't believe someone on the team hasn't already seen this problem first-hand, but you never know.)

    Thanks.
    • Edited by eshiggs Wednesday, April 29, 2009 3:18 AM spelling
    Wednesday, April 29, 2009 3:17 AM
  • Thank you for that excellent post, Rick!  My WHS came with PP2 installed on it (or it downloaded right when I set it up), so it's good to know that this is a new problem.  Hopefully it won't take too long to fix.

    Ken (or any other guru): Is there a better way to let the WHS team know of the problem, if they don't already?  (I can't believe someone on the team hasn't already seen this problem first-hand, but you never know.)

    Thanks.
    You can post a bug report/suggestion on Connect.
    Friday, May 1, 2009 4:20 AM
    Moderator
  • Thank you for that excellent post, Rick! 
    I'm glad my post was of some use to you.

    I did post this on Microsoft Connect as well. The url is https://connect.microsoft.com/WindowsHomeServer/feedback/ViewFeedback.aspx?FeedbackID=435950

    Microsoft has not responded yet.

    Thanks
    Friday, May 1, 2009 12:49 PM
  • Thank you kariya21!  I wasn't even aware of that site -- and my company is a Microsoft Partner!  :-)

    Rick: I added my validation of the problem.

    VSMN1 and Pettakos: You may want to add your validations too.

    Thank you everyone!
    Friday, May 1, 2009 3:30 PM
  • I added my validation since I have been really annoyed by this behaviour of WHS from the beginning. I am surprised that there is not much more echo from the user community about this. Or does it only happen in certain circumstances? I am using two home servers, one from Fujitsu with pre-installed server software and a home-built one with an OEM license. The external hard drive issue exists on both platforms, and as far as I can remember it was also there when I used the try-out version last year.
    Tuesday, June 9, 2009 5:13 PM
  • ... Or does it only happen in certain circumstances? ...
    This, I believe. If you scroll up you'll see I've stated I don't see this behavior, even though others do. So there's an external or environmental factor at work here.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, June 9, 2009 5:36 PM
    Moderator
  • I am experiencing the same problem but on a much bigger scale.  I have a Mvix MX-780HD media player that is network attached.  It has an internal hard drive and the unit acts like a network attached storage system.  It is accessible to all of our systems (7 total) as a shared drive.  We load movies on the Mvix and take it with us in our camper to watch movies without having to take all the DVDs.  It is an excellent solution.  But when we return home and I reconnect the Mvix to the home network, I get seven "At Risk" messages that all the computers have a new hard drive.  I have to go into the console and manually reconfigure all seven computer's backups to exclude the Mvix.  A huge pain.  WHS needs to remember that if a drive (USB or network attached) is disconnected and reconnected, the backup settings need to remain the same.


    Tom
    • Edited by tsteuver Sunday, August 9, 2009 1:53 AM
    Sunday, August 9, 2009 1:33 AM