Confirm assignment dialog box does not show up when clicking ownerid field (email entity) RRS feed

  • Question

  • Hi,

    I have faced really weird issue on my Dynamics CRM 2011 deployment. I am using two environments - one is used for developing purposes other is the on which user are perfoming the tests on.

    The tests on testing evrionment revealed that while user tries to change the value of the ownerid field from the form (not from the ribbon button) the Confirm Assignment dialog box does not shows up, CRM displays normal look up windows the same like for custom lookup fields and the changes made in this way are not 'seen' by CRM as it would be no change done on the form (form is not refreshed after clicking "save" button, when user clicks "save and close" the form is closed but after opening it again value of the ownerid field remains unchanged).

    The problem is that there is no way to replicate this behaviour on developing environment, here everything works correct (Confirm Assignment dialog box is showed, and user is able to successfully change the owner of email record). Both environments are congured exactly the same, I have even tried to simply export email entity in crmsolution from developing to testing environment, but it didn't help at all).

    While debugging form in IE after clicking ownerid lookup field on testing environment using networ caputre tool I can see GET method on url started form:


    whrereas on developing environment it looks different its:


    Funny thing is that this issue exists only on the email enitty in the testing environment, ownerid fields of the other entities works well (including the activity entities like tasks).

    Where could this difference get from? Are there any system settings that are defining behaviour of ownerid field which are not possible to be migrated with CRMSolution? What else I can do to solve this? Anyone faced similar bizzarre CRM bug?

    Best regards, Kubas

    • Edited by Kubas_86 Wednesday, December 18, 2013 7:23 PM
    Wednesday, December 18, 2013 7:21 PM