locked
WHS backup fails RRS feed

  • Question

  • Hi,

    I got a new laptop to replace my aging winXP machine. Backups have been running flawless for years on that machine. However, I cannot seem to get a successfull backup for my new machine (64bit Win7). It constantly fails at 12%. If I look in the event log, I find the following two errors:

    • Unexpected error 0x1 from WriteFile on D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\LAPTOPDELL.RECOVERY.VolumeCluster.4096.new: Incorrect function.
    • Client Backup server failed at d:\wssg_src\whs_pp3\qhs\src\backup\util\diskfile.cpp(421)

    I've run checkdisk on both the client and the server. Backups from the xp machine still work. I've reinstalled the whs console (and removed the laptop from the list of conneceted PCs.

    I'm desperatly seeking help for this one...

    Greetings,
    Lodewijk

    Sunday, August 21, 2011 7:11 PM

All replies

  • Looks like it is something to do with the Dell recovery partition - what happens if you exclude that from the backup? Did you run Chkdsk on that partition?
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Sunday, August 21, 2011 7:44 PM
  • Try to exclude this volume from backup (its not needed anyway under most circumstances and sometimes these recovery volumes, which should be invisible, contain a specific flag, which theoretically could cause the trouble you see).

    On the other side - such write errors can mean both - read problems or write issues, so check also the event log of your WHS, if it indicates any trouble with the servers harddisks, usually red entries from source ntfs.

    Best greetings from Germany
    Olaf

    Monday, August 22, 2011 12:24 PM
    Moderator
  • Run a chkdsk on boot. I just solved my problem by doing that (the scan found many errors and dead clusters) and on reboot, the backup went flawlessly. This drive will be trashed since it has too many read errors but at least I now have a working backup!!
    Wednesday, February 29, 2012 6:28 PM
  • I have started getting this same error on my Windows 8 workstation backup.  multiple backup attempts bring the same error at about the same time during the backup.

    The failure occurs during the backup of drive c:

    Two WHS errors are given just as in the above case.

    Chkdsk reported zero errors on the C: drive.

    Can you tell me what did or did not resolve your problem?  Thank you.  Eric Lewis


    Eric Robert Lewis, Ph.D.

    Thursday, April 11, 2013 6:37 PM
  • Please check the event log of the client for relevant error messages.

    Best greetings from Germany
    Olaf

    Thursday, April 11, 2013 8:33 PM
    Moderator
  • I've checked the client side for error messages and found nothing except notation of the event.  I did all the chkdsks too.

    However, I took a closer look at my storage on the WHS v1 very much 32-bit, and noticed that the nice new 4 TB USB drive that was listed as a 4 TB drive in the WHS client screen ... showed up in Disk Administrator as a 2 TB partition with the remaining 1.85 GB or so portion of the hd un-allocated.  I was afraid of that but suspended belief when I saw the disk show up as 4 TB in the client. 

    So, if this was causing a little confusion for the WHS client... perhaps ...

    So I removed the 4TB hd from the storage pool and guess what?  A nice clean backup ensued.

    I've not had any problems with all sorts of different sized USB connected hard drives before but none larger than 2 TB.


    Eric Robert Lewis, Ph.D.

    Friday, April 12, 2013 3:00 AM
  • Windows Home Server v.1 unfortunately does not support client disks larger than 2 TB.

    Best greetings from Germany
    Olaf

    Friday, April 12, 2013 6:17 AM
    Moderator