locked
CRM 2011 - Reporting Extensions: Reports will not be published for some organizations because the Report Server instances used by these organizations differ from the instance selected during Microsoft Dynamics CRM Reporting Extensions Setup. RRS feed

  • Question

  • Hi,

    - Installed CRM 2011, did not check the "Launch Reporting Extension Setup" at the end of that;

    - Installed Language Pack

    - Installed Rollup 1

    - Installed Rollup 1 for Language Pack

    Then I tried to install Rporting Extension, but i got the Warning reported on this thread title and this one:

    A Microsoft Dynamics CRM Server component is using the same account as the instance of SQL Server Reporting Services.

    I was trying to solve the warning reported on the title, here the steps I' ve done.

    Here part of the log:

    10:06:30|Verbose| Method entry: Microsoft.Crm.Setup.Common.SetupBase.Run

    10:06:30|Verbose| Method exit: Microsoft.Crm.Setup.Common.SetupBase.Run

    10:06:30|   Info| CrmAction execution time; CollectAction; 00:00:00.0058500

    10:06:30|   Info| CrmAction execution time; CollectAction; 00:00:00.0253500

    10:06:32|Verbose| Retrieving Base Language Id Provider=SQLOLEDB;Data Source=SERVER2;Initial Catalog=CRMORG_MSCRM;Connection Timeout=60;Integrated Security=SSPI ...

    10:06:32|   Info| Base Language Id of CRMORG_MSCRM: 1033.

    10:06:32|Warning| Instance Name needs to be escaped. Management Exception: Invalid Namespace

     10:06:32|   Info| Escaped Instance Name is RS_MSSQLSERVER

    10:06:33|Warning| Could not find a local RS instance corresponding to the reporting url https://server2.CRMORG.local/reportserver for organization CRMORG

    10:06:33|   Info| CrmAction execution time; CollectAction; 00:00:03.3413250

    10:06:34|Warning| Instance Name needs to be escaped. Management Exception: Invalid Namespace

     10:06:34|   Info| Escaped Instance Name is RS_MSSQLSERVER

    Then I searched for solutions. I found this:

     

    1.       http://social.msdn.microsoft.com/forums/en-US/sqlreportingservices/thread/e90c853b-6018-41b0-9dd1-abd2ac872f16/

     

    Q: I get this when trying to connect to my local machine's instance of Reporting Services.  I know that it's running because I can push reports and run reports.  I've even managed to edit the config file so I can send e-mails through a data-driven subscription.  However, I cannot connect to my Reporting Services instance through the 2008 Configuration Manager.  I always get an "invalid namespace" message.

    Any suggestions?

     

    A: Steps to modify the MOF file to fix this issue:

    1.       Locate the existing MOF file (example: %ProgamFiles%\Microsoft SQL Server\MSRS10.SQL2008\Reporting Services\ReportServer\bin\reportingservices.mof would be the default location for a Reporting Services instance named SQL2008).

    2.       Copy this reportingservices.mof to reportingservicesalt.mof (or some other unique name).

    3.       Notepad reportingservicealt.mof

    4.       Choose edit->replace…

    5.       In the dialog, in the Find What: text box enter the modified instance name (for an RS instance named SQL2008, the modified instance name is RS_SQL2008), in the Replace with: text box enter the instance name unmodified (so for an RS instance named SQL2008, just enter SQL2008).

    6.       Press the Replace All button.

    7.       Save and close notepad.

    8.       From a command window at the same location as the results of step 1, type MOFCOMP REPORTINSERVICESALT.MOF (or whatever the name from step 2 was).

     Now the configuration tool should work with the following exception, if the RS instance name contains an underscore (_), a dollar sign ($) or a hash (#), then step 8 will fail and the user will need to re-install the Reporting Services instance with a name that does not include any of these three characters.

    Done what suggested above, then tried to install Reporting Extensions again: same error. However, the log changed a bit: here the same part of it:

    13:41:28|Verbose| Method entry: Microsoft.Crm.Setup.Common.SetupBase.Run

    13:41:28|Verbose| Method exit: Microsoft.Crm.Setup.Common.SetupBase.Run

    13:41:28|   Info| CrmAction execution time; CollectAction; 00:00:00.0048825

    13:41:28|   Info| CrmAction execution time; CollectAction; 00:00:00.0205065

    13:41:30|Verbose| Retrieving Base Language Id Provider=SQLOLEDB;Data Source=SERVER2;Initial Catalog=CRMORG_MSCRM;Connection Timeout=60;Integrated Security=SSPI ...

    13:41:31|   Info| Base Language Id of CRMORG_MSCRM: 1033.

    13:41:32|Warning| Could not find a local RS instance corresponding to the reporting url https://server2.CRMORG.local/reportserver for organization Blind

    The

    10:06:32|Warning| Instance Name needs to be escaped. Management Exception: Invalid Namespace

     10:06:32|   Info| Escaped Instance Name is RS_MSSQLSERVER"

     

    now is missing.

    So I tried this:

    http://social.microsoft.com/Forums/en-US/crm/thread/593fb3e1-2b5e-4123-8b9a-466a0925973b

    WORKAROUND: Update the rsreportserver.config for the RS instances that are not configured such that it has an empty UrlString node if not present as follows:

    <Configuration>

      <URLReservations>

        <Application>

          <Name>ReportServerWebService</Name>

          <VirtualDirectory>

          </VirtualDirectory>

          <URLs>

            <URL>

                    <UrlString />

            </URL>

          </URLs>

        </Application>

        <Application>

          <Name>ReportManager</Name>

          <VirtualDirectory>

          </VirtualDirectory>

          <URLs>

            <URL>

            </URL>

          </URLs>

        </Application>

      </URLReservations>

    the file mentioned was:

     <URLReservations>
      <Application>
       <Name>ReportServerWebService</Name>
       <VirtualDirectory>ReportServer</VirtualDirectory>
       <URLs>
        <URL>
         <UrlString>http://+:80</UrlString>
         <AccountSid>S-1-5-18</AccountSid>
         <AccountName>LocalSystem</AccountName>
        </URL>
        <URL>
         <UrlString>https://Server2.CRMORG.local:443</UrlString>
         <AccountSid>S-1-5-18</AccountSid>
         <AccountName>LocalSystem</AccountName>
        </URL>
       </URLs>
      </Application>
      <Application>
       <Name>ReportManager</Name>
       <VirtualDirectory>Reports</VirtualDirectory>
       <URLs>
        <URL>
         <UrlString>http://+:80</UrlString>
         <AccountSid>S-1-5-18</AccountSid>
         <AccountName>LocalSystem</AccountName>
        </URL>
        <URL>
         <UrlString>https://Server2.CRMORG.local:443</UrlString>
         <AccountSid>S-1-5-18</AccountSid>
         <AccountName>LocalSystem</AccountName>
        </URL>
       </URLs>
      </Application>
     </URLReservations>

    I modified it this way:

     <URLReservations>
      <Application>
       <Name>ReportServerWebService</Name>
       <VirtualDirectory>ReportServer</VirtualDirectory>
       <URLs>
        <URL>
         <UrlString />     
        </URL>
       </URLs>
      </Application>
      <Application>
       <Name>ReportManager</Name>
       <VirtualDirectory>Reports</VirtualDirectory>
       <URLs>
        <URL>
         <UrlString>http://+:80</UrlString>
         <AccountSid>S-1-5-18</AccountSid>
         <AccountName>LocalSystem</AccountName>
        </URL>
        <URL>
         <UrlString>https://Server2.CRMORG.local:443</UrlString>
         <AccountSid>S-1-5-18</AccountSid>
         <AccountName>LocalSystem</AccountName>
        </URL>
       </URLs>
      </Application>
     </URLReservations>

    But neither this solved the problem.

    Then I choose to install Reporting Extension even if I was still getting the warning; the installation was succesful, but obviously the reports are not avaiable.

    The log does not reports nothing different from the last i reported above.

     

    What I have to do to solve this problem?

    Does I need to solve first the other warning?

    Thanks a lot,

    Lorenzo

    Wednesday, May 11, 2011 10:41 AM

All replies

  • Can you disable your CRM Org in the Deployment Manager then edit it and ensure you have the correct SQL Report Server path listed.  Check the Report Server path in the Deployment Manager to ensure you can browse to the Report Server.  If there is no Report Server URL listed then add it and complete the remaining steps of the wizard.  Then try to install the List Component again.

    If the above does not work, tell us about your environment.


    Regards, Donna

    Saturday, May 28, 2011 10:03 PM
  • In the deployment manager I see:

    https://server2.CRMORG.local/reportserver 

    This is the Report Server URL, not the Report Manager URL, as the Installing Guide tells.
    If I put that URL in the browser, I reach the correct page.

    The environment:
    - Windows Server 2008 SP2
    - SQL Server 2008 SP1
    The server ("Server2") has installed CRM 2011, NAV, SQL Server.


    In the Manager Studio I tried to connect the Reporting Services instances:
    - Server2\MSSQLSERVER
    - Server2

    and both were connected correctly. Those instances have the same items under security>roles:

    - Browser for Microsoft CRM
    - Report Generator
    - Content Management
    - Publisher
    - Publisher for Microsoft CRM
    - Personal Reports
    - Visualization

    (I could post an image, but i don't know how)

    This make me assume that those 2 instances are the same instance, but i do not know how to verify this.
    The strange thing is that The Database Engine is 10.0.2531 but the Reporting Services are 10.0.1600 ... Is this a problem?

    Thanks for the answers,

    Lorenzo 

    Monday, May 30, 2011 7:46 AM
  • I don't think the version difference is an issue.  I think there is something in your installation that is 'non-standard' but I don't know what.  I'm having a little difficulty following some of your comments.  This one for for example:

    "In the Manager Studio I tried to connect the Reporting Services instances:
    - Server2\MSSQLSERVER
    - Server2"

    When you installed CRM, did you install it to the default SQL instance or a named instance?  Also, I'm not sure I understand why your Report Server URL has ".local" in the name.  The report server URL should be something like https://CRMReportServerName/reportserver.  I'm wondering if the URL's are name incorrectly in the deployment manager and the config file.  Also wondering if you need to add the port number to the URL in the config file.  I think IIS understands the port to route https requestst to but I could be wrong.


    Regards, Donna

    Monday, May 30, 2011 7:35 PM
  • I've installed CRM to the default instance; when I configure the reporting services I can only select the SERVER2\MSSQLSERVER instance. Could SERVER2 and SERVER2\MSSQLSERVER be the same instance? SQL Server was not installed by myself.

    In the deployment manager I've got the same url I've got in the reporting services configuration manager.

    In the reporting services configuration manager I can see 2 urls:

    http://server2:80/reportserver

    https://server2.crmorg.local:443/reportserver

    During CRM installation the first one was not accepted; the second one (https) was accepted correctly: I put the address in the browser then i copied it into the CRM url box (without the ":443", since the browser removed it).

    So I have to uninstall Reporting Extension and re-install it specifying the port number? Or I can change some setting?

    Thanks a lot for your help

    Lorenzo

     

    Tuesday, May 31, 2011 7:35 AM
  • If it were me, I would try to get  http://server2:80/reportserver working and remove https://server2.crmorg.local:443/reportserver unless there is a good reason why you need a secure connection.  If you change it then you need to first update the reportserver.config file and add the correct URL, removing the other references then disable the CRM Org, edit it and update it with the new URL and finish the wizard

    Before you make changes, can you access http://server2:80/reportserver Do you see the Admin folder there when you access the URL.  You shouldn't need the port number in the URL since it is using the default port.  Try http://server2/reportserver instead

    Is your CRM server installed on the default Web site (port 80) or did you create a new web site when you installed CRM port 5555?


    Regards, Donna

    Tuesday, May 31, 2011 11:39 AM
  • I'll try and I'll let you know.

    I've Installed the CRM creating a new site with port 5555.

    Thanks a lot again.

    Lorenzo

    Tuesday, May 31, 2011 12:08 PM