locked
Error Running Reports from MSCRM 4.0 Web Client RRS feed

  • Question

  • Hi,

    We are facing issue running CRM Reports from web client. We have SQL server and Reporting Services installed on one machine and CRM Server installed on another. Couple of days back everything was fine. Now following error comes up; I am able to run reports by going directly to reportserver but when a report is run from CRM it says:
    [ReportServerException: Cannot create a connection to data source 'CRM'. (rsErrorOpeningConnection)]

    ReportServerException: An error has occurred during report processing. (rsProcessingAborted)]
       at Microsoft.Reporting.WebForms.ServerReport.SetDataSourceCredentials(DataSourceCredentials[] credentials)
       at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport report)

    [CrmReportingException: An error has occurred during report processing. (rsProcessingAborted)]
       at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport report)
       at Microsoft.Crm.Web.Reporting.SrsReportViewer.ConfigurePage()
       at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
       at System.Web.UI.Page.HandleError(Exception e)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
       at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
       at System.Web.UI.Page.ProcessRequest()
       at System.Web.UI.Page.ProcessRequest(HttpContext context)
       at ASP.crmreports_rsviewer_reportviewer_aspx.ProcessRequest(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


    Can some one please let me know what could be the reason?? I have checked connection string of MSCRM_DataSource on report server in 4.0 folder under ORG_MSCRM and it is pointing to the right server and connection string seems to be fine.

    What else could be the reason?

    Regards,

    Wednesday, December 9, 2009 8:52 PM

Answers

  • Try doing a repair or reinstall the SRSS Connector.
    Best Regards, Donna
    • Marked as answer by Imran I Abbasi Wednesday, December 9, 2009 11:25 PM
    Wednesday, December 9, 2009 9:45 PM

All replies

  • Try doing a repair or reinstall the SRSS Connector.
    Best Regards, Donna
    • Marked as answer by Imran I Abbasi Wednesday, December 9, 2009 11:25 PM
    Wednesday, December 9, 2009 9:45 PM
  • I repaired SSRS Connector and issue has been fixed. 

    Thanks Donna. 
    Wednesday, December 9, 2009 11:25 PM