locked
Right-click menu option missing? RRS feed

  • Question

  • In the prior version, I could just right-click on my images and stitch them in ICE. After the recent upgrade, that option is missing.

    Any way to get that back?

    I have uninstalled and re-installed, no luck.

    Thursday, June 16, 2011 3:13 AM

Answers

  • Sorry this feature has been removed from the latest version of ICE.
    Thursday, June 16, 2011 3:33 PM

All replies

  • Sorry this feature has been removed from the latest version of ICE.
    Thursday, June 16, 2011 3:33 PM
  • I have been using the right click option in ICE very often, and I miss it !!

    Is there a way to create a new shortcut?

    Friday, June 17, 2011 3:01 PM
  • Why would you disable this function?

    I used the right click all the time.. Taking away user friendly and time saving functions seems a little weird for an 'upgrade'.

    Please bring it back! :)

    Wednesday, June 22, 2011 10:33 PM
  • Uh, Not sure why you would want to remove the ability to drop a file on ICE when open, or why you would want to removed a logical right click call for the program to pick up the photos for stitching. As it now stands I have to open ICE, go to the file menu in ICE, search backwards through the directories to find the two or three files that are already open and displayed on my desktop. How is that logical or convenient.

    Are you considering restoring these functions in a later release?

    I work in Real Estate and ICE used to be a valid and valuable tool for my work. Now..... Just kinda disturbed.

    Tuesday, July 5, 2011 3:18 AM
  • The ability to drop a file on ICE is still there.  The right click option in Windows Explorer is no longer there.
    Saturday, July 9, 2011 11:57 PM
  • Matt,

    Well, the right click option is not there in my installation either, and I am not able to drop files on the open Microsoft Ice application. This "release" appears to have been crippled or corrupted in some way.

    I have removed ICE from my system no less than five times, restarted the system and then reinstalled ICE. Each time I get the same result. No right click menu item, and no ability to drop files on the application.

    I work in Real Estate and have used Microsoft Ice daily to easily and conviently stitch panoramas to get images that were not available otherwise. Now I am not able to use ICE as the process to dive through the directorys to find the files I need is debilitating, to say the least. I am not using Microsoft ICE now.

    That right click option is what made Microsoft ICE viable, in my opinion. I would still use it, but am not able to open files by dropping either.

    Perhaps you could go back and review the build? Surely, something sure appears to be out of order.

    I am running Windows 7 Ultimate on a 2.8 GHZ Pentium D 32 bit.


    All my applications are up to date.
    Monday, July 25, 2011 5:58 PM
  • Someoneone needs to find the prior version that we can download and get our right-click back!
    Monday, July 25, 2011 6:01 PM
  • BrianSharp,

    You and I must be the only people on the Planet using this feature.

    Bryant

    Monday, July 25, 2011 6:21 PM
  • Matt,

    Sorry, it is not present in my install. I can select files all day long but all I get is a circle with a slash through it when I mouse over the ICE open window.

    Monday, July 25, 2011 6:31 PM
  • I just tried this on several examples.  It's working on my system.  So, we need to figure out what is different about your use or your system. 

    Are you dragging onto the ICE icon or onto the running ICE application window?

    What kind of image files are you dragging (.jpg, .tiff,) ?

    How many images are you dragging onto ICE?

    Are you dragging images from Windows Explorer?

     

     

    Monday, July 25, 2011 10:01 PM
  • Also note that drag-and-drop of files from Windows Explorer to any program running with elevated permissions (running as administrator) is disallowed on Windows Vista and Windows 7, for security reasons.

    I'm not sure why you'd run ICE as administrator, since it doesn't need elevated permissions, but that would explain the problem.  Is it possible you right-clicked on ICE and selected "Run as administrator"?  To make sure you're not permanently running ICE as an administrator, please right-click on ICE (either in the Start menu or in Windows Explorer) and select "Properties", then switch to the "Compatibility" tab and make sure the box labeled "Run this program as an administrator" is not checked.


    Eric Stollnitz, Interactive Visual Media Group, Microsoft Research
    Monday, July 25, 2011 10:40 PM
    Moderator
  • That's horrible! Why would they do that?
    I think I have an old version ICE installer.
    I might just go back to that.
    Saturday, October 1, 2011 12:59 AM
  • I've been looking for that. If you still have it and wouldn't mind sharing, I'd love to revert back. If it's too big to email, maybe via dropbox or something like that?
    Saturday, October 1, 2011 1:02 AM
  • Me Three! I am the third person on this planet using this awesome feature. I want it back too ! please reply if you have the earlier version. Thank you.
    Thursday, December 8, 2011 4:36 AM
  • Me too want this function back, Makes it number 4!
    Tuesday, January 10, 2012 10:40 PM
  • ShellExtension.dll is still registered as the right-click shell extension at:

    HKEY_CLASSES_ROOT\CLSID\{1AC77AE9-9EC6-405A-9F9B-C06AB3C10B71}

    during ICE 1.4.4 installation, but the file is missing (it was removed from this version).

    When I copied ShellExtension.dll version 1.2.3.1 (from ICE 1.2) and put it in the ICE 1.4.4 (x86) installation folder:

    C:\Program Files\Microsoft Research\Image Composite Editor\ShellExtension.dll (default for 32-bit), the right-click functionality was restored successfully (it worked like previously on my computer).

    (I don't know if this will work on a 64-bit machine, though...)

     

    • Proposed as answer by jakub.hejnic Tuesday, January 31, 2012 9:32 PM
    Friday, January 13, 2012 4:45 PM
  • Thanks John! It's redemptive idea after year of searching.

     

    It works also on 64-bit:

    1) Install ICE 1.4.4, copy the folder from C:\Program Files\Microsoft Research\Image Composite Editor\ to different destination

    2) Uninstall ICE 1.4.4

    3) Install ICE 1.3.5

    4) Open the "different folder" (see 1)) with ICE 1.4.4, copy these files to ICE 1.4.4 folder ( C:\Program Files\Microsoft Research\Image Composite Editor\ ):

    • ICE.exe
    • ICE.exe.config
    • StitchEngine.dll
    • WICDiag.exe
    • WLPG.dll
    • folder Templates

    [Maybe It would be the same as copy everything, from "different folder", because it doesn't contain ShellExtension.dll ]

    64 bit:
    ICE 1.3.5
    ICE 1.4.4

    32 bit:
    ICE 1.3.5
    ICE 1.4.4

    _______________________________________________

    In few words: Install ICE 1.3.5 (keep its registry settings) and then overwrite all files except ShellExtension.dll with files from ICE 1.4.4 (get new version functionality).

    If links stop working, new version is always on this web, older is from time to time stored on software servers. 

    I am the number 5!

    • Proposed as answer by jakub.hejnic Tuesday, January 31, 2012 9:31 PM
    Tuesday, January 31, 2012 9:30 PM

  • Thank you, thank you, THANK YOU!!  I was so disappointed to use the latest version of ICE and see this feature gone.  WHAT THE HECK!! Why would something so easily applied be omitted from the install process??  I hope that was just a stupid mistake made by the ICE team.  Either way, I'm glad the fix was that simple.
    Saturday, August 3, 2013 5:32 PM