locked
Cannot run get-ucpool or exchucutil after migrating to ocs 2007 r2 RRS feed

  • Question

  • I did a parrell migration. I migrated to a configuration container and installed a new ocs 2007 r2 pool and services. moved the users over and everything looks good. audio calls work and my pbx can call the mediation server and end users with no issues. The problem I have is when I run any of the exchange utils to connect the 2 together they fail. It is Exchange 2007 SP1 Rollup 7.
    when i run get-ucpool.ps1 i get this.
    [PS] C:\Program Files\Microsoft\Exchange Server\Scripts>.\Get-UCPool.ps1
    Using Global Catalog: GC://DC=arrayasolutions,DC=com

    You cannot call a method on a null-valued expression.
    At C:\Program Files\Microsoft\Exchange Server\Scripts\Get-UCPool.ps1:186 char:4
    1
    +         $obj.Name    = $adsiPool.psbase.InvokeGet( <<<< "CN");

    RTCPools                   RTCUniversalServerAdmins   RTCComponentUniversalServ
                                                          ices
    --------                   ------------------------   -------------------------
    {ocs.BLAH.com}  @{Name=RTCUniversalServ... @{Name=RTCComponentUni...

    ocs.blah.com is right.... but the errors arent.

    When I run exchucutil.ps1 I get this:
    [PS] C:\Program Files\Microsoft\Exchange Server\Scripts>.\ExchUCUtil.ps1

    Using Global Catalog: GC://DC=arrayasolutions,DC=com

    Failed to read Communications Server 2007 pool objects. Please verify Communicat
    ions Server 2007 is deployed in this Active Directory forest and you are a membe
    r of the RTCUniversalServerReadOnlyGroup group or have sufficient privilege to r
    ead from this Active Directory container. Additional information follows: You ca
    nnot call a method on a null-valued expression.


    Im running this as a DA and running powershell as an admin. Not that much of a n00b!

    Any ideas???

    Friday, April 3, 2009 9:28 PM