locked
Windows Home Server Internet Access RRS feed

  • Question

  • I can access my Windows Home Server fine from Home, but cannot access it from the internet. Using NetGear Router and DSL Modem
    Saturday, September 19, 2009 8:04 PM

All replies

  • The router and the modem should be configured in bridge mode, or you need to establish proper port forwarding between the modem and the router, since such a configuration often is based on a double NAT. (And this is something, WHS does not support out of the box.)
    Best greetings from Germany
    Olaf
    Saturday, September 19, 2009 8:52 PM
    Moderator
  • I had sort of same problem, I could not see my server from home over the internet via the https://XXXXXXXX.homeserver.com address that you create via the settings of the WHS console.
    I could access the server however via a https://192.168.1.xxx xxx being the ip address you give your server.
    Also it will need to be a static IP address.
    As in my case my route didnt like looking for the .homeserver.com address as I was not in its routing table as being external.
    Have you tried access it via the ip address from home?
    I also had to configure the Internet options to allow the https// etc to a trusted site in the security settings of I.Explorer settings.
    Last thing to check is the server firewall settings has the exceptions in the advanced section.  ( I left mine as default)
    Sunday, September 20, 2009 3:11 AM
  • I had sort of same problem, I could not see my server from home over the internet via the https://XXXXXXXX.homeserver.com address that you create via the settings of the WHS console.
    I could access the server however via a https://192.168.1.xxx xxx being the ip address you give your server.
    Also it will need to be a static IP address.

    No, WHS does not have to have a static IP.  As a matter of fact, technically speaking, setting your server with a static IP is unsupported (because it involves logging into the server desktop).

    As in my case my route didnt like looking for the .homeserver.com address as I was not in its routing table as being external.
    Have you tried access it via the ip address from home?
    I also had to configure the Internet options to allow the https// etc to a trusted site in the security settings of I.Explorer settings.
    Last thing to check is the server firewall settings has the exceptions in the advanced section.  ( I left mine as default)

    Sunday, September 20, 2009 4:51 AM
    Moderator
  • You can often determine where the problem lies by examining your router's configuration pages. It should include information about the WAN address (the exact terminology varies from manufacturer to manufacturer). If that doesn't match the IP address a site such as e.g. this page reports for your connection, and in particular if it's an address that's part of a private network address range, then you have the "double NAT" situation Olaf mentioned. In that case, your best course of action is to put your DSL modem in bridge mode (not both router and modem). If that doesn't work, you may need to contact your ISP for assistance.
    I'm not on the WHS team, I just post a lot. :)
    Monday, September 21, 2009 5:16 PM
    Moderator