locked
Send Timesheet Locked/Disabled for Resource RRS feed

  • Question

  • A resource's timesheet has been disabled/locked in the periods that he's missed. He did not have this issue about two weeks ago submitting missed timesheets. As of today, the send timesheet button is disabled/greyed out. The send status however is available. I tried deleting/recreating timesheet but still does not work on all of them. Please note that when I recreate the timesheet it automatically adds the 40 hours for the week, is that normal? I have checked and periods are OPEN for these weeks. I am running out of ideas of why this is causing his timesheets to not send. A while back, he had an error on a timesheet that I recently rejected and deleted/recreated if that provides any hints. 

    Regards,

    John


    Johnny Eltawn, Project Server Admin

    Friday, April 17, 2015 6:56 PM

All replies

  • Try to recall -> delete and recreate the timesheet. If Send Timesheet option disabled then click on Send Status first before you send Timeshee.

    Also please verify PWA setting and enable Single entry mode and Protected user actuals under Quick Launch, in the Settings section, click Server Settings ->Time and Task Management section, click Timesheet Settings and Defaults.

    Protect actual setting will restrict PM to update actual directly in work plan.

    Hope this setting will help to prevent issue.

    -------------------------------------------------------------------------

    Raushan Kumar |LinkedIn


    Sunday, April 19, 2015 11:25 AM
  • Hi Raushan,

    Do you mean send status? before send timesheet? Again, the timesheet is not submitted state it is still showing "IN Progress" so the recall button is not available unless it got submitted. I've tried deleting the timesheet and then recreating however, and the send timesheet is still not available, it is greyed out. Timesheet settings are already set to Single entry mode. 


    Johnny Eltawn, Project Server Admin

    Sunday, April 19, 2015 9:58 PM
  • Make sure the browser has compatibility mode on and a trusted site.  

    Also see if the behavior is the same on a different workstations.

    cheers


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Monday, April 20, 2015 1:55 AM
  • As mention by Michael clear your browser cache and trust the site then click on Send Status first before you send Timeshee.

    Hope this will fix the issue.

    -------------------------------------------------------------------------

    Raushan Kumar |LinkedIn


    Monday, April 20, 2015 10:29 AM
  • Good answer.
    Monday, April 20, 2015 10:38 AM
  • Thank you for the response.

    I cleared browser cache and still send timesheet is disabled. I try to send status, and I am getting the message after clicking 'Send Status' all tasks, the pop up shows :

    "The submitted timesheet contains lines that have been rejected. Update these lines on your timesheet and then resubmit it."

    Could this be the issue for the send timesheet being disabled? However, I try to find which line is rejected under the "Process Status" column and all of them are blank, none showing Rejected. What should I do?

    Thanks,



    Johnny Eltawn, Project Server Admin

    Monday, April 20, 2015 5:32 PM
  • Seems this is bug in MSPS 2013, you can Recall TS to Identify Assignment rejected task
    by process status as "Rejected" and the it's cells in the Task Entry
    grid would be read-only, As temporary workaround you can select that task and
    click on “Remove Task” from option Ribbon.

    Now you would be able to submit timesheet without any error.

    Hope this will help you

    -------------------------------------------------------------------------

    Raushan Kumar |LinkedIn


    Monday, April 20, 2015 9:33 PM
  • Rashaun,

    Except when I do try to remove this task with this bug, the 'Remove Task' button is also greyed out for this task  (disabled)... It seems like every solution I try it does not want to let me figure it out. What would be the next option? 


    Johnny Eltawn, Project Server Admin

    Tuesday, April 21, 2015 4:26 PM
  • Johnny,

    What you are seeing is a standard behavior of timesheets in project server. It is NOT a bug.

    All you need to do is make a modification to the rejected line in the timesheet(Like Just make add an hour to the timesheet) , and all the buttons will become active agai, allowing you to resubmit the timesheet. 


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Tuesday, April 21, 2015 5:43 PM
  • Hi Johnny,

    Seems issue related to "Assignment Accepted, Time Rejected" scenario. Next option would be to modified effort in Time sheet line (Rejected task) and resubmit Time sheet.  This is also bug in 2013 as task has a blank Process Status even though the reported hours to this task were rejected by the Status Manager.  

    Hope this option will fix the issue.

    -------------------------------------------------------------------------

    Raushan Kumar |LinkedIn

    Tuesday, April 21, 2015 6:18 PM
  • I have tried this method after researching, by adding any number to the actual for this line, however STILL have Send Timesheet disabled.... I am running out of ideas and this timesheet is driving me nuts. Any other options? I'm not sure why but all timesheets ongoing for this resource has send timesheet disabled.

    Johnny Eltawn, Project Server Admin


    Wednesday, April 22, 2015 4:52 PM