uTorrent running on Vista "system cannot find the path specified" error

    General discussion

  • I have uTorrent running on Vista with a mapped share from WHS as the save point for my downloads. It was running fine, then tonight I added two hard drives to WHS. Now I'm getting the error "The system cannot find the specified path" a few seconds after starting a download. The error does not trigger on files I'm seeding. The path length is pretty short, so my issue does not seem to be addressed by the uTorrent FAQ that deals with this error.

    I'm wondering if the drive extender software is somehow not keeping the files in a consistent state as it moves files around with the new hard drives? Has anyone experienced like behavior? The problem is definitely associated with file writes. I'll check it again later to see if the error goes away after the disks have been in the WHS for awhile.

    Tuesday, March 06, 2007 6:59 AM

All replies

  • I guess its possible that the files have not yet been copied/replicated to relavant section of the new drives.  Or maybe you didnot add the drives correctly
    Tuesday, March 06, 2007 7:35 AM
  • All right, not sure exactly what the problem was, but even though Vista could read the files out of that folder, it couldn't copy from that folder or write to that folder. However, if I RDP'ed into the server, I could copy the offending folders to a new location (using UNC shares, of course), and then Vista could write to the newly created folders fine.

    I have no idea how those folders got corrupted, but I'll be on the lookout for this behavior again.

    Tuesday, March 06, 2007 4:05 PM
  • This problem is still occurring for me. I believe it is related to the problem described in

    This problem is that some files/folders will not copy from WHS to Vista and the error returned is that the directory is invalid. All the files/folders that give that error in uTorrent also give me the described error when copying in Windows Explorer from WHS to Vista.

    Wednesday, March 07, 2007 8:58 PM
  • I just directly leave uTorrent running on WHS , to cause no complication, and have it save into one directory then sort out later. That way also i can shut my personal computer down when not needed, and still have downloading on the server.

    But as for your problem, I really dont know what to tell you, I have saved files to network folders before from uTorrent with ease, but then it was just going to another personal computer of mine. WHS could be a different case. To aid you I will run uTorrent off of this computer and try to save files onto WHS to see if this problem is common or it could be on your end.
    Wednesday, March 07, 2007 11:18 PM
  • Thanks!

    For now I think I'm just going to use a temp folder for unfinished downloads on my Vista computer so uTorrent isn't writing to the WHS share until the download is complete. Hopefully this helps.

    Another problem I've been having that I didn't mention before is corrupted downloads when saving downloading directly to WHS. When the download is done and I run a force-check, it finds a bunch of bad blocks. I only get this corruption when running uTorrent on Vista. When I run uTorrent from XP and download to WHS, there are no problems whatsoever.

    So odd...

    Thursday, March 08, 2007 12:52 AM
  • That is very odd.. I've ran uTorrent consistently on Vista , to save onto WHS for nearly a day now. As far as I can tell everything has saved correctly with no errors. I stress "as far as I can tell" because I havent actually went in there to see if the downloads are ok and not corrupted, but once i do this task, I will know.
    Thursday, March 08, 2007 6:48 PM
  • Thank you so much for your effort. Yeah, what happens when you stop the torrent and do a force check from within uTorrent?
    Thursday, March 08, 2007 8:30 PM