A SQL Server error occurred... RRS feed

  • Question

  • Hi,

    One of my users has come across a less than helpful error using the CRM 4.0 Outlook Client.  He tracks emails using the tool and has been doing so without error.  He did initially come across the ampersand (&) issue after the upgrade so I installed that hotfix (http://support.microsoft.com/kb/949719) and fixed the problem.  He is now seeing this error when he attempts to track a specific email (in other words it's only this one email...The error doesn't appear for other emails).  He opens the email in Outlook, clicks Track in CRM and sees the following popup message:

    A SQL Server error occurred.  Try this action again.  If the problem continues check the Microsoft Dynamics CRM Community for solutions or contact your organization's
    Microsoft Dynamics CRM Administrator.  Finally, you can contact Microsoft Support.

    There is nothing special about the email.  There are no attachments and no strange characters in either the subject or any of the addressees names or email addresses.

    It would be useful, seeing as this is a SQL Server error, to know what the actual error is but there doesn't seem to be a way of finding that out.

    I have tried closing Outlook and the CRM client and restarting them...No good.

    Any ideas..?

    Tuesday, October 14, 2008 5:01 AM


All replies

  • Hi Jack,


    Have you checked the event log on the PC running the outlook client.

    Tuesday, October 14, 2008 8:39 AM
  • Jack,


    Is this user running the offline client or online only?


    If the offline client, it could be an error with the local SQL Express database, in this case, as already suggested, check the event log on the pc.


    Also, check the event log on your SQL server--could be something there.


    Tuesday, October 14, 2008 10:19 AM
  • Thanks Jacques / Joel for your input,

    I had checked the event log and it wasn't all that helpful.  It suggested restarting Outlook which was the first thing I tried.  I also came across an article which mentioned it could be the length of the Message Id field but I had already made that bigger due to an earlier issue, and the Message Id of the offending email is quite short.

    I have noticed that the Message Id contains a percentage symbol (%) and am wondering if that could be a problem..?  The event log text is:

    Event Type:        Error

    Event Source:    MSCRMAddin

    Event Category:                None

    Event ID:              5983

    Date:                     21/10/2008

    Time:                     2:52:28 PM

    User:                     N/A

    Computer:          GARETHFINNIE


    An error occurred while promoting a Microsoft CRM e-mail message.  Restart Microsoft Outlook and try again. HR=0x80044150. Context=. Function=CMailItemHelper::HrPromoteMailItemInCrm. Line=1643.


    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    And the message headers are:

    Microsoft Mail Internet Headers Version 2.0

    Received: from mail138.messagelabs.com ([]) by mail.ermgroup.com.au with Microsoft SMTPSVC(6.0.3790.3959);

                     Tue, 21 Oct 2008 14:37:01 +1000

    X-VirusChecked: Checked

    X-Env-Sender: john.jcl@bigpond.com

    X-Msg-Ref: server-11.tower-138.messagelabs.com!1224563818!54398566!1

    X-StarScan-Version:; banners=-,-,-

    X-Originating-IP: []

    Received: (qmail 18860 invoked from network); 21 Oct 2008 04:36:59 -0000

    Received: from nschwmtas03p.mx.bigpond.com (HELO nschwmtas03p.mx.bigpond.com) (

      by server-11.tower-138.messagelabs.com with SMTP; 21 Oct 2008 04:36:59 -0000

    Received: from nschwotgx02p.mx.bigpond.com ([])

              by nschwmtas03p.mx.bigpond.com with ESMTP

              id <20081021043657.SZNZ1796.nschwmtas03p.mx.bigpond.com@nschwotgx02p.mx.bigpond.com>;

              Tue, 21 Oct 2008 04:36:57 +0000

    Received: from [] by nschwotgx02p.mx.bigpond.com with ESMTP

              id <20081021043655.WMPT21966.nschwotgx02p.mx.bigpond.com@[]>;

              Tue, 21 Oct 2008 04:36:55 +0000

    User-Agent: Microsoft-Entourage/

    Date: Tue, 21 Oct 2008 15:34:13 +1000

    Subject: Re: Holmesglen RFT CRM:00053160

    From: John Lowen <john.jcl@bigpond.com>

    To: Terry McCauley <tmccauley@ermpower.com.au>

    CC: Gareth Finnie <gfinnie@ermpower.com.au>,

                    David Guiver <dguiver@ermpower.com.au>

    Message-ID: <C523A6F5.8C53%john.jcl@bigpond.com>

    In-Reply-To: <705B22D2F093ED40A44A2BA80B723C4001DDB4C4@river-exchange.ERM.local>

    Mime-version: 1.0

    Content-type: multipart/alternative; boundary="B_3307448160_4473798"

    X-RPD-ScanID: Class unknown; VirusThreatLevel unknown, RefID str=0001.0A150201.48FD5C69.0097,ss=1,fgs=0

    Return-Path: john.jcl@bigpond.com

    X-OriginalArrivalTime: 21 Oct 2008 04:37:01.0866 (UTC) FILETIME=[A950B8A0:01C93336]



    Content-type: text/plain; charset="ISO-8859-1"

    Content-transfer-encoding: quoted-printable



    Content-type: text/html; charset="ISO-8859-1"

    Content-transfer-encoding: quoted-printable




    Tuesday, October 21, 2008 5:24 AM
  • There appears to be a bug tracking emails with a message id containing a percentage symbol.  Has anyone else come across this or can someone from MS please look into this..?  Where can a log a bug with MS..?
    Monday, October 27, 2008 10:29 PM
  • Hi


    I just wondered if you resolved the problem whereby when tracking some but not all emails you get the error "A SQL Sever error occurred". I hve just upgraded to CRM 4 and have started getting this.


    Many thanks



    Tuesday, November 11, 2008 5:30 PM
  • TDS,


    Did you escalate this to Microsoft Support?




    Tuesday, November 11, 2008 10:09 PM
  • Thanks for the response. Yes this is being looked into now. I shall let you know if I get a resolution.





    Wednesday, November 12, 2008 9:02 AM
  • We are having same problem with a customer of us as well...


    Some mails are just not trackable. When you forward them to yourself you can track it...


    I guess this is because the internetheader of the email message dissappears when you forward to yourself.


    So something is wrong with certain email headers.


    This is the one where it fails for me to track it:


    Microsoft Mail Internet Headers Version 2.0

    Received: from cp3.superservers.be ([]) by xxxxx.com with Microsoft SMTPSVC(6.0.3790.3959);

                     Thu, 30 Oct 2008 11:09:18 +0100

    Received: from [] ( [])

                    (authenticated bits=0)

                    by cp3.superservers.be (8.13.1/8.13.1) with ESMTP id m9UA9Ff8005241;

                    Thu, 30 Oct 2008 11:09:15 +0100

    Mime-Version: 1.0 (Apple Message framework v753.1)

    To:  xxxxx xxxxx <xxxxx.xxxxx@xxxxx.xxxxx>

    Message-Id: <9EC078F2-932D-4B26-87E2-3B975B276EBC@xxxxx.xxxxx>

    Content-Type: multipart/alternative; boundary=Apple-Mail-17-93534987

    Cc: xxxxx xxxxx <xxxxx.xxxxx@xxxxx.xxxxx>

    Subject: Display XXXX

    From: xxxxx xxxxx <xxxxx.xxxxx@xxxxx.xxxxx>

    Date: Thu, 30 Oct 2008 11:09:14 +0100

    X-Mailer: Apple Mail (2.753.1)

    Return-Path: xxxxx.xxxxx@xxxxx.xxxxx

    X-OriginalArrivalTime: 30 Oct 2008 10:09:18.0737 (UTC) FILETIME=[92559010:01C93A77]



    Content-Transfer-Encoding: quoted-printable

    Content-Type: text/plain;





    Content-Type: multipart/mixed;




    Content-Transfer-Encoding: quoted-printable

    Content-Type: text/html;




    Content-Transfer-Encoding: base64

    Content-Type: application/pdf;


                    name=Display XXXX 1.pdf

    Content-Disposition: inline;

                    filename="Display XXXX 1.pdf"



    Content-Transfer-Encoding: quoted-printable

    Content-Type: text/html;









    There are no event logs on the server side, The only problem i could see is that the Message ID contains '-' signs

    But i dont know if something is wrong with that.



    Or perhaps this:


    Content-Type: application/pdf;


                    name=Display XXXX 1.pdf

    Content-Disposition: inline;

                    filename="Display XXXX 1.pdf"



    PS: I changed personal information by the xxxx

    Monday, November 17, 2008 8:43 AM

    Another untrackable header, This mail doesnt contains any attachment just normal text. After forwarding this mail to own inbox, so that the header disappears, it works without any error.

    Again the message ID contains a '-':


    Microsoft Mail Internet Headers Version 2.0
    Received: from mc28.lon.server.colt.net ([]) by xxxx.xxxx with Microsoft SMTPSVC(6.0.3790.3959);
         Mon, 10 Nov 2008 18:04:49 +0100
    Received: from mail.gevers.com (mail.gevers.com [])
        by mc28.lon.server.colt.net (Postfix) with ESMTP id B282B790E
        for xxxxx.xxxxx@xxxxx.xxxxx; Mon, 10 Nov 2008 17:04:48 +0000 (UTC)
    Received: from s0003-gexch2.gevers.com ([]) by mail.gevers.com with Microsoft SMTPSVC(6.0.3790.3959); Mon, 10 Nov 2008 18:02:50 +0100
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4133
    Content-Class: urn:content-classes:message
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    Subject: RE: licence xxxx:xxxx
    Date: Mon, 10 Nov 2008 18:02:50 +0100
    Message-ID: <D92E541D66AE0E45A08C8EFB59E8D28507275347@xxxxx-xxxxx.xxxxx.xxxxx>
    In-Reply-To: <0FCF54C9385603408FD2F311521126AD50F0CC@xxxxx.xxxxx>
    Thread-Topic: licence xxxx:xxxx
    thread-index: AckkmAWTL+H9ckXIRk+CVvZsUdYF7wAmS6eAAKJTSTAAyyNO0AAALFxAAABhhCAFddGGcAClJ2Fg
    References: <xxxxx.xxxxx@xxxxx.xxxxx>

    <D92E541D66AE0E45A08C8EFB59E8D285072751E1@xxxxx.xxxxx> <0FCF54C9385603408FD2F311521126AD432FD8@xxxxx.xxxxx> <D92E541D66AE0E45A08C8EFB59E8D28507275238@xxxxx.xxxxx> <0FCF54C9385603408FD2F311521126AD50E7F8@xxxxx.xxxxx> <D92E541D66AE0E45A08C8EFB59E8D28507275239@xxxxx.xxxxx> <0FCF54C9385603408FD2F311521126AD50F0CC@xxxxx.xxxxx>
    From: "xxxxx xxxxx" <xxxxx.xxxxx@xxxxx.xxxxx>
    To: "xxxxx xxxxx" <xxxxx.xxxxx@xxxxx.xxxxx>
    X-OriginalArrivalTime: 10 Nov 2008 17:02:50.0863 (UTC) FILETIME=[2A0EC7F0:01C94356]
    Return-Path: xxxxx.xxxxx@xxxxx.xxxxx

    Content-Type: text/plain;
    Content-Transfer-Encoding: quoted-printable

    Content-Type: text/html;
    Content-Transfer-Encoding: quoted-printable


    Monday, November 17, 2008 8:53 AM

    I guess the '-' sign in the Message-ID is not the cause of the problem cause other emails which contain a '-' in there header are trackable...


    It must be something else, but i have no idea anymore where to look

    Monday, November 17, 2008 8:58 AM

    Hi we are experiecing this problem too. What we have noticed is that this occurs when another users has tracked the e-mail.


    This is what is happening.


    1) User 1 tracks an e-mail to Customer X and copies (CC) User 2.

    2) In Outlook User 2 does not see the e-mail as tracked no CRM icon next to the e-mail.

    3) User 2 attempts to track the e-mail.


    SQL error appears.


    Any fix for this?




    Monday, November 17, 2008 11:44 AM
  • mm thats not the problem here... what happens when user2 forwards the mail (where the SQL Error appears) to his own inbox, and then try to track that new email?



    Tuesday, November 18, 2008 1:04 PM

    He manages to track it then.


    I cannot understand what is going on Sad


    I cannot even find and error in the logs on the SQL server, client PC or CRM server.


    This is really frustrating and staff are not tracking e-mails anymore.


    Does anyone have a solution or a way to find out whta the error is.



    Tuesday, December 2, 2008 8:48 AM
  • http://www.microsoft.com/downloads/details.aspx?FamilyId=57C6267B-3B13-49DD-BFED-3CC83633AEA7&displaylang=en


    Installing this Server + Email Router update & the client update on the clients computer has solved the problem


    It as actually solved by this KB:



    But this KB is included in the Update Rollup 1 for Microsoft Dynamics CRM 4.0 (first link)

    Wednesday, December 3, 2008 10:27 AM
  • HI

    Can you possibly share the resolution to this issue, I am experiencing this and no one seems to have an answer to why this happens? It always when using the Track in or set regarding option and it only occurs for some users.

    Thank you


    Thursday, August 26, 2010 10:56 AM
  • This is an update for people like me who came here looking for an answer and did not find one -  The resolution for me is written here in detail




    Hope it can help somebody as I will never get that time back!



    • Proposed as answer by TD-CRM Tuesday, August 23, 2011 9:47 AM
    Friday, May 27, 2011 4:03 PM