locked
WHS wont restore my system RRS feed

  • Question

  • I had a problem where all of a sudden I was receiving BSOD's on a client machine.  I tried system restore, and also ran Spinrite (which did not report any flaws on the drive or that it needed to recover any sectors.  I'm running WHS (OEM) power pack 1

    So as a last ditch effort before installing the system from the factory CD, I thought that I should try to restore the SYSTEM from a backup on my WHS from a time that I know that the machine was working.

    Well, 36 hours later and I still can not get the WHS to restore the system.  Here are the things that I have tried so far:

    1) Restore the system using the original WHS restore CD.  With and without the drivers on a USB drive.  Neither option worked.  In this case the system looked like it was going to restore, but the restore time just kept getting longer and longer until finall the restore software gave up.

    2) Download the Dual boot restore software from here: http://www.microsoft.com/downloads/details.aspx?FamilyID=26881305-91cc-4f37-b1fc-3813c423df2c&DisplayLang=en  and tried restoring the system using that software and I got an error stating that the software on the server might be too old...Trying to use older version of the software.  The older version of the restore that it tried to use just hung after selecting the backup version to be restored from.

    Any help on this issue would be greatly appreciated as I really don't want to start from scratch with the Manufacturers CD.
    Friday, December 26, 2008 3:45 PM

All replies

  • Hello,
    the reasons for a failing restore via network can be difficult to determine. That the restore environment tells about different versions, can have to do with the November upgrade for Windows Home Server, while the Dual Boot Restore CD is still on the Power Pack 1 version. Maybe uninstalling the November upgrade from the server would solve that behavior.
    Other than that often network drivers not fully compatible with the recovery environment can make restore a pain.
    You can try to get more up to date drivers (Vista 32 bit should fit), unpack them to an USB drive and use those. Other people had good experience with using an older PCI network card, for which drivers have been included in the recovery environment.
    Finally, if you have a second client PC at your hands, you can try, if the method described in this FAQ allows you a successfull restore.
    Best greetings from Germany and good luck
    Olaf
    Friday, December 26, 2008 4:35 PM
    Moderator
  • Is KB957825 the "November update" to which you were referring?
    Friday, December 26, 2008 5:05 PM
  • Hi,
    yes it is.
    Best greetings from Germany
    Olaf
    Friday, December 26, 2008 7:10 PM
    Moderator
  • Hi,

    So I removed the following from the WHS:

    KB957825 November release

    KB952069
    KB954600
    KB955839
    KB956802
    KB958215
    KB960714

    Because they were shown on a list of fixes that might be dependent on KB57825.

    I then tried to restore the system using new Dual boot CD with and without the drivers on the USB drive, and also with the old (original) WHS Home Computer restore CD and here is what happened.

    Using either of the restore CD's with the drivers from the USB drive caused the system to not be able to recognize the primary partition on the system drive.
    Using either of the restore CD's with the default drivers allowed me to see the primary partition on the system, but failed during the restore process.  The original version of the restore just rebooted the system in the middle of the restore without issuing any error messages and the dual boot CD issued the same message as before about older version of the software being on the server and then when i told it to try to use an older version, it hung and would not start the restore process.

    Does anyone have any ideas?

    Friday, December 26, 2008 10:12 PM
  • Hi again,
    did you try to delete the volume to which you wish to restore and recreate it? So you can avoid, that errors in the file system from the old volume are blocking the restore process (given the harddisk is not at fault completely, although you tried to exclude this scenario with your check above).
    Best greetings from Germany
    Olaf
    Saturday, December 27, 2008 12:09 AM
    Moderator
  • Too much time being wasted.  I'm going to revert to manufacturer install CD's.

    I'm very dissapointed that I was not able to get the system restored in a reasonable amount of time using WHS.

    The primary reason I purchased WHS was for the backup and restore abilities.  In my opinion, there is no value in WHS for this purpose based on this experience.  Here is yet another Microsoft product that fails to fulfill on its promises.

    Olaf, thanks for all of your help, but I could have been restored by now had I just started with the Manufacturers CD's.  I'm cutting my losses at this point.
    Saturday, December 27, 2008 3:00 AM
  • I had a similar problem. In my case it was a memory module that went bad in my laptop.

    My Toshiba Laptop was BSOD-ing. I tried to restore the laptop using the WHS backup, but it failed repeatedly. I was very disappointed. I called HP support, and tried several things, but nothing worked.

    It turned out, I had a faulty memory module in the laptop - it just went bad without warning.

    In my case, I was able to remove one memory module in the laptop (it had 2 - 512 MB modules) and I was able to restore. Adding the faulty module caused the errors to recurr. Replacing the faulty module with a new one and all was well again. I took back all the bad things I said about the WHS.

    Could a bad piece of hardware, such as memory or video card be causing your problems?
     

    If your reverting to the manufacturer install CD's fixes the problem, then it would seem to be a "restore problem." IF it doesn't, you may become suspicious of the client's hardware.
    • Marked as answer by Lara JonesModerator Friday, January 23, 2009 9:37 PM
    • Unmarked as answer by MyCroWave Saturday, January 24, 2009 6:35 AM
    Sunday, December 28, 2008 3:09 AM
  • Thanks for sharing your information regarding this disturbing situation. 

    You would think that since one of the selling points of this software is that it is a backup utility, that Microsoft would do everything in their power to be able to restore a system, and in cases where they can not, the software would, at a minimum, tell you EXACTLY why it can not perform the restore so that we could come to a quick resolution as opposed to being relegated to trial and error experimentation.  I lost a whole day trying to get the restore to work properly before giving up.  I realize that this was partially my fault for not giving up sooner, but it would have been much more convenient if I were able to get the restore to work.

    I guess it is possible that there is a bad memory module however, consider this:

    Since restoring the system using the factory CD, there have been no further problems with the system.  Everything has been working correctly.

    With that said, though, to be on the safe side, I'll run a memtest on it today just to be sure.
    Tuesday, December 30, 2008 1:59 PM
  • Memtest never came up with anything.  While the answer above was checked as an answer, it was not the answer to my problem.  Perhaps it was the answer to theirs.
    Saturday, January 24, 2009 6:35 AM
  • MyCroWave said:

    Memtest never came up with anything.  While the answer above was checked as an answer, it was not the answer to my problem.  Perhaps it was the answer to theirs.

    Hi,

    Please submit a bug on Connect and include the following:

    1. Server side CABs. You will find information regarding how to submit CABs to Microsoft here.
    2. Add two files named "HomeServerPCRestore.log" and "HomeServerPCRestore_Update.log" at the root of a USB flash key and place the USB key in the client machine during restore. Restore looks for those files and will log to them when found. Attach these files to the bug report.

    Thank you


    Lara Jones [MSFT] | Program Manager
    Community Support and Beta | Windows Home Server Team
    Windows Home Server Team Blog
    Connect Windows Home Server
    Windows Home Server
    Saturday, January 24, 2009 8:16 PM
    Moderator
  • This issue was a month ago.  I no longer have that information.

    Had you been more responsive when I was having the problem, I would have been more than happy to submit the information that you requested.

    Sunday, January 25, 2009 2:37 PM