none
MVC - sample got nuget version missmatch - Okta integration RRS feed

  • Question

  • I am a newbie in MVC

    I am trying to build an internet facing site in MVC 5 with Okta integration (only for login as users need not to remember new user Id and password for this site)

    I downloaded example from this location https://github.com/rlondner/okta-msoidc-sample

    run couple of commands to install nugets, but ended up with below error not sure now how to uninstall/install correct versions or how can I know which version to install,

    Assembly 'Microsoft.Owin.Security.OpenIdConnect' with identity 'Microsoft.Owin.Security.OpenIdConnect, Version=3.0.1.0, Culture=neutral, PublicKeyToken=null' uses 'Microsoft.IdentityModel.Protocol.Extensions, Version=1.0.3.42, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a higher version than referenced assembly 'Microsoft.IdentityModel.Protocol.Extensions' with identity 'Microsoft.IdentityModel.Protocol.Extensions, Version=1.0.2.33, Culture=neutral, PublicKeyToken=31bf3856ad364e35'    E:\Solutions\POCs\okta-msoidc-sample-master\Okta.Samples.OpenIDConnect.CodeFlow\CSC    Okta.Samples.OpenIDConnect.CodeFlow

    if anyone of you has any sample solution or any resolution of above error pls do share




    • Edited by TheCodeMan8 Friday, May 5, 2017 5:58 AM .
    • Moved by 宝宝徐 Tuesday, May 9, 2017 2:20 AM
    Thursday, May 4, 2017 2:54 PM

All replies

  • Hi PraveenIndia,

    Thank you for posting in MSDN forum.

    This forum is discussing about .Net Framework setup and servicing, since your issue related to MVC and, I suggest you could post in https://www.asp.net/mvc  to get a better help.

    Thanks for your understanding and cooperation.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by 宝宝徐 Friday, May 5, 2017 8:05 AM
    Friday, May 5, 2017 8:04 AM
  • Thanks, I resolved version mismatch issue by using NuGet manager - UI, but now facing another issue posted here, 

    https://forums.asp.net/p/2121017/6135707.aspx?p=True&t=636295678804494166

    • Marked as answer by TheCodeMan8 Friday, May 5, 2017 3:00 PM
    • Unmarked as answer by TheCodeMan8 Friday, May 5, 2017 3:01 PM
    • Proposed as answer by 宝宝徐 Monday, May 8, 2017 1:55 AM
    Friday, May 5, 2017 3:00 PM
  • Hi PraveenIndia,

    Thank you for your update and glad to hear you solved this issue successfully.

    You could mark your reply as answer, so that other community members will be easier to search for your solution. About another question, please wait patiently till the professional engineer help you solve it.

    Thank you for your understanding and cooperation,

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, May 8, 2017 1:54 AM