locked
CRM 2011 - Goal Auto Recalculate Doesn't Work RRS feed

  • Question

  • Hi Forum,

    We have CRM 2011,UR 16 on-premise installation.

    Recently, we started to use Goal management functionality in CRM and hence imported some 100 goals for our sales people through Excel/Import process which was a success.

    For some reason, auto calculation of the goal progress is not working and we have to manually click "Recalculate" ribbon button to see the progress.

    In the System Settings I have checked the roll up frequency setting which is set to 24 hours under "Goals" tab.

    I have also checked the Async services (including maintenance) and they are working fine. (re-started as well).

    In further investigation, I also couldn't find the system job for this purpose. I can see rest of the system job like custom and system workflows but not anything for the goals.

    So just for the testing, I tried to change the roll up frequency to 48 hours from default 24 hours and to my surprise that threw the error and didn't save my change. In the downloaded error log it says:

    asyncoperation With Id = 4d1d25d5-8a71-4e31-bab5-d1866147e5db Does Not Exist

    I googled it but couldn't find any solution to this issue.

    Is there anyone out there who has encountered this type of behaviour.

    I have queried below and that returned 0 records.

    so it seems like that something is not right with Goal Async service but not sure how to fix it.

    Any help would appreciated. Thank you.

    Below query shows no result

    SELECT [MessageName]      
          ,[OperationType]
          ,[RecurrencePattern]
          ,[Name]
          ,[PostponeUntil]      
          ,[RecurrenceStartTime]
          ,[StatusCode]
          ,[AsyncOperationId]
          ,[CorrelationUpdatedTime]
      FROM [XXXXXX_MSCRM].[dbo].[AsyncOperationBase]
     
      WHERE OperationType=40 (this is for Goal)

    I have seen below post as well but I don't seems to have entry for the Goal rollup which is confirmed by above query.

    http://social.microsoft.com/Forums/en-US/c0688905-7238-4ae3-81f3-2dd0a96e31ba/goal-recalculate?forum=crm

    Any help would be greatly appreciated.

    -H.Desai

    Wednesday, October 1, 2014 2:11 AM

All replies

  • Any One ?

    Thursday, October 2, 2014 10:36 PM
  • sorry, not familiar with goal calculation. Async operations table gets cleaned up periodically. So a record missing does not mean the system job never executed. regards Jithesh
    Thursday, October 2, 2014 10:55 PM
  • Hi Jithesh,

    Thanks for your reply.

    To me, not able to change the goal frequency default period (24 hours) is a bigger worry.

    Running that query in UAT returns single record for goal roll up job and I can change the frequency to 48 hours from 24 hours and this change is visible in the query result.

    My understanding is, when CRM is installed a default record gets created with default roll up frequency to 24. When system admin changes this default value

    to something else through UI, it gets reflected in this table row.

    Because this record is missing in the production system, I can't change the default roll up frequency and therefore goal recalculation doesn't work.

    See attached screenshot from our UAT system for the same query. I have do idea how to bring back this record in to our production system which I am very sure will fix this issue.

    (Don't want to play with my production SQL with direct update)

    Regards,

    H.Desai





    • Edited by H.Desai Thursday, October 9, 2014 10:13 PM
    Thursday, October 9, 2014 10:04 PM
  • Hi All,

    Updated the system up to the roll up 18 but to no avail.

    Still clueless on this.

    Anyone out there?

    Regards,

    H.Desai

    Thursday, November 6, 2014 8:29 PM
  • Hi,

    In an effort to try and change the time of day the goal calculation job runs, I tried to update it and set the asyncoperation.recurrenceStartTime property through the SDK (should be supported, right?). But the result was that the job was completely removed from the system, and now I have the same problem as you. System settings throws an error, and the goals aren't being calculated.

    The guid in my environment for this job was the same as you have, so apparently it should be the same for every organization. I even tried to create a new, similar job with the same guid through the SDK, and it was created but did nothing to the goals.

    Fortunately this was in my dev env, so everything still works in test and production.

    I'm on rollup 14.

    Don't know if this is of any help, but I would like to know how to bring it back too. Reinstall? Enable/disable org? Call Microsoft support?

    regards, T

    Wednesday, November 12, 2014 11:24 AM
  • Hi,

    Interesting to hear that changing frequency value using SDK can eliminate the record completely. I am sure you are using the right SDK message on this operation. (and I am  sure it's supported via SDK too. though I haven't tried this way).

    Have you tried to change the frequency through UI after creating "Goal Roll Up Job" record through SDK. Does my above mentioned query return any record?

    Unfortunately, there is not much information about how to repair this in either SDK or on the web and that's why I have posted this on forum. I doubt enabling/disabling Org will be of any help here. We might have to reinstall Asyncservice  or call for MS support as a last option.

    My problem is on production system and that's why bit hesitate to take any hasty action without getting into root of the issue.

    I will update this space if I come across any solution.

    Thanks for sharing your experience.

    Regards,

    H.Desai





    • Edited by H.Desai Wednesday, November 12, 2014 10:00 PM
    Wednesday, November 12, 2014 9:43 PM
  • Hi All,

    It's been more than 6 months I am looking out for the solution of this problem and unfortunately still no luck.

    Trying one more time with forum to see if anyone else has similar experience. It's still CRM 2011 system with roll up 18 but to my knowledge nothing has changed in Goal functionality in CRM 2015 (Will upgrade to 2015 in 6 months time)

    Regards,

    H.Desai

    Tuesday, June 2, 2015 12:21 AM
  • Hi Forum,

    Bumping up this question to get attention of someone who has any idea on this issue.

    Thanks,

    H.Desai

    Friday, September 11, 2015 12:14 AM
  • I am experiencing the same issue with a client right now... In the DEVELOPMENT machine I can see the "Goal Rollup" record in the AsyncOperationBase table, but for some reason that record is not present in the UAT or PRODUCTION environment.  No idea yet about how to fix it without directly touching the SQL database.

    The client is CRM 2013 SP1.

    Tuesday, September 22, 2015 10:07 PM